バージョン管理システム subversionについて語ろう。
バージョン管理システムの一つにCVSがあるが、ディレクトリの移動の管理や
ネットワーク対応などでやや難がある。
これらCVSの問題点を解決すべく開発されているのがSubversionである。
オープンソースソフトウェアの開発においてはCVSが多く使われているが、
Subversionを利用するオープンソースプロジェクトも急速に増えている。
subversion バージョン管理【サブバージョン】
■ このスレッドは過去ログ倉庫に格納されています
1犬板
2006/08/04(金) 23:33:16ID:aMGjnjPK2008/11/05(水) 11:14:23ID:+aQcOaz1
122120
2008/11/05(水) 14:49:33ID:lxwRaWIS エラーが出るパターンがわかりました
他の人がインポートしたプロジェクトはリビジョンを比較できますが、
自分がインポートしたプロジェクトはエラーが出て見れません
他の人がインポートしたプロジェクトはリビジョンを比較できますが、
自分がインポートしたプロジェクトはエラーが出て見れません
2008/11/07(金) 10:54:10ID:2FcnhWy1
Apache + DAV のAutoversioning環境で、pre-commit でエラーを返しても
PUTに201を返してしまって、ユーザに成功したかのように見えてしまうんですが
INTERNALSERVERERRORなどを返すのが正しいと思うけど
そんな設定が見あたらなくてこまってます
誰か知りませんか?
PUTに201を返してしまって、ユーザに成功したかのように見えてしまうんですが
INTERNALSERVERERRORなどを返すのが正しいと思うけど
そんな設定が見あたらなくてこまってます
誰か知りませんか?
2008/11/07(金) 14:11:28ID:DhmwtaXY
コマンドを全角で書いているとか?w
2008/11/07(金) 18:48:51ID:18Y7n3w8
>>124
wいやいや。
wいやいや。
2008/11/14(金) 11:41:28ID:MYTniDsA
svk mirrorでうっかりsvnリポジトリのパスをtypoしちまったのだが、これ直すのどうすればいい?
svk mirror //hoge http://repos.example.net/repos/typo
とかしてしまって、
svk sync //hoge
したら
HTTP Path Not Found: 〜
といわれる状態です。//hogeにhttp://repos.example.net/repos/hogeを
対応させたいです。
svk mirror //hoge http://repos.example.net/repos/typo
とかしてしまって、
svk sync //hoge
したら
HTTP Path Not Found: 〜
といわれる状態です。//hogeにhttp://repos.example.net/repos/hogeを
対応させたいです。
2009/01/16(金) 22:50:41ID:t2yH3kqH
DAVアクセスで、Windows Explorer にエラーメッセージを渡す方法しりませんか?
2009/01/29(木) 00:11:49ID:IQa3YtuL
129login:Penguin
2009/02/06(金) 15:37:11ID:bcsA7XkK check in するとき、ステータスがAまたはMのものをすべてまとめてコミット〜みたいなことがしたいんですが、そういうことができるコマンドオプションってありませんでしょうか??
ご教示をばいただきたく><
ご教示をばいただきたく><
2009/02/06(金) 17:49:57ID:cdCEWSvv
>>129
フォルダをコミットすればいいんじゃないか
フォルダをコミットすればいいんじゃないか
2009/02/06(金) 21:50:22ID:z7oT/QBl
引数付けなきゃ全部コミット対象じゃないのか?
2009/02/06(金) 22:57:00ID:BxNHvKiV
2009/02/06(金) 23:21:23ID:Y5rETPvK
ふつーにgrepで絞ってしまうなぁ。
svn add `svn status | grep '^?' | grep -v '~$'`
ぐらい普通に打っちゃう。
svn add `svn status | grep '^?' | grep -v '~$'`
ぐらい普通に打っちゃう。
2009/02/08(日) 04:42:34ID:Mf2yx5KJ
>132
A や M だけ commit したい理由って何?
どーせ設定するときに >133 みたいにする必要があるけど changelist を使うと多少見通しが良くなるかもね。
A や M だけ commit したい理由って何?
どーせ設定するときに >133 みたいにする必要があるけど changelist を使うと多少見通しが良くなるかもね。
135132
2009/02/08(日) 05:01:22ID:Kl2sibex (´・ω・`) しらんがな
129のお題に完全な回答になっていない可能性を示唆しただけやし
129がそんな変則的な事をしたいのかも分からんし
129のお題に完全な回答になっていない可能性を示唆しただけやし
129がそんな変則的な事をしたいのかも分からんし
2009/02/08(日) 16:17:44ID:nAvDCiCa
psvn.el 系なら *A とか *M でできるけどなぁ
137129
2009/02/11(水) 17:28:33ID:j+WRM2eE レスありがとうございます。お礼遅れてすいません。
こういうことやりたい理由は3、4個のファイルを編集してコミットしたいとき、全部打ち込むのが面倒だからです。
>>133
`svn status | grep '^?' | grep -v '~$'`
これだと、出力結果が
? a.txt
? b.txt
みたいになって、svnに渡すとエラーが出ませんか??
こういうことやりたい理由は3、4個のファイルを編集してコミットしたいとき、全部打ち込むのが面倒だからです。
>>133
`svn status | grep '^?' | grep -v '~$'`
これだと、出力結果が
? a.txt
? b.txt
みたいになって、svnに渡すとエラーが出ませんか??
2009/02/11(水) 19:48:31ID:RusQM2Nz
>137
cut か awk か sed あたりが必要だね。
cut か awk か sed あたりが必要だね。
139133
2009/02/12(木) 00:45:51ID:Nhgz6WJM あーごめんごめん。awk '{print $2;}' をつけてる。
試さずに書くもんじゃないね‥‥‥。
試さずに書くもんじゃないね‥‥‥。
2009/02/23(月) 23:06:51ID:M8rihguj
リポジトリの名前を変更する事はどうやったらできるんでしょうか
2009/02/24(火) 07:15:42ID:6dEWDwEz
リポジトリに名前ってあった?
リポジトリurlをエイリアスできる機能があったらほしいけど
リポジトリurlをエイリアスできる機能があったらほしいけど
2009/02/24(火) 21:44:12ID:oqLbCHeF
名前はあるけど、FSFS なら普通にサーバー側でリポジトリの
フォルダをリネームするだけじゃないの?
フォルダをリネームするだけじゃないの?
2009/02/24(火) 22:08:07ID:qHM7/ieN
2009/02/25(水) 21:21:21ID:VH+HFvi4
リポジトリからチェックアウトしてコピーファイル置くローカルの作業フォルダだけを
削除したい場合はどうすればよいのでしょうか?
リポジトリにある大元のデータも消したい場合は右クリックのsvnのコマンドから削除
すればよい、というのは分かったのですが、ローカルの作業フォルダだけを消す方法は
分かりませんでした。
削除したい場合はどうすればよいのでしょうか?
リポジトリにある大元のデータも消したい場合は右クリックのsvnのコマンドから削除
すればよい、というのは分かったのですが、ローカルの作業フォルダだけを消す方法は
分かりませんでした。
2009/02/25(水) 21:59:20ID:etuOC5Pv
subversionに右クリックとかないから
2009/02/25(水) 23:00:38ID:8LgvKRme
>>144
普通にOSコマンドで削除すればいいだけだと思うが。
普通にOSコマンドで削除すればいいだけだと思うが。
2009/02/25(水) 23:08:45ID:ow53GHL8
rm -rf $HOME/.*
2009/02/28(土) 16:45:56ID:JxODMXVc
Subversion 1.5.6 って,どんなバージョンアップですか。
教えて英語得意な人。
教えて英語得意な人。
2009/02/28(土) 16:51:56ID:MuoceZfx
ちょっとしたバージョンアップだ
2009/02/28(土) 16:58:37ID:JxODMXVc
>>150
ありがとう。
ありがとう。
2009/05/10(日) 14:18:27ID:R56D1N/a
Visualsvnに関する質問はスレチでしょうか?
2009/05/10(日) 16:23:37ID:l3u8uj0x
>>152
他いけ
他いけ
2009/05/10(日) 19:26:35ID:R56D1N/a
>>153
チッ
チッ
2009/05/10(日) 22:02:07ID:6t5VOjiz
> TortoiseSVN 1.6.2, built against Subversion 1.6.2. Released 9. May 2009.
なのに
> The latest release of Subversion is 1.6.1.
珍しいこった
なのに
> The latest release of Subversion is 1.6.1.
珍しいこった
2009/05/20(水) 12:29:48ID:8MQk2QWP
EclipseのプラグインはSubversiveでいいの?
2009/05/20(水) 21:00:06ID:U+Qhox8w
158login:Penguin
2009/07/01(水) 08:58:34ID:LpPrGwNO MacOSX上ではGUIでまともに使えないのか。
CUIにがて。
CUIにがて。
159login:Penguin
2009/07/06(月) 19:28:31ID:vfHIXM1C160login:Penguin
2009/09/06(日) 18:20:00ID:p9qlQ2nj >>158
開発環境ならXcode、Eclipse
単体ソフトならVersions、Cornerstone
Finder拡張ならSCPlugin
Path Finderも対応してる。
Cent OS 5に、Subversion 1.6.5をインストールしたのですが、
Apacheのmod_dav_svn.soの読み込みが、下のエラーで成功しません。
どなたか解決方法ご存知の方よろしくお願いします。
apachectl: Configuration syntax error, will not run "restart":
httpd: Syntax error on line 206 of /etc/httpd/conf/httpd.conf: Cannot load /usr/lib/httpd/modules/mod_dav_svn.so into server: /usr/lib/httpd/modules/mod_dav_svn.so: undefined symbol: svn_log__update
開発環境ならXcode、Eclipse
単体ソフトならVersions、Cornerstone
Finder拡張ならSCPlugin
Path Finderも対応してる。
Cent OS 5に、Subversion 1.6.5をインストールしたのですが、
Apacheのmod_dav_svn.soの読み込みが、下のエラーで成功しません。
どなたか解決方法ご存知の方よろしくお願いします。
apachectl: Configuration syntax error, will not run "restart":
httpd: Syntax error on line 206 of /etc/httpd/conf/httpd.conf: Cannot load /usr/lib/httpd/modules/mod_dav_svn.so into server: /usr/lib/httpd/modules/mod_dav_svn.so: undefined symbol: svn_log__update
2009/09/06(日) 18:53:25ID:HbMaguit
Syntax Errorってんだから該当箇所(206行め)を提示するのが筋。
2009/09/06(日) 19:11:01ID:4V79/gLg
>>160
「mod_dav_svn.soのモジュールのロード時に、svn_log_updateってシンボル (=エントリポイント) が無い」ってエラーが出てるね。
どうやってインストールしたの? CentOS 5.xにはSubversion 1.6.xは用意されていないだろうから、
DAG Repository使ったの? それとも自前でビルドした? 他のOSのRPMを無理矢理入れた?
「mod_dav_svn.soのモジュールのロード時に、svn_log_updateってシンボル (=エントリポイント) が無い」ってエラーが出てるね。
どうやってインストールしたの? CentOS 5.xにはSubversion 1.6.xは用意されていないだろうから、
DAG Repository使ったの? それとも自前でビルドした? 他のOSのRPMを無理矢理入れた?
2009/09/06(日) 21:09:41ID:p9qlQ2nj
2009/09/06(日) 21:58:39ID:4V79/gLg
>>163
Apache httpdを自前で入れた
→httpdとSubversionの全てを知るくらいがんがれ。
Apache httpdはCentOSのを使ってる
→(1)開発パッケージ(*-dev)やconfigureのオプションが足りないのでは。がんがれ。
→(2)あきらめてDAG (rpmforge) のmod_dav_svn-1.6.5-0.1いれたら?
Apache httpdを自前で入れた
→httpdとSubversionの全てを知るくらいがんがれ。
Apache httpdはCentOSのを使ってる
→(1)開発パッケージ(*-dev)やconfigureのオプションが足りないのでは。がんがれ。
→(2)あきらめてDAG (rpmforge) のmod_dav_svn-1.6.5-0.1いれたら?
2009/09/06(日) 22:21:14ID:KuFi4KpJ
2009/09/06(日) 23:59:06ID:p9qlQ2nj
>>164-165
rpmforgeからインストール後、httpd.confに
LoadFile /usr/local/apr-util/lib/libaprutil-1.so
LoadFile /usr/local/apr/lib/libapr-1.so
を追加することで成功しました。ありがとうございます。
rpmforgeからインストール後、httpd.confに
LoadFile /usr/local/apr-util/lib/libaprutil-1.so
LoadFile /usr/local/apr/lib/libapr-1.so
を追加することで成功しました。ありがとうございます。
2009/09/24(木) 16:40:31ID:GyboCB1A
誤ってリポジトリを消してしまったんだがどうすればいい?
2009/09/24(木) 17:30:43ID:kKos8gdb
すべてわすれてしまえばいい
2009/09/24(木) 18:53:31ID:dibJlPmu
権限そのままでupdateする方法ないですか?
test.txtのグループがtest ユーザーがuserで、
rootでupdateかけたらユーザーもグループもrootになってしまうのですが、
ユーザーとグループはそのままにしておきたいのです
test.txtのグループがtest ユーザーがuserで、
rootでupdateかけたらユーザーもグループもrootになってしまうのですが、
ユーザーとグループはそのままにしておきたいのです
2009/09/24(木) 20:25:37ID:JfTL1DdE
リポジトリに入れた時点でそういうメタ属性はなくなるので無理。
OSに付いてるアーカイブツールやバックアップツール(tarやdump等)を検討ください。
OSに付いてるアーカイブツールやバックアップツール(tarやdump等)を検討ください。
2009/09/24(木) 21:23:57ID:/waC5kl9
>169
使った事無いけど、contrib にある asvn が使えるかも。
使った事無いけど、contrib にある asvn が使えるかも。
172login:Penguin
2009/10/16(金) 22:21:41ID:rtVctrRo subversionでコミット/チェックアウトする際にあるフォルダやそのサブフォルダを更新の対象から外すことは可能でしょうか。
TortoiseSVNというのをインストールせずに、コマンドで出来ることがあれば教えて頂けないでしょうか。宜しくお願いします。
TortoiseSVNというのをインストールせずに、コマンドで出来ることがあれば教えて頂けないでしょうか。宜しくお願いします。
2009/10/17(土) 00:15:21ID:Khi8KpUf
-N [--non-recursive] : 廃止予定です。--depth=files または
--depth=immediates を使用してください
--depth <ARG> : 操作の対象を深さ <ARG> ('empty'、'files'、
'immediates'、'infinity' のいずれか) に限定しま
す
svn commit helpですぐ出てきたよ
--depth=immediates を使用してください
--depth <ARG> : 操作の対象を深さ <ARG> ('empty'、'files'、
'immediates'、'infinity' のいずれか) に限定しま
す
svn commit helpですぐ出てきたよ
2009/10/17(土) 00:31:25ID:Khi8KpUf
訂正
×svn commit help
○svn help commit
×svn commit help
○svn help commit
2009/10/17(土) 10:46:39ID:P+VUHopA
2009/11/05(木) 23:11:51ID:HajlHzkt
TortoiseSVN の板ってある?
2009/11/07(土) 16:56:49ID:reQ6D8FG
プログラム板の方ならいいんじゃね?
2009/11/12(木) 22:20:23ID:8/5DVSGw
板とスレの区別がつかないなんて
2009/11/12(木) 22:52:12ID:MRzqEEJC
2009/11/24(火) 20:39:34ID:ZSVwfXSk
チェックアウト中に画像の多く含まれるフォルダで止まってしまうんですが、
単体ファイルのサイズが大きいとそういう事あるのでしょうか。
単体ファイルのサイズが大きいとそういう事あるのでしょうか。
2009/11/24(火) 22:44:03ID:3LIsDQPO
亀はバージョンによっては結構タイムアウトするかも
2009/12/02(水) 00:28:36ID:fd1FfZ3I
ttp://terai.xrea.jp/Subversion/WinMerge.html
このページを参考にWinMergeをSubversionのdiffとして使用する設定を行ったのですが
svn diff test.txt
はうまくいきますが
svn diff -r 100 test.txt
はWinMergeのファイル指定のダイアログが表示されうまくいきません。
どうもリビジョン100のファイルが取得できないようです。
どなたか原因がわかる方いらっしゃいませんか?
このページを参考にWinMergeをSubversionのdiffとして使用する設定を行ったのですが
svn diff test.txt
はうまくいきますが
svn diff -r 100 test.txt
はWinMergeのファイル指定のダイアログが表示されうまくいきません。
どうもリビジョン100のファイルが取得できないようです。
どなたか原因がわかる方いらっしゃいませんか?
2009/12/02(水) 01:50:49ID:fd1FfZ3I
182です。
すみません、ここはLinux板でした。
移動します。
すみません、ここはLinux板でした。
移動します。
184login:Penguin
2010/01/28(木) 19:09:05ID:pMN7rp65 post-commitでupdateかかったパスを取得できないでしょうか。
そのパス以下のみsvn ?upしたいのですが。
全体やるとえらい時間かかるので・・。
そのパス以下のみsvn ?upしたいのですが。
全体やるとえらい時間かかるので・・。
185login:Penguin
2010/01/28(木) 22:08:55ID:78GFY+QQ svnで、現在のリビジョン番号を取得する方法はないでしょうか。
svn info -r base
で表示されるリビジョン番号を取得して、それを引数にプログラムを起動したいのです。
svn info -r base
で表示されるリビジョン番号を取得して、それを引数にプログラムを起動したいのです。
2010/01/28(木) 23:28:37ID:ue/5FY9H
>184
svnlook changed 使えば?
>185
その svn info -r base の出力結果を解釈するんじゃ駄目なのか?
svnlook changed 使えば?
>185
その svn info -r base の出力結果を解釈するんじゃ駄目なのか?
2010/02/10(水) 03:50:21ID:dPpKE6PU
subversionが作成する管理フォルダ .svn 以下全てのパーミッションを
drwxrwxrwxにしたいのですが、どうすれば可能でしょうか。
drwxrwxrwxにしたいのですが、どうすれば可能でしょうか。
188login:Penguin
2010/02/10(水) 08:55:54ID:ckhwuPgW プロジェクトのルートで
$ find . -name .svn -type d -exec chmod -v 777 '{}' +
Linuxなら使えると思うけど、もし最後の + が使えなかったら
$ find . -name .svn -type d -print | xargs chmod -v 777
$ find . -name .svn -type d -exec chmod -v 777 '{}' +
Linuxなら使えると思うけど、もし最後の + が使えなかったら
$ find . -name .svn -type d -print | xargs chmod -v 777
189login:Penguin
2010/02/10(水) 08:56:46ID:ckhwuPgW あ、「以下すべて」か。chmod に -R オプションも付けて。
2010/02/10(水) 09:59:54ID:M1khvjc5
phpでフォルダ作成のプログラムを使用しているのですが、
所有者とグループがapacheになってしまいます。
svn add ./****** したときに作成される.svnのパーミッションが
777にはならないでしょうか。
191login:Penguin
2010/02/10(水) 10:17:57ID:KJX+qOU+ umask 000
2010/02/10(水) 15:22:48ID:whMNNUoE
svn addしたときにumask 000 すればいいのでしょうか。
それともmkdirしたとき?
それともmkdirしたとき?
193login:Penguin
2010/02/10(水) 15:49:17ID:KJX+qOU+ ひょっとして chmod ug+s とかかも?
2010/02/23(火) 23:40:13ID:kVGIcis2
すいません。
ここの住人でリポジトリが巨大になってチェックアウトや更新が
途中で失敗する症状になった方はおられませんか?
今、リポジトリが20Gバイトくらいでチェックアウトした
ワーキングコピーは40G、ファイル数が3万程度です。
checkout中topで眺めていると、apacheがメモリとスワップ領域を食いつぶしたところで
停止しているようです。
更新を繰り返せばいいのですが、なんだかスッキリしません。
サーバーはubuntu server9.10,memory2GByte,apache2、subversion1.6です。
apacheがメモリにキャッシュ?してるかな?
ここの住人でリポジトリが巨大になってチェックアウトや更新が
途中で失敗する症状になった方はおられませんか?
今、リポジトリが20Gバイトくらいでチェックアウトした
ワーキングコピーは40G、ファイル数が3万程度です。
checkout中topで眺めていると、apacheがメモリとスワップ領域を食いつぶしたところで
停止しているようです。
更新を繰り返せばいいのですが、なんだかスッキリしません。
サーバーはubuntu server9.10,memory2GByte,apache2、subversion1.6です。
apacheがメモリにキャッシュ?してるかな?
2010/02/27(土) 11:30:13ID:ZoX9kyv0
64bitと32bitで試しましたが変化なし。
おっきいバイナリをsubversionで扱うのは良くないのか。
おっきいバイナリをsubversionで扱うのは良くないのか。
2010/02/27(土) 18:46:10ID:Th2KkYpB
鯖側はわからないけれど、
クライアントが Windows の亀の場合、
checkout したり update したりすると、
タイムアウトで切れることはあるかな。
ワーキングコピーは 20G くらい。
クライアントが Windows の亀の場合、
checkout したり update したりすると、
タイムアウトで切れることはあるかな。
ワーキングコピーは 20G くらい。
197login:Penguin
2010/02/28(日) 01:08:07ID:74fup2Wj 失礼、お知恵をお貸しください。
webdav経由でアクセスさせる時の認証の設定をすると403が出るようになりました。
http://g-chan.dip.jp/square/archives/2008/02/subversionwebdav.html
http://ryus.co.jp/modules/wordpress/index.php?p=278
は探し出せましたが、どうもこの問題とは違うようです。
※前者はちゃんとディレクトリを指定しても403がでました
後者はブラウザでのアクセスでもダメだったので問題が違うようです。
apacheのerror_logにも「Access denied」以外のログは特に残っていないようです。
また、認証関係の設定を削るとアクセスできるので、subversionそのものは動いているようです。
以上、お心当たりがありましたらご指摘ください。
必要なら設定を晒しますので、「ここ見せろ」と言ってもらえれば幸いです。よろしくお願いします。
webdav経由でアクセスさせる時の認証の設定をすると403が出るようになりました。
http://g-chan.dip.jp/square/archives/2008/02/subversionwebdav.html
http://ryus.co.jp/modules/wordpress/index.php?p=278
は探し出せましたが、どうもこの問題とは違うようです。
※前者はちゃんとディレクトリを指定しても403がでました
後者はブラウザでのアクセスでもダメだったので問題が違うようです。
apacheのerror_logにも「Access denied」以外のログは特に残っていないようです。
また、認証関係の設定を削るとアクセスできるので、subversionそのものは動いているようです。
以上、お心当たりがありましたらご指摘ください。
必要なら設定を晒しますので、「ここ見せろ」と言ってもらえれば幸いです。よろしくお願いします。
198197
2010/03/01(月) 14:48:29ID:pUNPJEo9 失礼、解決しました。
問題はAuthzSVNAccessFileの内容だったようです。
/etc/httpd/conf.d/subversion.confではSVNPathとせずSVNParentPathでリポジトリの親ディレクトリを指定していたのですが、
その場合はAuthzSVNAccessFileで指定するファイルでは、配下にあるリポジトリの名前を明示的に指定してアクセス権限を指定してやらないといけないのですね。
リポジトリ直下においたファイルをAuthzSVNAccessFileで指定した場合、特にリポジトリを指定しなくても権限が制御できていたので勘違いしていました。申し訳ありません。
以上、ご報告まで。お騒がせして申し訳ありませんでした。
問題はAuthzSVNAccessFileの内容だったようです。
/etc/httpd/conf.d/subversion.confではSVNPathとせずSVNParentPathでリポジトリの親ディレクトリを指定していたのですが、
その場合はAuthzSVNAccessFileで指定するファイルでは、配下にあるリポジトリの名前を明示的に指定してアクセス権限を指定してやらないといけないのですね。
リポジトリ直下においたファイルをAuthzSVNAccessFileで指定した場合、特にリポジトリを指定しなくても権限が制御できていたので勘違いしていました。申し訳ありません。
以上、ご報告まで。お騒がせして申し訳ありませんでした。
2010/03/01(月) 16:22:45ID:8PcUbKJH
よきにはからえ。
2010/03/03(水) 07:34:23ID:z9Y2wXVN
巨大なリポジトリ(repo)があります。
その配下にAAA,BBB,CCC,DDD・・・などフォルダが4,000ぐらいあります。
今まではrepoを全てcheckoutして作業していたのですが、
checkoutにかなり時間を要するので、BBBとDDDセットでcheckoutなど
を考えています。
しかし、個別のフォルダをcheckoutすると、コミット時にフォルダごと
個別にしなければいけません。
かなり手間なのでいい方法はありませんでしょうか。
/repo
L AAA
L BBB
L CCC
L DDD
・
・
・
その配下にAAA,BBB,CCC,DDD・・・などフォルダが4,000ぐらいあります。
今まではrepoを全てcheckoutして作業していたのですが、
checkoutにかなり時間を要するので、BBBとDDDセットでcheckoutなど
を考えています。
しかし、個別のフォルダをcheckoutすると、コミット時にフォルダごと
個別にしなければいけません。
かなり手間なのでいい方法はありませんでしょうか。
/repo
L AAA
L BBB
L CCC
L DDD
・
・
・
2010/03/03(水) 08:20:56ID:+HQ54dyD
2010/03/03(水) 19:30:20ID:qtlV0RN6
svn commit /repo/{BBB,DDD} のどこが不服なのか。
2010/03/03(水) 21:10:26ID:z9Y2wXVN
>202
そのようなやり方があったのですね。
知りませんでした。参考になります。
repoが大きくなりすぎたので、別のリポジトリを作成し分割も考えています。
その場合は>>201さんが言っている、外部参照をしたいと思うのですが、
分割した場合はパスがずれてしまいます。(webシステムと連動しているので
ややこしい)
4000フォルダをオーバーしても運用上問題なければ分割しなくてもいいのかと
なかなか判断が出来ません。
リポジトリのサーバはlinuxで、クライアントはwindowsです。
ウィンドウズはフォルダが多すぎると開くのに時間がかかってしまいます。
運用のアドバイスをいただければ幸甚です。
そのようなやり方があったのですね。
知りませんでした。参考になります。
repoが大きくなりすぎたので、別のリポジトリを作成し分割も考えています。
その場合は>>201さんが言っている、外部参照をしたいと思うのですが、
分割した場合はパスがずれてしまいます。(webシステムと連動しているので
ややこしい)
4000フォルダをオーバーしても運用上問題なければ分割しなくてもいいのかと
なかなか判断が出来ません。
リポジトリのサーバはlinuxで、クライアントはwindowsです。
ウィンドウズはフォルダが多すぎると開くのに時間がかかってしまいます。
運用のアドバイスをいただければ幸甚です。
2010/03/04(木) 08:07:35ID:m1EChrKM
2010/03/04(木) 18:48:58ID:QEx69d3F
2010/03/04(木) 19:58:06ID:0xVm3n75
cmd.exeの場合は
svn commit "C:\Documents and Settings\repos\BBB" "C:\Documents and Settings\repos\DDD"
みたいに、人間が自分で展開して並べてやる必要がある。
...けど、できる。
svn commit "C:\Documents and Settings\repos\BBB" "C:\Documents and Settings\repos\DDD"
みたいに、人間が自分で展開して並べてやる必要がある。
...けど、できる。
2010/03/04(木) 19:59:53ID:1WE8MgDn
Cygwin 入れちゃえ。
208login:Penguin
2010/03/04(木) 20:03:17ID:CbypfiKi 引数展開を誰がやってるかっていう話だな。
2010/03/05(金) 00:37:11ID:i/dyYoIT
ubuntu サーバ(ubuと呼ぶ)上で subversion のリポジトリを作成し、Windows のファイルサーバ(winと呼ぶ)にバックアップを取ろうとしています。
バックアップの手段としては svnsync を使おうとしています(post-commitで、win 上のリポジトリと同期させたい)。
そのため、win の共有フォルダにバックアップ用のリポジトリを作成しようと、ubu から win の共有フォルダをマウントしましたが、
マウントしたディレクトリ内で svnadmin create をすると「svnadmin: database is locked」というエラーが
出てしまい、リポジトリが作成できません。
ubu 上では apache から DAV でリポジトリにアクセスさせるために、ubu 上のリポジトリには www-data:www-data に
所有権を与え、さらに、win をマウントする時にも uid,gid を www-data の id を指定しています。
windows の共有フォルダをマウントして、その上にリポジトリを作成することはできないのでしょうか?
それとも、何かしらの設定によるものなのでしょうか?
板違い、スレ違い等ありましたら誘導していただければ助かります。
よろしくお願いします。
バックアップの手段としては svnsync を使おうとしています(post-commitで、win 上のリポジトリと同期させたい)。
そのため、win の共有フォルダにバックアップ用のリポジトリを作成しようと、ubu から win の共有フォルダをマウントしましたが、
マウントしたディレクトリ内で svnadmin create をすると「svnadmin: database is locked」というエラーが
出てしまい、リポジトリが作成できません。
ubu 上では apache から DAV でリポジトリにアクセスさせるために、ubu 上のリポジトリには www-data:www-data に
所有権を与え、さらに、win をマウントする時にも uid,gid を www-data の id を指定しています。
windows の共有フォルダをマウントして、その上にリポジトリを作成することはできないのでしょうか?
それとも、何かしらの設定によるものなのでしょうか?
板違い、スレ違い等ありましたら誘導していただければ助かります。
よろしくお願いします。
210209
2010/03/07(日) 16:33:23ID:i2q43V0t2010/03/25(木) 15:50:13ID:Q/OHi20B
fsfs-reshard.py
でリポジトリDBバージョンを2->3にしたらチェックアウト、更新はできるけど
コミットできなくなった。バージョンは1.6.9です。
横着しないほうがいいってことらしい。
でリポジトリDBバージョンを2->3にしたらチェックアウト、更新はできるけど
コミットできなくなった。バージョンは1.6.9です。
横着しないほうがいいってことらしい。
212login:Penguin
2010/04/02(金) 20:44:39ID:IyKbf9bJ はあ、どこで道を踏み誤ったんだろうなあ。。。
2010/06/02(水) 08:03:38ID:Hhndte6H
>>209
私もsentOSからwindowsの共有フォルダをマウントして、
sentOS上のリポジトリのバックアップをwindows側に取ろうとしているんですが、
上手くいかず困っています。
【状況】
1.sentOSからwindow共有フォルダをマウント
2.SentOSから"svnadmin create hogehoge"を実行し、windows上にミラー用リポジトリ作成
3.ミラーリポジトリのhooks/pre-revprop-change の内容を以下に変更
#!/bin/sh
exit 0
4. 3のファイルに実行権限を付与
5. SentOSから "svnsync init file///ミラー先 file:///ミラー元" を実行してリポジトリの
初期化を試みるが失敗。以下のようなエラーが出た。
"svnsync: 'pre-revprop-change' フックが次のようなエラーを出力して失敗しました:"
(↑※「次のようなエラー」と出力されているにもかかわらず、エラー内容が出力されていない)
以上です。解決法をご存知の方がいらっしゃれば、アドバイスお願い致します。
私もsentOSからwindowsの共有フォルダをマウントして、
sentOS上のリポジトリのバックアップをwindows側に取ろうとしているんですが、
上手くいかず困っています。
【状況】
1.sentOSからwindow共有フォルダをマウント
2.SentOSから"svnadmin create hogehoge"を実行し、windows上にミラー用リポジトリ作成
3.ミラーリポジトリのhooks/pre-revprop-change の内容を以下に変更
#!/bin/sh
exit 0
4. 3のファイルに実行権限を付与
5. SentOSから "svnsync init file///ミラー先 file:///ミラー元" を実行してリポジトリの
初期化を試みるが失敗。以下のようなエラーが出た。
"svnsync: 'pre-revprop-change' フックが次のようなエラーを出力して失敗しました:"
(↑※「次のようなエラー」と出力されているにもかかわらず、エラー内容が出力されていない)
以上です。解決法をご存知の方がいらっしゃれば、アドバイスお願い致します。
2010/06/02(水) 10:45:18ID:HiSOFHLt
CentOS
215login:Penguin
2010/10/25(月) 08:03:24ID:gZnkNs2+ http://hibari.2ch.net/test/read.cgi/tech/1283780922/から誘導されてきました。
イントラ内に建てたfreebsd8.1サーバーにsubversionインストールして
ブラウザでhttp://サーバーアドレス/davってするとdav - Revision 0: / って表示されるところまでできました。
やりたいことは、クライアントのWin7上で開発中のvisual studio 2010 proのVC#プロジェクトを管理したいのですが
サーバーに同期(アップロード?コミット?チェックアウト?)させる方法がわかりません。
つまり、コミット先?をhttp://サーバーアドレス/davにしたいのですが
設定がまずいのか現在は、ローカルの
file:///C:/Repositories/dav/trunkになってしまいます。
どうしたら変更できますか?
イントラ内に建てたfreebsd8.1サーバーにsubversionインストールして
ブラウザでhttp://サーバーアドレス/davってするとdav - Revision 0: / って表示されるところまでできました。
やりたいことは、クライアントのWin7上で開発中のvisual studio 2010 proのVC#プロジェクトを管理したいのですが
サーバーに同期(アップロード?コミット?チェックアウト?)させる方法がわかりません。
つまり、コミット先?をhttp://サーバーアドレス/davにしたいのですが
設定がまずいのか現在は、ローカルの
file:///C:/Repositories/dav/trunkになってしまいます。
どうしたら変更できますか?
2010/10/25(月) 08:33:26ID:AgBROAV0
チュートリアルやった方が良いんじゃないか?
svn importとかしらべてみな。
その段階では、サーバの問題じゃないから
http://hibari.2ch.net/test/read.cgi/tech/1286654542/
で聞いた方が良いんじゃないか?
svn importとかしらべてみな。
その段階では、サーバの問題じゃないから
http://hibari.2ch.net/test/read.cgi/tech/1286654542/
で聞いた方が良いんじゃないか?
217login:Penguin
2010/10/25(月) 21:34:14ID:drc4urq+ >>216
できました。簡単でした。
できました。簡単でした。
218login:Penguin
2010/12/30(木) 12:04:21ID:JxXO22vt プログラム板から誘導されてきました
apacheプロジェクトやGoogle CodeのSubversionサーバみたいに
http://server/repo/trunk だとanonymous チェックアウト化、コミット不可
https://server/repo/trunk だと認証要かつコミット可
ってどうやって構成するんでしょう?
Webサーバーはapacheだと思うんですが、パスが同じなので<Location>ディレクティブ
では役に立たなさそうだし、URL rewriteのようなへんてこなことをしているようにも見えないし・・・
apacheプロジェクトやGoogle CodeのSubversionサーバみたいに
http://server/repo/trunk だとanonymous チェックアウト化、コミット不可
https://server/repo/trunk だと認証要かつコミット可
ってどうやって構成するんでしょう?
Webサーバーはapacheだと思うんですが、パスが同じなので<Location>ディレクティブ
では役に立たなさそうだし、URL rewriteのようなへんてこなことをしているようにも見えないし・・・
2010/12/30(木) 12:52:32ID:NCm/PPlG
httpとhttpsで独立して設定できるんだからそれぞれを希望するように設定すればいいだけ
2010/12/30(木) 13:05:21ID:JxXO22vt
>>219
VirtualHostを使うということでしょうか?
VirtualHostを使うということでしょうか?
221login:Penguin
2010/12/30(木) 14:58:57ID:zIYq0qFA <VirtualHost なんたら:80>
GET PROPFIND OPTIONSあたりのメソッドだけ許可
DAV設定
</VirtualHost>
<VirtualHost なんたら:443>
証明書の設定
DAV設定
</VirtualHost>
みたいなイメージ
GET PROPFIND OPTIONSあたりのメソッドだけ許可
DAV設定
</VirtualHost>
<VirtualHost なんたら:443>
証明書の設定
DAV設定
</VirtualHost>
みたいなイメージ
■ このスレッドは過去ログ倉庫に格納されています
ニュース
- 第2次大戦に触れトランプ氏「米中は同盟国」、当時は中華民国…「抗日」巡る中国の言説補強する恐れ ★7 [蚤の市★]
- 「暗い未来に子供を産みたくない…」それでも左派よりも右派の方が「たくさん子供を産む」のはなぜか【米研究】 [首都圏の虎★]
- 高市総理「日米は非常に強い絆で結ばれた同盟国」 トランプ大統領の“中国は同盟国だった”発言受け [首都圏の虎★]
- 【野球】広島東洋カープの矢野雅哉・前川誠太選手を書類送検 ゾンビたばこを巡る容疑 広島県警 [Ailuropoda melanoleuca★]
- パナソニックが市販カーナビ生産終了へ 30年以上の歴史に幕、スマホナビの普及など受け [少考さん★]
- 【速報】 高市首相 「円の過小評価は問題だ」 ★4 [お断り★]
- 今日もきのうもずっと5chなの?
- 女性「たのしいピクニック女は、男は好きでも女が見るとめっちゃ不安になる。生きる力がない女なのよ。それが分からないの?」 [592058334]
- 連休特別企画
- ずっとダブパンでいいのに。👊😅👊🏡
- 最近のゲーム、全部つまらなくないか・・・?全然やりたいものがない・・・ [514851239]
- 【画像】品格、高市惨敗wwwwwwwwwwwwwwwwwwww [668024367]