MS-Windows を仕方なく使っている貴方
Cygwin は偽者だとお嘆きの貴方
Windows 上で動作する本物の Linux 環境 coLinux を試してみませんか?
過去スレ
1: http://pc5.2ch.net/test/read.cgi/linux/1075620397/
2: http://pc5.2ch.net/test/read.cgi/linux/1086256260/
3: http://pc5.2ch.net/test/read.cgi/linux/1098153141/
4: http://pc8.2ch.net/test/read.cgi/linux/1108224327/
5: http://pc8.2ch.net/test/read.cgi/linux/1126305825/
6: http://pc11.2ch.net/test/read.cgi/linux/1158677481/
coLinux野郎ぜ! Part7
■ このスレッドは過去ログ倉庫に格納されています
1login:Penguin
2008/03/29(土) 13:52:29ID:wqE/gesx2009/01/20(火) 21:48:55ID:ZvxDChdf
知っている。
とりあえずググレカス
とりあえずググレカス
2009/01/20(火) 21:53:46ID:TFTcX3b4
2009/01/20(火) 22:34:40ID:IzPGwTyj
ちょっとwindowsのブリッジについて質問があるんですが、
ルータ-(LAN-TAP)
みたいにLANとTAPをブリッジ接続して、
さらにLANと繋がってるルータをゲートウェイとかDNSにしてる場合、
ルータの電源が切れてたりしてると
LAN-TAP間の接続にも支障が出たりしますかね?
ルータ-(LAN-TAP)
みたいにLANとTAPをブリッジ接続して、
さらにLANと繋がってるルータをゲートウェイとかDNSにしてる場合、
ルータの電源が切れてたりしてると
LAN-TAP間の接続にも支障が出たりしますかね?
2009/01/20(火) 22:37:01ID:IzPGwTyj
すみません、
>LAN-TAP間の接続にも支障が出たりしますかね?
これはLAN-TAP間の接続というより
要はwindowsホストとcolinuxの接続に支障が出るかどうかという意味です。
>LAN-TAP間の接続にも支障が出たりしますかね?
これはLAN-TAP間の接続というより
要はwindowsホストとcolinuxの接続に支障が出るかどうかという意味です。
2009/01/20(火) 22:49:04ID:TFTcX3b4
>>215
ルータでDHCPサーバ機能を使ってて、ブリッジがIP自動取得になってると、
ブリッジとlinux側のethインターフェースのネットワークが別になってしまう可能性が考えられるなぁ。
そうなると、ホスト−ゲスト間の通信が不可能になる。
ルータでDHCPサーバ機能を使ってて、ブリッジがIP自動取得になってると、
ブリッジとlinux側のethインターフェースのネットワークが別になってしまう可能性が考えられるなぁ。
そうなると、ホスト−ゲスト間の通信が不可能になる。
218215
2009/01/22(木) 08:16:34ID:7pM4Iy6V >>217
なるほどどうもありがとうございます。
なぜこんな心配をしたかというと、
ホストがノートPCで、ルータには無線で繋がってて不安定なため、
あまりルータに依存した構成にしたくないのです。
とりあえずこの構成にしてしまったので、
しばらくどんなものか様子をみてみます。
IPアドレスは、ブリッジ側でもcolinux側でも
DHCPを使わず手動で割り当てました。
ところで、なぜ「インターネット接続の共有」じゃなくブリッジにしたかというと
ホスト以外のマシンからもcolinuxを参照したかったからなんですが、
「インターネット接続の共有」でもそういうことできたりするんですか?
なるほどどうもありがとうございます。
なぜこんな心配をしたかというと、
ホストがノートPCで、ルータには無線で繋がってて不安定なため、
あまりルータに依存した構成にしたくないのです。
とりあえずこの構成にしてしまったので、
しばらくどんなものか様子をみてみます。
IPアドレスは、ブリッジ側でもcolinux側でも
DHCPを使わず手動で割り当てました。
ところで、なぜ「インターネット接続の共有」じゃなくブリッジにしたかというと
ホスト以外のマシンからもcolinuxを参照したかったからなんですが、
「インターネット接続の共有」でもそういうことできたりするんですか?
219207
2009/01/22(木) 22:42:47ID:5RoawdsS2009/01/23(金) 08:14:24ID:roGTSrvG
221207
2009/01/24(土) 16:09:00ID:BKsqlc7N >>220 ありがとさん!おかげさまでブリッジ問題は解決しました
ただ、まだLAN内の他のPCからColinuxが見れない。。
ルータ→Colinux、MyPC→Colinux、Colinux→www.google.com はPing
が通るんですけど、ほかが通らないというのは何が悪いんですかね?
ただ、まだLAN内の他のPCからColinuxが見れない。。
ルータ→Colinux、MyPC→Colinux、Colinux→www.google.com はPing
が通るんですけど、ほかが通らないというのは何が悪いんですかね?
2009/01/24(土) 16:19:41ID:ebepaWPC
223207
2009/01/24(土) 22:12:00ID:BKsqlc7N >>222
アドバイスありがとうございます。もっとググれカスと罵られる事を期待
してたんですけど、優しいアドバイスが多くて涙がでます。
本題ですが、どうやら問題はルータにあったらしく、ルータを初期化したら
直りました。
ご迷惑をおかけしましたm(| | )m
アドバイスありがとうございます。もっとググれカスと罵られる事を期待
してたんですけど、優しいアドバイスが多くて涙がでます。
本題ですが、どうやら問題はルータにあったらしく、ルータを初期化したら
直りました。
ご迷惑をおかけしましたm(| | )m
2009/02/02(月) 17:53:13ID:7XEyWWjx
いつのまにか devel-coLinux-20090121 出てた
cofs の日本語周りの改善はまだか
cofs の日本語周りの改善はまだか
2009/02/02(月) 18:30:55ID:lGNxjJch
いつからか忘れたけど、普通に日本語ファイルとかにアクセスできるよ。
何か他にあるんだっけ?
何か他にあるんだっけ?
226login:Penguin
2009/02/04(水) 10:25:44ID:wanMZSR+ この度、0.6.4→0.7.3にインストールし直しました。
ずいぶん仕様が変わって苦労してます。
rootディレクトリで.profileへPATHを追加しようと思って開けたら0.6.4のようには書いてなくてどう追加していいかわかりませんでした。
どこか詳しく書いてるサイトがあったら教えてください。
ずいぶん仕様が変わって苦労してます。
rootディレクトリで.profileへPATHを追加しようと思って開けたら0.6.4のようには書いてなくてどう追加していいかわかりませんでした。
どこか詳しく書いてるサイトがあったら教えてください。
2009/02/04(水) 13:03:13ID:CSqPI4a4
>>226
ようわからんのだが、co関係なくて、入れてるディストリの問題じゃねぇの?
ようわからんのだが、co関係なくて、入れてるディストリの問題じゃねぇの?
2009/02/09(月) 15:45:02ID:1OoeXtW5
20090208は注意っぽい。
インストール中にOSごと落ちた。
その後もセーフモードでアンインストールするまで起動直後に落ち続けた。
インストール中にOSごと落ちた。
その後もセーフモードでアンインストールするまで起動直後に落ち続けた。
2009/02/10(火) 04:28:09ID:CLHw9JqL
>>228
MLにも流れてたけど、Devel版なんだから、そのバージョンに限らず注意すんのは当たり前じゃね?
MLにも流れてたけど、Devel版なんだから、そのバージョンに限らず注意すんのは当たり前じゃね?
2009/02/10(火) 08:18:12ID:FGYqJihU
2009/02/10(火) 08:26:53ID:CLHw9JqL
2009/02/10(火) 12:50:23ID:QvzayWcT
colinux-usersでやってたのか。。colinux-develの方見てた。
20090210も来てるね
20090210も来てるね
2009/02/11(水) 13:01:06ID:0ToXSMIU
234login:Penguin
2009/02/14(土) 22:47:48ID:8OjDfq8E このcoLinux、ネットワーク設定の難しさで皆断念してるけど俺もずいぶん苦労したなー。
でも分かってみれば意外に簡単。
マイネットワーク→TAP→プロパティ→詳細設定でファイアウォールを無効にしなきゃならないってコトに気付くまでずいぶん時間が掛かったな。
でも分かってみれば意外に簡単。
マイネットワーク→TAP→プロパティ→詳細設定でファイアウォールを無効にしなきゃならないってコトに気付くまでずいぶん時間が掛かったな。
2009/02/15(日) 01:43:25ID:M9Z3m4Cr
そんなに難しいか?
Win側にPING通さなきゃいけない理由がなければ、coLinuxの実行ファイルを例外設定しておくだけでいいじゃないか。
Win側にPING通さなきゃいけない理由がなければ、coLinuxの実行ファイルを例外設定しておくだけでいいじゃないか。
2009/02/15(日) 02:03:17ID:JVFRoqAq
俺もネットワーク設定でみんな詰まるんだろうと思ってたんだけど
人に勧めるときとかはandLinux使えば楽にできるかな?
人に勧めるときとかはandLinux使えば楽にできるかな?
2009/02/15(日) 02:36:28ID:XRKZSS8T
コメントみたいな#消しただけでping通った
しかし公式のimageって鳥でかなり容量ちがうね。
しかし公式のimageって鳥でかなり容量ちがうね。
2009/02/15(日) 04:13:57ID:M9Z3m4Cr
>>237
Fedoraは知らないけど、Gentoo、Archはスターターパッケージみたいな感じで
そこから本番環境を構築していくための最低限の装備がなされてる。
Debianはハナから使える環境が整ってるよ。
そういえば、そろそろDebian Lennyがくるのか。
Fedoraは知らないけど、Gentoo、Archはスターターパッケージみたいな感じで
そこから本番環境を構築していくための最低限の装備がなされてる。
Debianはハナから使える環境が整ってるよ。
そういえば、そろそろDebian Lennyがくるのか。
2009/02/15(日) 17:08:22ID:XRKZSS8T
2009/02/15(日) 17:29:43ID:M9Z3m4Cr
>>239
Debianイメージつかえば、結構手軽に構築できるみたいなウェブ上の記事を見つけた。
http://repse.blogspot.com/search/label/クロスコンパイル
実際やってないからワカランけどw
Lennyきたみたいだし、しばらくはDebianが盛り上がりそうな空気だな。
Debianイメージつかえば、結構手軽に構築できるみたいなウェブ上の記事を見つけた。
http://repse.blogspot.com/search/label/クロスコンパイル
実際やってないからワカランけどw
Lennyきたみたいだし、しばらくはDebianが盛り上がりそうな空気だな。
2009/02/15(日) 21:53:56ID:Xa1eKf9A
2009/02/16(月) 00:27:32ID:7h16xR1t
Debianスレのお祭りムードがうらやましい。
coLinuxじゃお祭りなんてあり得ないモンな。
coLinuxじゃお祭りなんてあり得ないモンな。
2009/02/16(月) 03:54:33ID:1lkBwSfk
なぜその二つが比較対象になるのかよくわからんが
おれはcolinuxでdebian使ってるのでひさびさのアップグレード
マンドクサだぜ。
おれはcolinuxでdebian使ってるのでひさびさのアップグレード
マンドクサだぜ。
2009/02/17(火) 00:28:40ID:GoBgrM40
よっしゃ。
Devel-20090215きたから、俺たちもお祭り騒ぎしようぜwww
ふぅ。むなしいな。
Devel-20090215きたから、俺たちもお祭り騒ぎしようぜwww
ふぅ。むなしいな。
245login:Penguin
2009/02/19(木) 18:27:17ID:rQu8GfK7 0.7.3使ってます。
lennyになった途端aptーget updateが出来なくなった(涙
誰か詳しい人教えて!
lennyになった途端aptーget updateが出来なくなった(涙
誰か詳しい人教えて!
2009/02/19(木) 20:01:50ID:plhdKO+f
>>245
/etc/apt/source.listとかsource.list.d/の中身のファイルの内容とか晒そうぜ。
/etc/apt/source.listとかsource.list.d/の中身のファイルの内容とか晒そうぜ。
247245
2009/02/19(木) 22:40:54ID:sdiyZkhu >>246
レスありがとうございます。
/etc/apt/source.listの中身です↓
deb http://ftp.debian.org/debian/ etch main
deb-src http://ftp.debian.org/debian/ etch main
deb http://security.debian.org/ etch/updates main contrib
deb-src http://security.debian.org/ etch/updates main contrib
よろしくご教授お願いします。
レスありがとうございます。
/etc/apt/source.listの中身です↓
deb http://ftp.debian.org/debian/ etch main
deb-src http://ftp.debian.org/debian/ etch main
deb http://security.debian.org/ etch/updates main contrib
deb-src http://security.debian.org/ etch/updates main contrib
よろしくご教授お願いします。
2009/02/20(金) 00:53:07ID:MbVffJG0
>>247
ぜんぜん問題ないように見えるんだが、たまたま、てことはない?
もしくは、どう出来ないのか。メッセージとか。
つ〜か、lennyになったとたん、とか言うのに、source.listはetchでlennyになんか
なってねぇやん。stableがlenny、ていう意味か?
ぜんぜん問題ないように見えるんだが、たまたま、てことはない?
もしくは、どう出来ないのか。メッセージとか。
つ〜か、lennyになったとたん、とか言うのに、source.listはetchでlennyになんか
なってねぇやん。stableがlenny、ていう意味か?
249245
2009/02/20(金) 04:17:08ID:+6v2o66d >>248
stableがlennyになってからだと思われます。
1ヶ月ぶりにcoLinuxを起動したのですが、急にaptーgetが出来なくなりました。
エラーの種類ですがパッケージのリストが古すぎるかヴァージョンが違うって書いてありました。
source.listの中身をetch→lennyに変えてみたりもしましたが依然としてエラーを吐き出しています。
原因は何でしょうか?
stableがlennyになってからだと思われます。
1ヶ月ぶりにcoLinuxを起動したのですが、急にaptーgetが出来なくなりました。
エラーの種類ですがパッケージのリストが古すぎるかヴァージョンが違うって書いてありました。
source.listの中身をetch→lennyに変えてみたりもしましたが依然としてエラーを吐き出しています。
原因は何でしょうか?
2009/02/20(金) 08:58:28ID:8SiLqvXW
2009/02/20(金) 16:10:04ID:h0ldsZRq
deb http://ftp.debian.org/debian/ stable main
deb-src http://ftp.debian.org/debian/ stable main
deb http://security.debian.org/ stable/updates main contrib
deb-src http://security.debian.org/ stable/updates main contrib
で、aptitude update && aptitude full-upgradeは?
つか、etchからaptitude推奨じゃなかったっけ?Lennyからだっけ?
Debianスレで聞いた方がいいと思う。
あと、エラーメッセージを晒すとよさげ。
deb-src http://ftp.debian.org/debian/ stable main
deb http://security.debian.org/ stable/updates main contrib
deb-src http://security.debian.org/ stable/updates main contrib
で、aptitude update && aptitude full-upgradeは?
つか、etchからaptitude推奨じゃなかったっけ?Lennyからだっけ?
Debianスレで聞いた方がいいと思う。
あと、エラーメッセージを晒すとよさげ。
2009/02/20(金) 17:35:54ID:8SiLqvXW
>>251
すっかりスレチになるけど、stable指定だとlennyになってまう。
今stableはlennyで、etchはoldstable。以前stable指定してて、
cronで自動upgradeとかやってた連中が阿鼻叫喚になったりして、
etchとかのコードネーム指定が推奨されてるかと。
で、etchはaptitude推奨だったけど、apt-getもaptitudeと同様に
なったらしく、lenny以降はどっちでも良いけど、便宜上aptitude
推奨、と思って良いらしく。細かいところで違うんだろうけどさ。
さらに。aptitude full-upgradeはlennyからで、etch当時は
dist-upgradeだったかと。apt-getも同様かな?
すっかりスレチになるけど、stable指定だとlennyになってまう。
今stableはlennyで、etchはoldstable。以前stable指定してて、
cronで自動upgradeとかやってた連中が阿鼻叫喚になったりして、
etchとかのコードネーム指定が推奨されてるかと。
で、etchはaptitude推奨だったけど、apt-getもaptitudeと同様に
なったらしく、lenny以降はどっちでも良いけど、便宜上aptitude
推奨、と思って良いらしく。細かいところで違うんだろうけどさ。
さらに。aptitude full-upgradeはlennyからで、etch当時は
dist-upgradeだったかと。apt-getも同様かな?
2009/02/20(金) 17:41:30ID:8SiLqvXW
2009/02/20(金) 18:19:14ID:h0ldsZRq
2009/02/22(日) 21:27:23ID:HVt/u8Ma
質問なんですけど、ColinuxでGUI環境が使いたくて以下のHPに
従って設定したんですけど、
http://scratchpad.fc2web.com/colinux/install-0.7/install-9.html
外部からVNCでXserverを立ち上げようとするとウインドウが落ちてログイン
すらできません。あらかじめVNCServerを立てている場合はログインウインドウ
があがってくるのですが・・・。
このトラブルの原因について何か助言もらえないですかね?
ログを見て何が起こっているのか対処できないかと検討したんですけど、
ログすらどこにあるかわからなくて困ってます。
従って設定したんですけど、
http://scratchpad.fc2web.com/colinux/install-0.7/install-9.html
外部からVNCでXserverを立ち上げようとするとウインドウが落ちてログイン
すらできません。あらかじめVNCServerを立てている場合はログインウインドウ
があがってくるのですが・・・。
このトラブルの原因について何か助言もらえないですかね?
ログを見て何が起こっているのか対処できないかと検討したんですけど、
ログすらどこにあるかわからなくて困ってます。
2009/02/22(日) 23:27:43ID:yH/Zc28c
2009/02/23(月) 19:29:40ID:Fb09Ja96
>>256
VNCクライアント接続時に自動でvncserverが起動するように設定しようとして、
HPに書いてある
1,/etc/servicesの変更
2,/etc/inetd.confの変更
3,Xvfbのインストール
4,xdmの設定
を行ったのですが、VNCでホストPC(WINDOWS PC)から接続してもVNCserver
が立ち上がらず困っているという状況です。
VNCクライアント接続時に自動でvncserverが起動するように設定しようとして、
HPに書いてある
1,/etc/servicesの変更
2,/etc/inetd.confの変更
3,Xvfbのインストール
4,xdmの設定
を行ったのですが、VNCでホストPC(WINDOWS PC)から接続してもVNCserver
が立ち上がらず困っているという状況です。
2009/02/23(月) 21:09:30ID:MOmTM84y
2009/02/23(月) 22:50:59ID:OM5UFZHj
なんかXserverについて勘違いしてない?
>外部からVNCでXserverを立ち上げようとする
これが意味不明なんだけど具体的に説明してよ。
vncserverもXserverの一種だってわかってる?
>外部からVNCでXserverを立ち上げようとする
これが意味不明なんだけど具体的に説明してよ。
vncserverもXserverの一種だってわかってる?
2009/02/24(火) 08:43:37ID:IisX/m8b
>>258
今は時間ないので、今夜やってみます!ありがとさん
>>259
>>255 のHPより引用
>上記の設定でとりあえず、 coLinuxをGUIで使用することができるようになりました。 しかしこのままでは、
>GUIを使用するのには一旦coLinuxにログインしてから vncserverを起動させなければなりません。
これではさすがに面倒です。
>で、実はこれを解決するための機構が、 既にvncserverの方に組み込まれています。
>それはVNCクライアントで接続すると 自動的にvncserverが起動するというものです。
>ただし、それなりの設定が必要です。
この記述から、VNCserverが接続された瞬間にvncserverを立ち上げてくれる
サービスみたいな物があるもんだとおもってたんですけど、
それは勘違いなんですかね?
具体的にと言われてもこれ以上の情報は私が理解しきれてないのか出せないですね。
今は時間ないので、今夜やってみます!ありがとさん
>>259
>>255 のHPより引用
>上記の設定でとりあえず、 coLinuxをGUIで使用することができるようになりました。 しかしこのままでは、
>GUIを使用するのには一旦coLinuxにログインしてから vncserverを起動させなければなりません。
これではさすがに面倒です。
>で、実はこれを解決するための機構が、 既にvncserverの方に組み込まれています。
>それはVNCクライアントで接続すると 自動的にvncserverが起動するというものです。
>ただし、それなりの設定が必要です。
この記述から、VNCserverが接続された瞬間にvncserverを立ち上げてくれる
サービスみたいな物があるもんだとおもってたんですけど、
それは勘違いなんですかね?
具体的にと言われてもこれ以上の情報は私が理解しきれてないのか出せないですね。
2009/02/24(火) 13:07:05ID:S0VTBvMa
>>260
だったらxserverと書かずにvncserverと書け、ということなんだが。
んで、他にもinetdが実は立ち上がっていない/再起動されていないとか、
そもそもinetd.confの記述を間違えているとか、いろいろありそうやなぁ。
ところで、xdmを立ち上げる必要はあるのか? vncserver立ち上げっぱで
良いんじゃね? 1人で使うなら、わざわざxdmで認証するのもめんどいぞ?
だったらxserverと書かずにvncserverと書け、ということなんだが。
んで、他にもinetdが実は立ち上がっていない/再起動されていないとか、
そもそもinetd.confの記述を間違えているとか、いろいろありそうやなぁ。
ところで、xdmを立ち上げる必要はあるのか? vncserver立ち上げっぱで
良いんじゃね? 1人で使うなら、わざわざxdmで認証するのもめんどいぞ?
2009/02/24(火) 20:20:40ID:IisX/m8b
>>258
hosts周りも、syslog にも異常はありませんでした・・・。
>>261
>んで、他にもinetdが実は立ち上がっていない/再起動されていないとか、
>そもそもinetd.confの記述を間違えているとか、いろいろありそうやなぁ。
このあたりはそう考えて、3回くらいやりなおしたので間違っては居ないと
思います。
> vncserver立ち上げっぱで 良いんじゃね?
ここは意地ですかね?確かにそれでもいいんですけど、負けた気分に
なります。
とりあえずVNCでcolinuxに接続すると、サーバに接続できません!という
エラーはでないので、VNCサーバは立ち上がっている?と考えます。
ただ、リトライさせるとconnection dropped と表示されて
ウインドウ閉じる→また再接続でウインドウを開く という動作を繰り返す
んですよね。
原因究明は難しい・・・。
hosts周りも、syslog にも異常はありませんでした・・・。
>>261
>んで、他にもinetdが実は立ち上がっていない/再起動されていないとか、
>そもそもinetd.confの記述を間違えているとか、いろいろありそうやなぁ。
このあたりはそう考えて、3回くらいやりなおしたので間違っては居ないと
思います。
> vncserver立ち上げっぱで 良いんじゃね?
ここは意地ですかね?確かにそれでもいいんですけど、負けた気分に
なります。
とりあえずVNCでcolinuxに接続すると、サーバに接続できません!という
エラーはでないので、VNCサーバは立ち上がっている?と考えます。
ただ、リトライさせるとconnection dropped と表示されて
ウインドウ閉じる→また再接続でウインドウを開く という動作を繰り返す
んですよね。
原因究明は難しい・・・。
2009/02/24(火) 22:05:32ID:cCJ8TwiI
2009/02/24(火) 23:14:10ID:IisX/m8b
2009/02/25(水) 02:13:25ID:BE3K+L/u
とりあえず接続した時のログ読んでみたらいいんじゃない?
xdmが立ちあがってるかどうかとか、
プロセスにvncserverが出てくるかどうかとか
調べるところは山ほどある。
xdmが立ちあがってるかどうかとか、
プロセスにvncserverが出てくるかどうかとか
調べるところは山ほどある。
2009/02/25(水) 09:02:20ID:vmoVB4V+
うちのcoじゃないlennyにtightvncserver入れてやってみた。coのPC名、colinuxから
変えてね? で、-queryオプションにcolinuxのまんま設定してね? ついでに、XDMCPが
使うportを実は閉じたりしてね?
ただ、これだとconection refuseな気がするな。
変えてね? で、-queryオプションにcolinuxのまんま設定してね? ついでに、XDMCPが
使うportを実は閉じたりしてね?
ただ、これだとconection refuseな気がするな。
267245
2009/02/25(水) 09:03:47ID:wt/GQg/Y aptーget updateがうまく行かない原因はWindowsのファイアウォールが邪魔してました。
TAPとローカルエリア接続のプロパティから詳細設定でファイアウォールを無効にしたら開通しました。
すみませんお騒がせしました。
では。。
TAPとローカルエリア接続のプロパティから詳細設定でファイアウォールを無効にしたら開通しました。
すみませんお騒がせしました。
では。。
2009/02/25(水) 09:27:11ID:IPYnAKn/
処女開通オメデト!
269245
2009/02/25(水) 09:52:22ID:wt/GQg/Y2009/02/25(水) 17:06:46ID:02jWc0KV
>>264
とりあえず、xdmcp接続の許可はしてあるの?
とりあえず、xdmcp接続の許可はしてあるの?
2009/02/25(水) 18:33:58ID:CyPn+iJl
処女姦通、俺も死ぬまでに一回くらいはしてみたい
2009/02/25(水) 21:37:46ID:C2XA3VrT
>>245
開通オメ
>>266
colinuxのPC名とかは大丈夫ですね。
>>270
XDMCP接続許可は・・・わからないですね。GNOMEだとメニューから
できるそうなんですけど。
あと、接続時にvncserverは立ち上がっていないので、inetdあたりが怪しい
のかなと考えて以下のことをやってみました。
colinux:~# Xvnc -query colinux -geometry 1024x768
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.
で言われたとおりにやってみると
colinux:~# rm /tmp/.X0-lock
colinux:~# Xvnc -query colinux -geometry 1024x768
_XSERVTransSocketINETCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already running
となって全く別のところに問題があるんですかね?
ここまでくると、再インストールした方が早そうなんですが、
何となくうだうだとやってしまいます・・・。
開通オメ
>>266
colinuxのPC名とかは大丈夫ですね。
>>270
XDMCP接続許可は・・・わからないですね。GNOMEだとメニューから
できるそうなんですけど。
あと、接続時にvncserverは立ち上がっていないので、inetdあたりが怪しい
のかなと考えて以下のことをやってみました。
colinux:~# Xvnc -query colinux -geometry 1024x768
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.
で言われたとおりにやってみると
colinux:~# rm /tmp/.X0-lock
colinux:~# Xvnc -query colinux -geometry 1024x768
_XSERVTransSocketINETCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already running
となって全く別のところに問題があるんですかね?
ここまでくると、再インストールした方が早そうなんですが、
何となくうだうだとやってしまいます・・・。
2009/02/25(水) 21:50:45ID:pQxfQuCO
>>272
> If this server is no longer running, remove /tmp/.X0-lock
> and start again.
> で言われたとおりにやってみると
If this server is no longer running を見なかったことにすんなw
> If this server is no longer running, remove /tmp/.X0-lock
> and start again.
> で言われたとおりにやってみると
If this server is no longer running を見なかったことにすんなw
2009/02/25(水) 21:52:41ID:vmoVB4V+
vncserverとして、どのパッケージの使ってるのかわからんけど、
TightVNCだと、vncserverを立ち上げた状態で>>272なことやると、
似たようなエラーを吐くなぁ。
#Xvnc -query hoge
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock and start again.
#rm /tmp/.X0-lock
#Xvnc -query hoge
_XSERVTransSocketINETCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already running
TightVNCだと、vncserverを立ち上げた状態で>>272なことやると、
似たようなエラーを吐くなぁ。
#Xvnc -query hoge
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock and start again.
#rm /tmp/.X0-lock
#Xvnc -query hoge
_XSERVTransSocketINETCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already running
2009/02/25(水) 21:56:05ID:vmoVB4V+
あれ? 似たような、てか、まんま一緒?
ちなみに、vncserver立ち上げてないと
25/02/09 21:43:43 Xvnc version TightVNC-1.3.9
25/02/09 21:43:43 Copyright (C) 2000-2007 TightVNC Group
25/02/09 21:43:43 Copyright (C) 1999 AT&T Laboratories Cambridge
25/02/09 21:43:43 All Rights Reserved.
25/02/09 21:43:43 See http://www.tightvnc.com/ for information on TightVNC
25/02/09 21:43:43 Desktop name 'x11' (hage:0)
25/02/09 21:43:43 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
25/02/09 21:43:43 Listening for VNC connections on TCP port 5900
・
・
・
ちなみに、vncserver立ち上げてないと
25/02/09 21:43:43 Xvnc version TightVNC-1.3.9
25/02/09 21:43:43 Copyright (C) 2000-2007 TightVNC Group
25/02/09 21:43:43 Copyright (C) 1999 AT&T Laboratories Cambridge
25/02/09 21:43:43 All Rights Reserved.
25/02/09 21:43:43 See http://www.tightvnc.com/ for information on TightVNC
25/02/09 21:43:43 Desktop name 'x11' (hage:0)
25/02/09 21:43:43 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
25/02/09 21:43:43 Listening for VNC connections on TCP port 5900
・
・
・
2009/02/25(水) 22:35:47ID:BE3K+L/u
Server is already active for display 0
これじゃないの?
これじゃないの?
2009/02/25(水) 22:45:05ID:C2XA3VrT
>>273-276
Serverが既にたっていることも考えたんですけど、こんな状態
なので、立っていないってことですよね?
colinux:~# ps aux | grep vnc
root 2912 0.0 0.1 1644 512 pts/0 R+ 22:46 0:00 grep vnc
と思って無視したんですけど・・・間違いですかね?
Serverが既にたっていることも考えたんですけど、こんな状態
なので、立っていないってことですよね?
colinux:~# ps aux | grep vnc
root 2912 0.0 0.1 1644 512 pts/0 R+ 22:46 0:00 grep vnc
と思って無視したんですけど・・・間違いですかね?
2009/02/26(木) 00:43:04ID:FLhJSxFv
5900+αあたりとか、6000あたりとかのportは使われてねぇの?
2009/02/26(木) 01:36:23ID:9N9udLDp
2009/02/26(木) 07:39:10ID:FLhJSxFv
vnc使おうとして、なにがどうなって困ってるんだっけ?
実はvncは動いていて、xdmが動いてくれていない、とか?
いや、実はオレがそうなんだが。今回のコレで試してみたら
動かねぇなぁ、と。あんまし追求する気もないけどさ。
実はvncは動いていて、xdmが動いてくれていない、とか?
いや、実はオレがそうなんだが。今回のコレで試してみたら
動かねぇなぁ、と。あんまし追求する気もないけどさ。
2009/02/26(木) 08:14:37ID:YkDQm/RW
>>278-279
colinux:~# nmap colinux
Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2009-02-26 08:11 JST
Interesting ports on colinux (192.168.1.30):
Not shown: 1675 closed ports
PORT STATE SERVICE
22/tcp open ssh
80/tcp open http
139/tcp open netbios-ssn
445/tcp open microsoft-ds
6000/tcp open X11
Nmap finished: 1 IP address (1 host up) scanned in 0.150 seconds
6000は使われてるんですかね?
>>279
それはどういう意味ですかね?inetdでVNCを設定してはいけないということですか?
>>280
VNCが動かない状態ですね。xdmが動く動かない以前の問題です。
さてそろそろ仕事にいってきます ノシ
colinux:~# nmap colinux
Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2009-02-26 08:11 JST
Interesting ports on colinux (192.168.1.30):
Not shown: 1675 closed ports
PORT STATE SERVICE
22/tcp open ssh
80/tcp open http
139/tcp open netbios-ssn
445/tcp open microsoft-ds
6000/tcp open X11
Nmap finished: 1 IP address (1 host up) scanned in 0.150 seconds
6000は使われてるんですかね?
>>279
それはどういう意味ですかね?inetdでVNCを設定してはいけないということですか?
>>280
VNCが動かない状態ですね。xdmが動く動かない以前の問題です。
さてそろそろ仕事にいってきます ノシ
2009/02/26(木) 15:30:16ID:WgdGCpwa
>>281
nmapは、念のため-pで範囲指定したのが良い。標準で全部のport調べるわけじゃないから。
あと、6000はxdmが使ってると思われ。
そんなわけで、vncserverとviewerは何使ってて、念のため入れなおしてみるとか、vncserverとかXvncとかxdmとかinetdとか
動いてるのか動いてないのか、その各場合における動作とか、もっかい整理したのが良いんじゃねぇの?
ついでに、いつものwindows fwが悪さ、とか、実はiptablesが、とか。
nmapは、念のため-pで範囲指定したのが良い。標準で全部のport調べるわけじゃないから。
あと、6000はxdmが使ってると思われ。
そんなわけで、vncserverとviewerは何使ってて、念のため入れなおしてみるとか、vncserverとかXvncとかxdmとかinetdとか
動いてるのか動いてないのか、その各場合における動作とか、もっかい整理したのが良いんじゃねぇの?
ついでに、いつものwindows fwが悪さ、とか、実はiptablesが、とか。
2009/02/26(木) 18:45:20ID:jm0iLqA5
2009/02/26(木) 20:15:24ID:YkDQm/RW
>>283
You get an error message like:
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.The number denotes the display number
(in this case 0). This number needs to be unique on the system, so you cannot run two servers on one system with identical display numbers. This message indicates that there is already a server with this number running on the system.
You can verify this by running
ps aux | grep `cat /tmp/.X0-lock`If you see an output like:
root 2283 0.5 5.1 27796 6536 ? S Apr21 59:03 [X]it indicates that there is indeed an Xserver running under this PID. To start a second server on the same system you have to give it a different dislay number.
If you start your servers using startx you can do
startx -- :1to start a server with display number 1. If you are sure there is no other server running on your system and above ps command indicates that no server with this PID is running, you should remove the file
/tmp/.X0-lock by doing (as 'root'):
rm -rf /tmp/.X0-lock
ってことで、
ps aux | grep vnc
でvncserverがたっているか捜していなかったので、Server二重起動ではないと
踏んでいたのですが、探し方まちがいですかね?
You get an error message like:
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.The number denotes the display number
(in this case 0). This number needs to be unique on the system, so you cannot run two servers on one system with identical display numbers. This message indicates that there is already a server with this number running on the system.
You can verify this by running
ps aux | grep `cat /tmp/.X0-lock`If you see an output like:
root 2283 0.5 5.1 27796 6536 ? S Apr21 59:03 [X]it indicates that there is indeed an Xserver running under this PID. To start a second server on the same system you have to give it a different dislay number.
If you start your servers using startx you can do
startx -- :1to start a server with display number 1. If you are sure there is no other server running on your system and above ps command indicates that no server with this PID is running, you should remove the file
/tmp/.X0-lock by doing (as 'root'):
rm -rf /tmp/.X0-lock
ってことで、
ps aux | grep vnc
でvncserverがたっているか捜していなかったので、Server二重起動ではないと
踏んでいたのですが、探し方まちがいですかね?
2009/02/26(木) 21:00:55ID:WgdGCpwa
>>284
んだから、オレとしては、関係してそうなの全部落としてnmapを-p指定でやって、だれも待ち受けしてないのを確認した上で、
正しく必要なのを起動させて、念のためnmapで待ち受けを確認しつつ、やってみれば? と。
いちお、etchのbackports環境だけど、tightvncserverとwinのultravncclient、あとxdmで動作確認はした。
んだから、オレとしては、関係してそうなの全部落としてnmapを-p指定でやって、だれも待ち受けしてないのを確認した上で、
正しく必要なのを起動させて、念のためnmapで待ち受けを確認しつつ、やってみれば? と。
いちお、etchのbackports環境だけど、tightvncserverとwinのultravncclient、あとxdmで動作確認はした。
2009/02/26(木) 21:08:23ID:9N9udLDp
>>284
とりあえず、試すだけなら他のポートでやってみればいいじゃん。:1とか:2とか
とりあえず、試すだけなら他のポートでやってみればいいじゃん。:1とか:2とか
2009/02/27(金) 05:33:38ID:APUu9GJV
Xvfbってディスプレイナンバー使わんの?
2009/02/27(金) 07:24:13ID:E+vTF4Ha
ディスプレイ番号なら使ってると思うが
2009/02/27(金) 07:55:17ID:qT80Sjjj
えー、昨朝くだ質スレでcoLinuxを紹介されて、andLinuxを入れてしまいました。返答をくれた方、ありがとうございました。
ところで、このページの、
ttp://d.hatena.ne.jp/wadap/20080602/1212419216
1)xlogoの下あたりの「ランチャー」とは何のことでしょうか。
2)Windowsの画面に「Terminal」てのが無いのですが、どの/usr/bin/*term*を指しているか分かりますか? xfceてのを選択したので *xfce4* てのを使えば良いのかしら?
つか、xtermはどこ…
ところで、このページの、
ttp://d.hatena.ne.jp/wadap/20080602/1212419216
1)xlogoの下あたりの「ランチャー」とは何のことでしょうか。
2)Windowsの画面に「Terminal」てのが無いのですが、どの/usr/bin/*term*を指しているか分かりますか? xfceてのを選択したので *xfce4* てのを使えば良いのかしら?
つか、xtermはどこ…
2009/02/27(金) 09:58:26ID:oZADNwWJ
>>289
オレのことかーっ。
で、andってcoベースだったのか。知らんかった。ubuntuでxmingなのね。へぇ。
で。ランチャーって、windowsのスタートメニューに作られたフォルダって意味じゃねぇの? terminalはそこのショートカット。
参照しろってページの解説に、スタートメニューにandLinuxってフォルダ作るってインストール途中の画面にあるし。
で、そのterminalは設定によるから、入れてみんとわからん。xfceってそいや標準terminal持ってた気がするから、そうかも。
オレのことかーっ。
で、andってcoベースだったのか。知らんかった。ubuntuでxmingなのね。へぇ。
で。ランチャーって、windowsのスタートメニューに作られたフォルダって意味じゃねぇの? terminalはそこのショートカット。
参照しろってページの解説に、スタートメニューにandLinuxってフォルダ作るってインストール途中の画面にあるし。
で、そのterminalは設定によるから、入れてみんとわからん。xfceってそいや標準terminal持ってた気がするから、そうかも。
2009/02/27(金) 10:08:02ID:PYbVXS5O
2009/02/27(金) 19:30:49ID:ymxTMQHs
>>289
取り敢えず、自己レス。
MS-Windowsのランチャー==START MENUと思い込んでいたのですが、あにはからんや、画面最下行のタスクバー(だっけ?)に、xfce4-termを含むフォルダアイコンが出来ていました。
難し過ぎだよ…
>>290,291
レス有り難うございます。
もう一つ質問です。
andLinuxに「俺」でログインし、touch windowsDir/file し、MS-Windows側でfileを見ると所有者がAdminになってしまいます。
mount -t cofs -o username=俺@win,uid=俺@linux ...
などとやろうとしたのですが、cofsにusernameオプションは無いようです。
MS-Windowsのファイル所有者が「俺」のファイルをcofsで作成するためには、一般的にはどんな方法がありますか。
取り敢えず、自己レス。
MS-Windowsのランチャー==START MENUと思い込んでいたのですが、あにはからんや、画面最下行のタスクバー(だっけ?)に、xfce4-termを含むフォルダアイコンが出来ていました。
難し過ぎだよ…
>>290,291
レス有り難うございます。
もう一つ質問です。
andLinuxに「俺」でログインし、touch windowsDir/file し、MS-Windows側でfileを見ると所有者がAdminになってしまいます。
mount -t cofs -o username=俺@win,uid=俺@linux ...
などとやろうとしたのですが、cofsにusernameオプションは無いようです。
MS-Windowsのファイル所有者が「俺」のファイルをcofsで作成するためには、一般的にはどんな方法がありますか。
2009/02/27(金) 20:46:47ID:oZADNwWJ
>>292
cifsを使うってのはダメ?
cifsを使うってのはダメ?
294292
2009/02/27(金) 21:37:42ID:aRgI7Wi1 共有設定に、[非]技術的制約があるのです。
既に共有されているfsはsmbマウントしてるのですが、
c:\を共有設定することは出来ないのです。
既に共有されているfsはsmbマウントしてるのですが、
c:\を共有設定することは出来ないのです。
2009/02/27(金) 23:48:02ID:vlAIveXh
2009/02/28(土) 01:43:29ID:XItzrazz
>>295
すまん。オレが思っていた前提と違うんだが...
vncserverをコンソールから起動して、ならふつ〜に自分のログインセッションに繋がるけど、
inetd経由xvnc起動してxdmがダメ、じゃなかったん? 外からって、どこやねん。host? local? global?
すまん。オレが思っていた前提と違うんだが...
vncserverをコンソールから起動して、ならふつ〜に自分のログインセッションに繋がるけど、
inetd経由xvnc起動してxdmがダメ、じゃなかったん? 外からって、どこやねん。host? local? global?
2009/02/28(土) 01:46:57ID:XItzrazz
2009/02/28(土) 08:28:35ID:7NYT0Onr
>>296
その通りですね。ローカル?host?のcolinux動かしているWinXPからinetd
経由でVNCServerを立ち上げようとするとできないということですね。
>>297
colinux:/etc# nmap -p 5000-6000 colinux
Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2009-02-28 08:30 JST
Interesting ports on colinux (192.168.1.30):
Not shown: 997 closed ports
PORT STATE SERVICE
5902/tcp open vnc-2
5903/tcp open vnc-3
5904/tcp open unknown
5905/tcp open unknown
Nmap finished: 1 IP address (1 host up) scanned in 0.120 seconds
書き換えたら、半分VNCが使っているとなってこれは?!と思ったんですが
やっぱ同じ現象でVNCでつないだらすぐ画面がおちますね。
その通りですね。ローカル?host?のcolinux動かしているWinXPからinetd
経由でVNCServerを立ち上げようとするとできないということですね。
>>297
colinux:/etc# nmap -p 5000-6000 colinux
Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2009-02-28 08:30 JST
Interesting ports on colinux (192.168.1.30):
Not shown: 997 closed ports
PORT STATE SERVICE
5902/tcp open vnc-2
5903/tcp open vnc-3
5904/tcp open unknown
5905/tcp open unknown
Nmap finished: 1 IP address (1 host up) scanned in 0.120 seconds
書き換えたら、半分VNCが使っているとなってこれは?!と思ったんですが
やっぱ同じ現象でVNCでつないだらすぐ画面がおちますね。
299298
2009/02/28(土) 09:15:07ID:7NYT0Onr Xvncの動作をコンソールでみてみました。
colinux:/etc# Xvnc -geometry 1024x768 -depth 16
- 中略 -
28/02/09 09:08:22 Desktop name 'x11' (colinux:0)
28/02/09 09:08:22 Protocol version supported 3.3
28/02/09 09:08:22 Listening for VNC connections on TCP port 5900
Font directory '/usr/share/fonts/X11/Speedo/' not found - ignoring
Font directory '/usr/share/fonts/X11/75dpi/' not found - ignoring
Font directory '/usr/share/fonts/X11/100dpi/' not found - ignoring
となっていたので、 /usr/share/fonts/X11/をみにいったら、
これらのフォルダがなかったです。
これってどうやったらインストールできるんですかね?
とりあえずgoogleっても昔は'/usr/X11R6/lib/X11/fonts/Speedo/'にあったんよー
みたいな事しか出てこなくて、入れ方までは見つからなかったです・・・。
colinux:/etc# Xvnc -geometry 1024x768 -depth 16
- 中略 -
28/02/09 09:08:22 Desktop name 'x11' (colinux:0)
28/02/09 09:08:22 Protocol version supported 3.3
28/02/09 09:08:22 Listening for VNC connections on TCP port 5900
Font directory '/usr/share/fonts/X11/Speedo/' not found - ignoring
Font directory '/usr/share/fonts/X11/75dpi/' not found - ignoring
Font directory '/usr/share/fonts/X11/100dpi/' not found - ignoring
となっていたので、 /usr/share/fonts/X11/をみにいったら、
これらのフォルダがなかったです。
これってどうやったらインストールできるんですかね?
とりあえずgoogleっても昔は'/usr/X11R6/lib/X11/fonts/Speedo/'にあったんよー
みたいな事しか出てこなくて、入れ方までは見つからなかったです・・・。
2009/02/28(土) 10:48:45ID:XItzrazz
>>299
立ち上げてみるだけなら、そのエラー無視して良いし。
そろそろ、servicesとかinetd.confとかのvncに関係する箇所、晒してくれん?
あと、ついでにvncserverとclientでどれ使ってるのか。パッケージか野良か。
立ち上げてみるだけなら、そのエラー無視して良いし。
そろそろ、servicesとかinetd.confとかのvncに関係する箇所、晒してくれん?
あと、ついでにvncserverとclientでどれ使ってるのか。パッケージか野良か。
2009/02/28(土) 13:10:18ID:XItzrazz
もしかして、coの標準設定だとメモリ不足とか? て思うてcoのstable落としてdebianのrootFS落として
>>255の参考pageどおりにtightvncserverとultravncとxdmで設定してみた。なんも問題ねぇや。
や、ちとxdmの関係でそうなん? てのはあるけど、設定変更のたびにshutdownで無問題だし、>>255の
pageには/etc/X11/xdm-configってあるけど、これは/etc/X11/xdm/xdm-configだよな、てのもあるけど、
別にxdmのlogin画面が出てこないだけで、Xの画面は出てくるし。
しっかし。colinux on windowsxp on ubuntu(vmware)ってのは、なんだ。なんかすげぇ。
>>255の参考pageどおりにtightvncserverとultravncとxdmで設定してみた。なんも問題ねぇや。
や、ちとxdmの関係でそうなん? てのはあるけど、設定変更のたびにshutdownで無問題だし、>>255の
pageには/etc/X11/xdm-configってあるけど、これは/etc/X11/xdm/xdm-configだよな、てのもあるけど、
別にxdmのlogin画面が出てこないだけで、Xの画面は出てくるし。
しっかし。colinux on windowsxp on ubuntu(vmware)ってのは、なんだ。なんかすげぇ。
302298
2009/02/28(土) 22:13:53ID:7NYT0Onr スレの皆様には申し訳ないね・・・。3週間くらいこの状態から進めないんですわ。
現状のservice
# Local services
vnc-1024x768x8 5902/tcp
vnc-1024x768x32 5903/tcp
vnc-1280x1024x8 5904/tcp
vnc-1280x1024x32 5905/tcp
現状のinetd.conf
#:OTHER: Other services
vnc-1024x768x8 stream tcp nowait nobody /usr/bin/Xvnc Xvnc -inetd -query colin
ux -once -geometry 1024x768 -depth 8 -cc 3
vnc-1024x768x32 stream tcp nowait nobody /usr/bin/Xvnc Xvnc -inetd -query colin
ux -once -geometry 1024x768 -depth 32
vnc-1280x1024x8 stream tcp nowait nobody /usr/bin/Xvnc Xvnc -inetd -query colin
ux -once -geometry 1280x1024 -depth 8 -cc 3
vnc-1280x1024x32 stream tcp nowait nobody /usr/bin/Xvnc Xvnc -inetd -query colin
ux -once -geometry 1280x1024 -depth 32
vncserver: tightvncserver
client : UltraVNC
パッケージで入れました。
周りにPCに詳しい人がいればその人に聞くんですけども、
周りにそんな人はいなくてホントスレ汚しでもうしわけない・・・。
現状のservice
# Local services
vnc-1024x768x8 5902/tcp
vnc-1024x768x32 5903/tcp
vnc-1280x1024x8 5904/tcp
vnc-1280x1024x32 5905/tcp
現状のinetd.conf
#:OTHER: Other services
vnc-1024x768x8 stream tcp nowait nobody /usr/bin/Xvnc Xvnc -inetd -query colin
ux -once -geometry 1024x768 -depth 8 -cc 3
vnc-1024x768x32 stream tcp nowait nobody /usr/bin/Xvnc Xvnc -inetd -query colin
ux -once -geometry 1024x768 -depth 32
vnc-1280x1024x8 stream tcp nowait nobody /usr/bin/Xvnc Xvnc -inetd -query colin
ux -once -geometry 1280x1024 -depth 8 -cc 3
vnc-1280x1024x32 stream tcp nowait nobody /usr/bin/Xvnc Xvnc -inetd -query colin
ux -once -geometry 1280x1024 -depth 32
vncserver: tightvncserver
client : UltraVNC
パッケージで入れました。
周りにPCに詳しい人がいればその人に聞くんですけども、
周りにそんな人はいなくてホントスレ汚しでもうしわけない・・・。
2009/03/01(日) 01:06:48ID:3QmsLvSN
>>302
オレはどうオチが付くのか楽しみではあるんだが、スレチな危惧。
・coでvncserver :1で立ち上げればwinでvncviewerでcolinux:1で正常動作?
・winでvncviewerは、colinux:2 〜 colinux:5 で接続したとき、具体的にviewerはどうなる? messageとかは?
・上でコケたときのco側でのnetstat -lの結果
・co側でcolinuxで名前解決はできてる? inetd.confの -query colinux を -query 127.0.0.1 とすると?
・tightvncserverとxdmをいったんpurgeしてからinstallしなおして、/etc/X11/xdm/下のXaccess, Xserver, xdm-config
を修正してcoをrebootしてみる。
・設定変更したときは、念のためcoをrebootする。
>>298
vnc-2とか3とかって出て、他unknownなのは、単に5902と5903が/usr/share/nmap/nmap-servicesに
登録されてるってだけだから。
オレはどうオチが付くのか楽しみではあるんだが、スレチな危惧。
・coでvncserver :1で立ち上げればwinでvncviewerでcolinux:1で正常動作?
・winでvncviewerは、colinux:2 〜 colinux:5 で接続したとき、具体的にviewerはどうなる? messageとかは?
・上でコケたときのco側でのnetstat -lの結果
・co側でcolinuxで名前解決はできてる? inetd.confの -query colinux を -query 127.0.0.1 とすると?
・tightvncserverとxdmをいったんpurgeしてからinstallしなおして、/etc/X11/xdm/下のXaccess, Xserver, xdm-config
を修正してcoをrebootしてみる。
・設定変更したときは、念のためcoをrebootする。
>>298
vnc-2とか3とかって出て、他unknownなのは、単に5902と5903が/usr/share/nmap/nmap-servicesに
登録されてるってだけだから。
2009/03/01(日) 02:36:36ID:MVYY+8s4
過疎ってるんだし、スレチでも最後までやって欲しいなぁ。
俺も着陸地点が気になってきたよw
俺も着陸地点が気になってきたよw
2009/03/01(日) 03:30:17ID:/ZDbmZ5t
そもそもディスプレイマネージャ何つかってんの?
306298
2009/03/01(日) 09:14:11ID:plGeOcYq >>303
>・coでvncserver :1で立ち上げればwinでvncviewerでcolinux:1で正常動作?
正常に使えます
・winでvncviewerは、colinux:2 〜 colinux:5 で接続したとき、具体的にviewerはどうなる? messageとかは?
とりあえずcolinux:4 or :5で繋ぐとウインドウサイズが大きくなります。
ただ、接続後3.23秒後(5回平均)に画面が勝手に消えます。VNCクライアントの画面が
Alt+F4を押したときの様に勝手に消えます。
エラーメッセージボックスみたいなものが時折見えますが、表示されている最中に
消えてしまいみられません。
>・上でコケたときのco側でのnetstat -lの結果
これはVNC立ち上げて、落ちた後で良いですかね?
colinux:~# netstat -l
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 localhost:mysql *:* LISTEN
tcp 0 0 *:netbios-ssn *:* LISTEN
tcp 0 0 *:vnc-1024x768x8 *:* LISTEN
tcp 0 0 *:vnc-1024x768x32 *:* LISTEN
tcp 0 0 *:x11 *:* LISTEN
tcp 0 0 *:vnc-1280x1024x8 *:* LISTEN
tcp 0 0 *:vnc-1280x1024x32 *:* LISTEN
>・coでvncserver :1で立ち上げればwinでvncviewerでcolinux:1で正常動作?
正常に使えます
・winでvncviewerは、colinux:2 〜 colinux:5 で接続したとき、具体的にviewerはどうなる? messageとかは?
とりあえずcolinux:4 or :5で繋ぐとウインドウサイズが大きくなります。
ただ、接続後3.23秒後(5回平均)に画面が勝手に消えます。VNCクライアントの画面が
Alt+F4を押したときの様に勝手に消えます。
エラーメッセージボックスみたいなものが時折見えますが、表示されている最中に
消えてしまいみられません。
>・上でコケたときのco側でのnetstat -lの結果
これはVNC立ち上げて、落ちた後で良いですかね?
colinux:~# netstat -l
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 localhost:mysql *:* LISTEN
tcp 0 0 *:netbios-ssn *:* LISTEN
tcp 0 0 *:vnc-1024x768x8 *:* LISTEN
tcp 0 0 *:vnc-1024x768x32 *:* LISTEN
tcp 0 0 *:x11 *:* LISTEN
tcp 0 0 *:vnc-1280x1024x8 *:* LISTEN
tcp 0 0 *:vnc-1280x1024x32 *:* LISTEN
307298
2009/03/01(日) 09:14:41ID:plGeOcYq tcp 0 0 localhost:smtp *:* LISTEN
tcp 0 0 *:microsoft-ds *:* LISTEN
tcp6 0 0 *:x11 *:* LISTEN
tcp6 0 0 *:www *:* LISTEN
tcp6 0 0 *:ssh *:* LISTEN
tcp6 0 0 *:39607 *:* LISTEN
udp 0 0 colinux:netbios-ns *:*
udp 0 0 *:netbios-ns *:*
udp 0 0 colinux:netbios-dgm *:*
udp 0 0 *:netbios-dgm *:*
udp6 0 0 *:xdmcp *:*
Active UNIX domain sockets (only servers)
Proto RefCnt Flags Type State I-Node Path
unix 2 [ ACC ] STREAM LISTENING 5901 /var/run/mysqld/mysqld.sock
unix 2 [ ACC ] STREAM LISTENING 6485 /tmp/.X11-unix/X0
・co側でcolinuxで名前解決はできてる? inetd.confの -query colinux を -query 127.0.0.1 とすると?
だめでした・・・。
・tightvncserverとxdmをいったんpurgeしてからinstallしなおして、/etc/X11/xdm/下のXaccess, Xserver, xdm-config
を修正してcoをrebootしてみる。
・設定変更したときは、念のためcoをrebootする。
だめでした・・・。
>>304 ありがとうございます。皆様の暖かい支援を力に変えて私たちは
頑張っておりますと選挙カーがいっておりました。
>>305
icewm,icewm-theme ですね。以前Linuxを教えてもらってた友人に
iceはおまえの様に軽くて存在感の無いメモリ喰わない奴だから良いよと。
tcp 0 0 *:microsoft-ds *:* LISTEN
tcp6 0 0 *:x11 *:* LISTEN
tcp6 0 0 *:www *:* LISTEN
tcp6 0 0 *:ssh *:* LISTEN
tcp6 0 0 *:39607 *:* LISTEN
udp 0 0 colinux:netbios-ns *:*
udp 0 0 *:netbios-ns *:*
udp 0 0 colinux:netbios-dgm *:*
udp 0 0 *:netbios-dgm *:*
udp6 0 0 *:xdmcp *:*
Active UNIX domain sockets (only servers)
Proto RefCnt Flags Type State I-Node Path
unix 2 [ ACC ] STREAM LISTENING 5901 /var/run/mysqld/mysqld.sock
unix 2 [ ACC ] STREAM LISTENING 6485 /tmp/.X11-unix/X0
・co側でcolinuxで名前解決はできてる? inetd.confの -query colinux を -query 127.0.0.1 とすると?
だめでした・・・。
・tightvncserverとxdmをいったんpurgeしてからinstallしなおして、/etc/X11/xdm/下のXaccess, Xserver, xdm-config
を修正してcoをrebootしてみる。
・設定変更したときは、念のためcoをrebootする。
だめでした・・・。
>>304 ありがとうございます。皆様の暖かい支援を力に変えて私たちは
頑張っておりますと選挙カーがいっておりました。
>>305
icewm,icewm-theme ですね。以前Linuxを教えてもらってた友人に
iceはおまえの様に軽くて存在感の無いメモリ喰わない奴だから良いよと。
2009/03/01(日) 12:53:24ID:3QmsLvSN
icewmはウィンドウマネージャ。>>305が聞いてるのはディスプレイマネージャ。
で、xdmなら、ためしにwdmにしてみたらどう? apt-get install wdmで入れて、
/etc/X11/wdm/でxdmと同様に、Xaccessは元から変更済み、Xserverとwdm-configを修正。
あと/etc/X11/default-display-managerを/usr/bin/X11/xdmから/usr/bin/wdmに修正。
X11の有無に注意。こっちはまちっとsyslogになんか残してくれる。ような気がする。
で、念のため2回ほどshutdown -rしてvncviewerで繋げてみる。
あ、もひとつ。default-display-managerのみ修正して2回shutdown -rしてps -eでxdmが起動してなくて
wdmが起動してるの確認して、vncviewerで繋げたとき、wdm-config修正してshutdown -rしてvncviewer
で繋げたとき、Xserverも修正してshutdown -rしてvncviewerで繋げたとき、で挙動に変化があるか?
で、xdmなら、ためしにwdmにしてみたらどう? apt-get install wdmで入れて、
/etc/X11/wdm/でxdmと同様に、Xaccessは元から変更済み、Xserverとwdm-configを修正。
あと/etc/X11/default-display-managerを/usr/bin/X11/xdmから/usr/bin/wdmに修正。
X11の有無に注意。こっちはまちっとsyslogになんか残してくれる。ような気がする。
で、念のため2回ほどshutdown -rしてvncviewerで繋げてみる。
あ、もひとつ。default-display-managerのみ修正して2回shutdown -rしてps -eでxdmが起動してなくて
wdmが起動してるの確認して、vncviewerで繋げたとき、wdm-config修正してshutdown -rしてvncviewer
で繋げたとき、Xserverも修正してshutdown -rしてvncviewerで繋げたとき、で挙動に変化があるか?
309298
2009/03/01(日) 20:06:30ID:plGeOcYq >>308
↑側をやったら動きました!
これはXdmがわるかったってことですかね?何がわるかったのやら?
gdmでも動かなかったんですけど、wdmだったらおkな理由がわからないですね・・。
一応/var/log/syslogデータを
Mar 1 20:02:13 colinux wdm: Could not init font path element /usr/share/fonts/X
11/100dpi, removing from list!
Mar 1 20:02:13 colinux wdm: Could not init font path element /usr/share/fonts/X
11/75dpi, removing from list!
Mar 1 20:02:13 colinux wdm: /etc/X11/wdm/Xresources_0: line 1: /etc/X11/wdm/Xre
sources_0: Permission denied
Mar 1 20:02:13 colinux wdm: /etc/X11/wdm/Xresources_0: line 2: syntax error nea
r unexpected token `newline'
Mar 1 20:02:13 colinux wdm: /etc/X11/wdm/Xresources_0: line 2: `!'
Mar 1 20:02:13 colinux wdm: Cannot open config file. Using builtin defaults
Mar 1 20:02:20 colinux kernel: eth0: no IPv6 routers present
Mar 1 20:02:22 colinux wdm: wdmLogin warning: WINGs: could not load widget imag
es file: could not open file
Mar 1 20:03:57 colinux wdm: /etc/X11/wdm/Xresources: line 1: /etc/X11/wdm/Xreso
urces: Permission denied
Mar 1 20:03:57 colinux wdm: /etc/X11/wdm/Xresources: line 2: syntax error near
unexpected token `newline'
Mar 1 20:03:57 colinux wdm: /etc/X11/wdm/Xresources: line 2: `!'
Mar 1 20:03:57 colinux wdm: Cannot open config file. Using builtin defaults
Mar 1 20:03:58 colinux wdm: wdmLogin warning: WINGs: could not load widget imag
es file: could not open file
Mar 1 20:04:06 colinux wdm: cat: /home/itoh/.wm_style: No such file or director
y
↑側をやったら動きました!
これはXdmがわるかったってことですかね?何がわるかったのやら?
gdmでも動かなかったんですけど、wdmだったらおkな理由がわからないですね・・。
一応/var/log/syslogデータを
Mar 1 20:02:13 colinux wdm: Could not init font path element /usr/share/fonts/X
11/100dpi, removing from list!
Mar 1 20:02:13 colinux wdm: Could not init font path element /usr/share/fonts/X
11/75dpi, removing from list!
Mar 1 20:02:13 colinux wdm: /etc/X11/wdm/Xresources_0: line 1: /etc/X11/wdm/Xre
sources_0: Permission denied
Mar 1 20:02:13 colinux wdm: /etc/X11/wdm/Xresources_0: line 2: syntax error nea
r unexpected token `newline'
Mar 1 20:02:13 colinux wdm: /etc/X11/wdm/Xresources_0: line 2: `!'
Mar 1 20:02:13 colinux wdm: Cannot open config file. Using builtin defaults
Mar 1 20:02:20 colinux kernel: eth0: no IPv6 routers present
Mar 1 20:02:22 colinux wdm: wdmLogin warning: WINGs: could not load widget imag
es file: could not open file
Mar 1 20:03:57 colinux wdm: /etc/X11/wdm/Xresources: line 1: /etc/X11/wdm/Xreso
urces: Permission denied
Mar 1 20:03:57 colinux wdm: /etc/X11/wdm/Xresources: line 2: syntax error near
unexpected token `newline'
Mar 1 20:03:57 colinux wdm: /etc/X11/wdm/Xresources: line 2: `!'
Mar 1 20:03:57 colinux wdm: Cannot open config file. Using builtin defaults
Mar 1 20:03:58 colinux wdm: wdmLogin warning: WINGs: could not load widget imag
es file: could not open file
Mar 1 20:04:06 colinux wdm: cat: /home/itoh/.wm_style: No such file or director
y
2009/03/01(日) 21:12:47ID:3QmsLvSN
>>309
itohさんオメっ。
でま、せっかくなんで、次に考えていたことだけど。
・etchは最新? securityも含めupgradeしてる? ← むかし、xdmはうまくいかない、てネタがあったはず。
・pam関係でなんか弄ってない?
現象を考えるに、xdm動かそうとして、なんでか即logoutってなってんのかな? と。ただ、どうすりゃ
それができるのかさっぱりオレにゃわからんかった。うちで再現しねぇ。
xdmとgdmでいっしょでwdmのみ違う、/etc/pam.d/の設定とか? わからん。気が向いたらまちっと
追求して、なんかわかったらココで報告してくり。
itohさんオメっ。
でま、せっかくなんで、次に考えていたことだけど。
・etchは最新? securityも含めupgradeしてる? ← むかし、xdmはうまくいかない、てネタがあったはず。
・pam関係でなんか弄ってない?
現象を考えるに、xdm動かそうとして、なんでか即logoutってなってんのかな? と。ただ、どうすりゃ
それができるのかさっぱりオレにゃわからんかった。うちで再現しねぇ。
xdmとgdmでいっしょでwdmのみ違う、/etc/pam.d/の設定とか? わからん。気が向いたらまちっと
追求して、なんかわかったらココで報告してくり。
2009/03/01(日) 21:16:23ID:3QmsLvSN
で、次はxmingとか? いちおはxserverだしxmingは速そうだ。
2009/03/03(火) 19:36:24ID:SrWpxbF1
>>292
自己レスです。
Linux側の問題でなく、colinux-daemon.exeを手動起動したら、cofsを通じて「俺@win」所有のファイルが出来ました。
andLinuxインストーラは、colinux-daemon.exeをMS-Windowsの「サービス」に登録する際、Administratorで走るようにsetuid(?)みたいなことをするようです。
分かってしまえば、何だ…ですが、そこに到るまでcofs設定を試行錯誤するばかりでした。
自己レスです。
Linux側の問題でなく、colinux-daemon.exeを手動起動したら、cofsを通じて「俺@win」所有のファイルが出来ました。
andLinuxインストーラは、colinux-daemon.exeをMS-Windowsの「サービス」に登録する際、Administratorで走るようにsetuid(?)みたいなことをするようです。
分かってしまえば、何だ…ですが、そこに到るまでcofs設定を試行錯誤するばかりでした。
313298
2009/03/03(火) 20:00:29ID:nfJ+ROMl■ このスレッドは過去ログ倉庫に格納されています
ニュース
- 【速報】福原遥(まいんちゃん)とサッカー日本代表の久保建英がまさかの電撃結婚★6 [爆笑ゴリラ★]
- 大阪・清風高校で「カンニング指導」後に生徒が自殺「無関係とは決して思っていない」両親が1億円余の損害賠償求める★2 [七波羅探題★]
- 【速報】福原遥(まいんちゃん)とサッカー日本代表の久保建英がまさかの電撃結婚★7 [爆笑ゴリラ★]
- 【サッカー】なでしこジャパン、難敵・北朝鮮を下し大会3連覇の金メダル!PK戦の死闘を制し史上最多4度目Vの快挙 [ゴアマガラ★]
- 「ロシアへの姿勢変えたのは日本」プーチン大統領 関係悪化は日本の責任との認識示す [煮卵★]
- 【東京】10階以上の高さの工事現場から落ちてきた約1メートルの鉄骨が首に刺さる 2階にいた50代男性作業員が死亡 [煮卵★]
- 【実況】博衣こよりのえちえちこんこよ高校2026-2年目春甲子園-🧪★6
- 【高市悲報】地球上最悪の侵略的植物と言われる、水草「ナガエツルノゲイトウ」大分で群生確認!茎や根の小さな断片からでも再生しつこい [219241683]
- 【正論】岩屋前外相会見。「日中関係悪化の原因を作ったのは高市。中国はめっちゃ怒ってる」 [668024367]
- 【急募】ガチで萎える女の趣味wwwwwwwwwwwwwWWWwwwwwwwwwwwww [632596506]
- アセ顔ダブルピース✌😅✌の🏡
- 産経新聞、簗農水大臣にガチギレ [931948549]