MS-Windows を仕方なく使っている貴方
Cygwin は偽者だとお嘆きの貴方
Windows 上で動作する本物の Linux 環境 coLinux を試してみませんか?
過去スレ
1: http://pc5.2ch.net/test/read.cgi/linux/1075620397/
2: http://pc5.2ch.net/test/read.cgi/linux/1086256260/
3: http://pc5.2ch.net/test/read.cgi/linux/1098153141/
4: http://pc8.2ch.net/test/read.cgi/linux/1108224327/
5: http://pc8.2ch.net/test/read.cgi/linux/1126305825/
6: http://pc11.2ch.net/test/read.cgi/linux/1158677481/
coLinux野郎ぜ! Part7
■ このスレッドは過去ログ倉庫に格納されています
1login:Penguin
2008/03/29(土) 13:52:29ID:wqE/gesx2009/02/24(火) 22:05:32ID:cCJ8TwiI
2009/02/24(火) 23:14:10ID:IisX/m8b
2009/02/25(水) 02:13:25ID:BE3K+L/u
とりあえず接続した時のログ読んでみたらいいんじゃない?
xdmが立ちあがってるかどうかとか、
プロセスにvncserverが出てくるかどうかとか
調べるところは山ほどある。
xdmが立ちあがってるかどうかとか、
プロセスにvncserverが出てくるかどうかとか
調べるところは山ほどある。
2009/02/25(水) 09:02:20ID:vmoVB4V+
うちのcoじゃないlennyにtightvncserver入れてやってみた。coのPC名、colinuxから
変えてね? で、-queryオプションにcolinuxのまんま設定してね? ついでに、XDMCPが
使うportを実は閉じたりしてね?
ただ、これだとconection refuseな気がするな。
変えてね? で、-queryオプションにcolinuxのまんま設定してね? ついでに、XDMCPが
使うportを実は閉じたりしてね?
ただ、これだとconection refuseな気がするな。
267245
2009/02/25(水) 09:03:47ID:wt/GQg/Y aptーget updateがうまく行かない原因はWindowsのファイアウォールが邪魔してました。
TAPとローカルエリア接続のプロパティから詳細設定でファイアウォールを無効にしたら開通しました。
すみませんお騒がせしました。
では。。
TAPとローカルエリア接続のプロパティから詳細設定でファイアウォールを無効にしたら開通しました。
すみませんお騒がせしました。
では。。
2009/02/25(水) 09:27:11ID:IPYnAKn/
処女開通オメデト!
269245
2009/02/25(水) 09:52:22ID:wt/GQg/Y2009/02/25(水) 17:06:46ID:02jWc0KV
>>264
とりあえず、xdmcp接続の許可はしてあるの?
とりあえず、xdmcp接続の許可はしてあるの?
2009/02/25(水) 18:33:58ID:CyPn+iJl
処女姦通、俺も死ぬまでに一回くらいはしてみたい
2009/02/25(水) 21:37:46ID:C2XA3VrT
>>245
開通オメ
>>266
colinuxのPC名とかは大丈夫ですね。
>>270
XDMCP接続許可は・・・わからないですね。GNOMEだとメニューから
できるそうなんですけど。
あと、接続時にvncserverは立ち上がっていないので、inetdあたりが怪しい
のかなと考えて以下のことをやってみました。
colinux:~# Xvnc -query colinux -geometry 1024x768
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.
で言われたとおりにやってみると
colinux:~# rm /tmp/.X0-lock
colinux:~# Xvnc -query colinux -geometry 1024x768
_XSERVTransSocketINETCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already running
となって全く別のところに問題があるんですかね?
ここまでくると、再インストールした方が早そうなんですが、
何となくうだうだとやってしまいます・・・。
開通オメ
>>266
colinuxのPC名とかは大丈夫ですね。
>>270
XDMCP接続許可は・・・わからないですね。GNOMEだとメニューから
できるそうなんですけど。
あと、接続時にvncserverは立ち上がっていないので、inetdあたりが怪しい
のかなと考えて以下のことをやってみました。
colinux:~# Xvnc -query colinux -geometry 1024x768
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.
で言われたとおりにやってみると
colinux:~# rm /tmp/.X0-lock
colinux:~# Xvnc -query colinux -geometry 1024x768
_XSERVTransSocketINETCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already running
となって全く別のところに問題があるんですかね?
ここまでくると、再インストールした方が早そうなんですが、
何となくうだうだとやってしまいます・・・。
2009/02/25(水) 21:50:45ID:pQxfQuCO
>>272
> If this server is no longer running, remove /tmp/.X0-lock
> and start again.
> で言われたとおりにやってみると
If this server is no longer running を見なかったことにすんなw
> If this server is no longer running, remove /tmp/.X0-lock
> and start again.
> で言われたとおりにやってみると
If this server is no longer running を見なかったことにすんなw
2009/02/25(水) 21:52:41ID:vmoVB4V+
vncserverとして、どのパッケージの使ってるのかわからんけど、
TightVNCだと、vncserverを立ち上げた状態で>>272なことやると、
似たようなエラーを吐くなぁ。
#Xvnc -query hoge
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock and start again.
#rm /tmp/.X0-lock
#Xvnc -query hoge
_XSERVTransSocketINETCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already running
TightVNCだと、vncserverを立ち上げた状態で>>272なことやると、
似たようなエラーを吐くなぁ。
#Xvnc -query hoge
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock and start again.
#rm /tmp/.X0-lock
#Xvnc -query hoge
_XSERVTransSocketINETCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already running
2009/02/25(水) 21:56:05ID:vmoVB4V+
あれ? 似たような、てか、まんま一緒?
ちなみに、vncserver立ち上げてないと
25/02/09 21:43:43 Xvnc version TightVNC-1.3.9
25/02/09 21:43:43 Copyright (C) 2000-2007 TightVNC Group
25/02/09 21:43:43 Copyright (C) 1999 AT&T Laboratories Cambridge
25/02/09 21:43:43 All Rights Reserved.
25/02/09 21:43:43 See http://www.tightvnc.com/ for information on TightVNC
25/02/09 21:43:43 Desktop name 'x11' (hage:0)
25/02/09 21:43:43 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
25/02/09 21:43:43 Listening for VNC connections on TCP port 5900
・
・
・
ちなみに、vncserver立ち上げてないと
25/02/09 21:43:43 Xvnc version TightVNC-1.3.9
25/02/09 21:43:43 Copyright (C) 2000-2007 TightVNC Group
25/02/09 21:43:43 Copyright (C) 1999 AT&T Laboratories Cambridge
25/02/09 21:43:43 All Rights Reserved.
25/02/09 21:43:43 See http://www.tightvnc.com/ for information on TightVNC
25/02/09 21:43:43 Desktop name 'x11' (hage:0)
25/02/09 21:43:43 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
25/02/09 21:43:43 Listening for VNC connections on TCP port 5900
・
・
・
2009/02/25(水) 22:35:47ID:BE3K+L/u
Server is already active for display 0
これじゃないの?
これじゃないの?
2009/02/25(水) 22:45:05ID:C2XA3VrT
>>273-276
Serverが既にたっていることも考えたんですけど、こんな状態
なので、立っていないってことですよね?
colinux:~# ps aux | grep vnc
root 2912 0.0 0.1 1644 512 pts/0 R+ 22:46 0:00 grep vnc
と思って無視したんですけど・・・間違いですかね?
Serverが既にたっていることも考えたんですけど、こんな状態
なので、立っていないってことですよね?
colinux:~# ps aux | grep vnc
root 2912 0.0 0.1 1644 512 pts/0 R+ 22:46 0:00 grep vnc
と思って無視したんですけど・・・間違いですかね?
2009/02/26(木) 00:43:04ID:FLhJSxFv
5900+αあたりとか、6000あたりとかのportは使われてねぇの?
2009/02/26(木) 01:36:23ID:9N9udLDp
2009/02/26(木) 07:39:10ID:FLhJSxFv
vnc使おうとして、なにがどうなって困ってるんだっけ?
実はvncは動いていて、xdmが動いてくれていない、とか?
いや、実はオレがそうなんだが。今回のコレで試してみたら
動かねぇなぁ、と。あんまし追求する気もないけどさ。
実はvncは動いていて、xdmが動いてくれていない、とか?
いや、実はオレがそうなんだが。今回のコレで試してみたら
動かねぇなぁ、と。あんまし追求する気もないけどさ。
2009/02/26(木) 08:14:37ID:YkDQm/RW
>>278-279
colinux:~# nmap colinux
Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2009-02-26 08:11 JST
Interesting ports on colinux (192.168.1.30):
Not shown: 1675 closed ports
PORT STATE SERVICE
22/tcp open ssh
80/tcp open http
139/tcp open netbios-ssn
445/tcp open microsoft-ds
6000/tcp open X11
Nmap finished: 1 IP address (1 host up) scanned in 0.150 seconds
6000は使われてるんですかね?
>>279
それはどういう意味ですかね?inetdでVNCを設定してはいけないということですか?
>>280
VNCが動かない状態ですね。xdmが動く動かない以前の問題です。
さてそろそろ仕事にいってきます ノシ
colinux:~# nmap colinux
Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2009-02-26 08:11 JST
Interesting ports on colinux (192.168.1.30):
Not shown: 1675 closed ports
PORT STATE SERVICE
22/tcp open ssh
80/tcp open http
139/tcp open netbios-ssn
445/tcp open microsoft-ds
6000/tcp open X11
Nmap finished: 1 IP address (1 host up) scanned in 0.150 seconds
6000は使われてるんですかね?
>>279
それはどういう意味ですかね?inetdでVNCを設定してはいけないということですか?
>>280
VNCが動かない状態ですね。xdmが動く動かない以前の問題です。
さてそろそろ仕事にいってきます ノシ
2009/02/26(木) 15:30:16ID:WgdGCpwa
>>281
nmapは、念のため-pで範囲指定したのが良い。標準で全部のport調べるわけじゃないから。
あと、6000はxdmが使ってると思われ。
そんなわけで、vncserverとviewerは何使ってて、念のため入れなおしてみるとか、vncserverとかXvncとかxdmとかinetdとか
動いてるのか動いてないのか、その各場合における動作とか、もっかい整理したのが良いんじゃねぇの?
ついでに、いつものwindows fwが悪さ、とか、実はiptablesが、とか。
nmapは、念のため-pで範囲指定したのが良い。標準で全部のport調べるわけじゃないから。
あと、6000はxdmが使ってると思われ。
そんなわけで、vncserverとviewerは何使ってて、念のため入れなおしてみるとか、vncserverとかXvncとかxdmとかinetdとか
動いてるのか動いてないのか、その各場合における動作とか、もっかい整理したのが良いんじゃねぇの?
ついでに、いつものwindows fwが悪さ、とか、実はiptablesが、とか。
2009/02/26(木) 18:45:20ID:jm0iLqA5
2009/02/26(木) 20:15:24ID:YkDQm/RW
>>283
You get an error message like:
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.The number denotes the display number
(in this case 0). This number needs to be unique on the system, so you cannot run two servers on one system with identical display numbers. This message indicates that there is already a server with this number running on the system.
You can verify this by running
ps aux | grep `cat /tmp/.X0-lock`If you see an output like:
root 2283 0.5 5.1 27796 6536 ? S Apr21 59:03 [X]it indicates that there is indeed an Xserver running under this PID. To start a second server on the same system you have to give it a different dislay number.
If you start your servers using startx you can do
startx -- :1to start a server with display number 1. If you are sure there is no other server running on your system and above ps command indicates that no server with this PID is running, you should remove the file
/tmp/.X0-lock by doing (as 'root'):
rm -rf /tmp/.X0-lock
ってことで、
ps aux | grep vnc
でvncserverがたっているか捜していなかったので、Server二重起動ではないと
踏んでいたのですが、探し方まちがいですかね?
You get an error message like:
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.The number denotes the display number
(in this case 0). This number needs to be unique on the system, so you cannot run two servers on one system with identical display numbers. This message indicates that there is already a server with this number running on the system.
You can verify this by running
ps aux | grep `cat /tmp/.X0-lock`If you see an output like:
root 2283 0.5 5.1 27796 6536 ? S Apr21 59:03 [X]it indicates that there is indeed an Xserver running under this PID. To start a second server on the same system you have to give it a different dislay number.
If you start your servers using startx you can do
startx -- :1to start a server with display number 1. If you are sure there is no other server running on your system and above ps command indicates that no server with this PID is running, you should remove the file
/tmp/.X0-lock by doing (as 'root'):
rm -rf /tmp/.X0-lock
ってことで、
ps aux | grep vnc
でvncserverがたっているか捜していなかったので、Server二重起動ではないと
踏んでいたのですが、探し方まちがいですかね?
2009/02/26(木) 21:00:55ID:WgdGCpwa
>>284
んだから、オレとしては、関係してそうなの全部落としてnmapを-p指定でやって、だれも待ち受けしてないのを確認した上で、
正しく必要なのを起動させて、念のためnmapで待ち受けを確認しつつ、やってみれば? と。
いちお、etchのbackports環境だけど、tightvncserverとwinのultravncclient、あとxdmで動作確認はした。
んだから、オレとしては、関係してそうなの全部落としてnmapを-p指定でやって、だれも待ち受けしてないのを確認した上で、
正しく必要なのを起動させて、念のためnmapで待ち受けを確認しつつ、やってみれば? と。
いちお、etchのbackports環境だけど、tightvncserverとwinのultravncclient、あとxdmで動作確認はした。
2009/02/26(木) 21:08:23ID:9N9udLDp
>>284
とりあえず、試すだけなら他のポートでやってみればいいじゃん。:1とか:2とか
とりあえず、試すだけなら他のポートでやってみればいいじゃん。:1とか:2とか
2009/02/27(金) 05:33:38ID:APUu9GJV
Xvfbってディスプレイナンバー使わんの?
2009/02/27(金) 07:24:13ID:E+vTF4Ha
ディスプレイ番号なら使ってると思うが
2009/02/27(金) 07:55:17ID:qT80Sjjj
えー、昨朝くだ質スレでcoLinuxを紹介されて、andLinuxを入れてしまいました。返答をくれた方、ありがとうございました。
ところで、このページの、
ttp://d.hatena.ne.jp/wadap/20080602/1212419216
1)xlogoの下あたりの「ランチャー」とは何のことでしょうか。
2)Windowsの画面に「Terminal」てのが無いのですが、どの/usr/bin/*term*を指しているか分かりますか? xfceてのを選択したので *xfce4* てのを使えば良いのかしら?
つか、xtermはどこ…
ところで、このページの、
ttp://d.hatena.ne.jp/wadap/20080602/1212419216
1)xlogoの下あたりの「ランチャー」とは何のことでしょうか。
2)Windowsの画面に「Terminal」てのが無いのですが、どの/usr/bin/*term*を指しているか分かりますか? xfceてのを選択したので *xfce4* てのを使えば良いのかしら?
つか、xtermはどこ…
2009/02/27(金) 09:58:26ID:oZADNwWJ
>>289
オレのことかーっ。
で、andってcoベースだったのか。知らんかった。ubuntuでxmingなのね。へぇ。
で。ランチャーって、windowsのスタートメニューに作られたフォルダって意味じゃねぇの? terminalはそこのショートカット。
参照しろってページの解説に、スタートメニューにandLinuxってフォルダ作るってインストール途中の画面にあるし。
で、そのterminalは設定によるから、入れてみんとわからん。xfceってそいや標準terminal持ってた気がするから、そうかも。
オレのことかーっ。
で、andってcoベースだったのか。知らんかった。ubuntuでxmingなのね。へぇ。
で。ランチャーって、windowsのスタートメニューに作られたフォルダって意味じゃねぇの? terminalはそこのショートカット。
参照しろってページの解説に、スタートメニューにandLinuxってフォルダ作るってインストール途中の画面にあるし。
で、そのterminalは設定によるから、入れてみんとわからん。xfceってそいや標準terminal持ってた気がするから、そうかも。
2009/02/27(金) 10:08:02ID:PYbVXS5O
2009/02/27(金) 19:30:49ID:ymxTMQHs
>>289
取り敢えず、自己レス。
MS-Windowsのランチャー==START MENUと思い込んでいたのですが、あにはからんや、画面最下行のタスクバー(だっけ?)に、xfce4-termを含むフォルダアイコンが出来ていました。
難し過ぎだよ…
>>290,291
レス有り難うございます。
もう一つ質問です。
andLinuxに「俺」でログインし、touch windowsDir/file し、MS-Windows側でfileを見ると所有者がAdminになってしまいます。
mount -t cofs -o username=俺@win,uid=俺@linux ...
などとやろうとしたのですが、cofsにusernameオプションは無いようです。
MS-Windowsのファイル所有者が「俺」のファイルをcofsで作成するためには、一般的にはどんな方法がありますか。
取り敢えず、自己レス。
MS-Windowsのランチャー==START MENUと思い込んでいたのですが、あにはからんや、画面最下行のタスクバー(だっけ?)に、xfce4-termを含むフォルダアイコンが出来ていました。
難し過ぎだよ…
>>290,291
レス有り難うございます。
もう一つ質問です。
andLinuxに「俺」でログインし、touch windowsDir/file し、MS-Windows側でfileを見ると所有者がAdminになってしまいます。
mount -t cofs -o username=俺@win,uid=俺@linux ...
などとやろうとしたのですが、cofsにusernameオプションは無いようです。
MS-Windowsのファイル所有者が「俺」のファイルをcofsで作成するためには、一般的にはどんな方法がありますか。
2009/02/27(金) 20:46:47ID:oZADNwWJ
>>292
cifsを使うってのはダメ?
cifsを使うってのはダメ?
294292
2009/02/27(金) 21:37:42ID:aRgI7Wi1 共有設定に、[非]技術的制約があるのです。
既に共有されているfsはsmbマウントしてるのですが、
c:\を共有設定することは出来ないのです。
既に共有されているfsはsmbマウントしてるのですが、
c:\を共有設定することは出来ないのです。
2009/02/27(金) 23:48:02ID:vlAIveXh
2009/02/28(土) 01:43:29ID:XItzrazz
>>295
すまん。オレが思っていた前提と違うんだが...
vncserverをコンソールから起動して、ならふつ〜に自分のログインセッションに繋がるけど、
inetd経由xvnc起動してxdmがダメ、じゃなかったん? 外からって、どこやねん。host? local? global?
すまん。オレが思っていた前提と違うんだが...
vncserverをコンソールから起動して、ならふつ〜に自分のログインセッションに繋がるけど、
inetd経由xvnc起動してxdmがダメ、じゃなかったん? 外からって、どこやねん。host? local? global?
2009/02/28(土) 01:46:57ID:XItzrazz
2009/02/28(土) 08:28:35ID:7NYT0Onr
>>296
その通りですね。ローカル?host?のcolinux動かしているWinXPからinetd
経由でVNCServerを立ち上げようとするとできないということですね。
>>297
colinux:/etc# nmap -p 5000-6000 colinux
Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2009-02-28 08:30 JST
Interesting ports on colinux (192.168.1.30):
Not shown: 997 closed ports
PORT STATE SERVICE
5902/tcp open vnc-2
5903/tcp open vnc-3
5904/tcp open unknown
5905/tcp open unknown
Nmap finished: 1 IP address (1 host up) scanned in 0.120 seconds
書き換えたら、半分VNCが使っているとなってこれは?!と思ったんですが
やっぱ同じ現象でVNCでつないだらすぐ画面がおちますね。
その通りですね。ローカル?host?のcolinux動かしているWinXPからinetd
経由でVNCServerを立ち上げようとするとできないということですね。
>>297
colinux:/etc# nmap -p 5000-6000 colinux
Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2009-02-28 08:30 JST
Interesting ports on colinux (192.168.1.30):
Not shown: 997 closed ports
PORT STATE SERVICE
5902/tcp open vnc-2
5903/tcp open vnc-3
5904/tcp open unknown
5905/tcp open unknown
Nmap finished: 1 IP address (1 host up) scanned in 0.120 seconds
書き換えたら、半分VNCが使っているとなってこれは?!と思ったんですが
やっぱ同じ現象でVNCでつないだらすぐ画面がおちますね。
299298
2009/02/28(土) 09:15:07ID:7NYT0Onr Xvncの動作をコンソールでみてみました。
colinux:/etc# Xvnc -geometry 1024x768 -depth 16
- 中略 -
28/02/09 09:08:22 Desktop name 'x11' (colinux:0)
28/02/09 09:08:22 Protocol version supported 3.3
28/02/09 09:08:22 Listening for VNC connections on TCP port 5900
Font directory '/usr/share/fonts/X11/Speedo/' not found - ignoring
Font directory '/usr/share/fonts/X11/75dpi/' not found - ignoring
Font directory '/usr/share/fonts/X11/100dpi/' not found - ignoring
となっていたので、 /usr/share/fonts/X11/をみにいったら、
これらのフォルダがなかったです。
これってどうやったらインストールできるんですかね?
とりあえずgoogleっても昔は'/usr/X11R6/lib/X11/fonts/Speedo/'にあったんよー
みたいな事しか出てこなくて、入れ方までは見つからなかったです・・・。
colinux:/etc# Xvnc -geometry 1024x768 -depth 16
- 中略 -
28/02/09 09:08:22 Desktop name 'x11' (colinux:0)
28/02/09 09:08:22 Protocol version supported 3.3
28/02/09 09:08:22 Listening for VNC connections on TCP port 5900
Font directory '/usr/share/fonts/X11/Speedo/' not found - ignoring
Font directory '/usr/share/fonts/X11/75dpi/' not found - ignoring
Font directory '/usr/share/fonts/X11/100dpi/' not found - ignoring
となっていたので、 /usr/share/fonts/X11/をみにいったら、
これらのフォルダがなかったです。
これってどうやったらインストールできるんですかね?
とりあえずgoogleっても昔は'/usr/X11R6/lib/X11/fonts/Speedo/'にあったんよー
みたいな事しか出てこなくて、入れ方までは見つからなかったです・・・。
2009/02/28(土) 10:48:45ID:XItzrazz
>>299
立ち上げてみるだけなら、そのエラー無視して良いし。
そろそろ、servicesとかinetd.confとかのvncに関係する箇所、晒してくれん?
あと、ついでにvncserverとclientでどれ使ってるのか。パッケージか野良か。
立ち上げてみるだけなら、そのエラー無視して良いし。
そろそろ、servicesとかinetd.confとかのvncに関係する箇所、晒してくれん?
あと、ついでにvncserverとclientでどれ使ってるのか。パッケージか野良か。
2009/02/28(土) 13:10:18ID:XItzrazz
もしかして、coの標準設定だとメモリ不足とか? て思うてcoのstable落としてdebianのrootFS落として
>>255の参考pageどおりにtightvncserverとultravncとxdmで設定してみた。なんも問題ねぇや。
や、ちとxdmの関係でそうなん? てのはあるけど、設定変更のたびにshutdownで無問題だし、>>255の
pageには/etc/X11/xdm-configってあるけど、これは/etc/X11/xdm/xdm-configだよな、てのもあるけど、
別にxdmのlogin画面が出てこないだけで、Xの画面は出てくるし。
しっかし。colinux on windowsxp on ubuntu(vmware)ってのは、なんだ。なんかすげぇ。
>>255の参考pageどおりにtightvncserverとultravncとxdmで設定してみた。なんも問題ねぇや。
や、ちとxdmの関係でそうなん? てのはあるけど、設定変更のたびにshutdownで無問題だし、>>255の
pageには/etc/X11/xdm-configってあるけど、これは/etc/X11/xdm/xdm-configだよな、てのもあるけど、
別にxdmのlogin画面が出てこないだけで、Xの画面は出てくるし。
しっかし。colinux on windowsxp on ubuntu(vmware)ってのは、なんだ。なんかすげぇ。
302298
2009/02/28(土) 22:13:53ID:7NYT0Onr スレの皆様には申し訳ないね・・・。3週間くらいこの状態から進めないんですわ。
現状のservice
# Local services
vnc-1024x768x8 5902/tcp
vnc-1024x768x32 5903/tcp
vnc-1280x1024x8 5904/tcp
vnc-1280x1024x32 5905/tcp
現状のinetd.conf
#:OTHER: Other services
vnc-1024x768x8 stream tcp nowait nobody /usr/bin/Xvnc Xvnc -inetd -query colin
ux -once -geometry 1024x768 -depth 8 -cc 3
vnc-1024x768x32 stream tcp nowait nobody /usr/bin/Xvnc Xvnc -inetd -query colin
ux -once -geometry 1024x768 -depth 32
vnc-1280x1024x8 stream tcp nowait nobody /usr/bin/Xvnc Xvnc -inetd -query colin
ux -once -geometry 1280x1024 -depth 8 -cc 3
vnc-1280x1024x32 stream tcp nowait nobody /usr/bin/Xvnc Xvnc -inetd -query colin
ux -once -geometry 1280x1024 -depth 32
vncserver: tightvncserver
client : UltraVNC
パッケージで入れました。
周りにPCに詳しい人がいればその人に聞くんですけども、
周りにそんな人はいなくてホントスレ汚しでもうしわけない・・・。
現状のservice
# Local services
vnc-1024x768x8 5902/tcp
vnc-1024x768x32 5903/tcp
vnc-1280x1024x8 5904/tcp
vnc-1280x1024x32 5905/tcp
現状のinetd.conf
#:OTHER: Other services
vnc-1024x768x8 stream tcp nowait nobody /usr/bin/Xvnc Xvnc -inetd -query colin
ux -once -geometry 1024x768 -depth 8 -cc 3
vnc-1024x768x32 stream tcp nowait nobody /usr/bin/Xvnc Xvnc -inetd -query colin
ux -once -geometry 1024x768 -depth 32
vnc-1280x1024x8 stream tcp nowait nobody /usr/bin/Xvnc Xvnc -inetd -query colin
ux -once -geometry 1280x1024 -depth 8 -cc 3
vnc-1280x1024x32 stream tcp nowait nobody /usr/bin/Xvnc Xvnc -inetd -query colin
ux -once -geometry 1280x1024 -depth 32
vncserver: tightvncserver
client : UltraVNC
パッケージで入れました。
周りにPCに詳しい人がいればその人に聞くんですけども、
周りにそんな人はいなくてホントスレ汚しでもうしわけない・・・。
2009/03/01(日) 01:06:48ID:3QmsLvSN
>>302
オレはどうオチが付くのか楽しみではあるんだが、スレチな危惧。
・coでvncserver :1で立ち上げればwinでvncviewerでcolinux:1で正常動作?
・winでvncviewerは、colinux:2 〜 colinux:5 で接続したとき、具体的にviewerはどうなる? messageとかは?
・上でコケたときのco側でのnetstat -lの結果
・co側でcolinuxで名前解決はできてる? inetd.confの -query colinux を -query 127.0.0.1 とすると?
・tightvncserverとxdmをいったんpurgeしてからinstallしなおして、/etc/X11/xdm/下のXaccess, Xserver, xdm-config
を修正してcoをrebootしてみる。
・設定変更したときは、念のためcoをrebootする。
>>298
vnc-2とか3とかって出て、他unknownなのは、単に5902と5903が/usr/share/nmap/nmap-servicesに
登録されてるってだけだから。
オレはどうオチが付くのか楽しみではあるんだが、スレチな危惧。
・coでvncserver :1で立ち上げればwinでvncviewerでcolinux:1で正常動作?
・winでvncviewerは、colinux:2 〜 colinux:5 で接続したとき、具体的にviewerはどうなる? messageとかは?
・上でコケたときのco側でのnetstat -lの結果
・co側でcolinuxで名前解決はできてる? inetd.confの -query colinux を -query 127.0.0.1 とすると?
・tightvncserverとxdmをいったんpurgeしてからinstallしなおして、/etc/X11/xdm/下のXaccess, Xserver, xdm-config
を修正してcoをrebootしてみる。
・設定変更したときは、念のためcoをrebootする。
>>298
vnc-2とか3とかって出て、他unknownなのは、単に5902と5903が/usr/share/nmap/nmap-servicesに
登録されてるってだけだから。
2009/03/01(日) 02:36:36ID:MVYY+8s4
過疎ってるんだし、スレチでも最後までやって欲しいなぁ。
俺も着陸地点が気になってきたよw
俺も着陸地点が気になってきたよw
2009/03/01(日) 03:30:17ID:/ZDbmZ5t
そもそもディスプレイマネージャ何つかってんの?
306298
2009/03/01(日) 09:14:11ID:plGeOcYq >>303
>・coでvncserver :1で立ち上げればwinでvncviewerでcolinux:1で正常動作?
正常に使えます
・winでvncviewerは、colinux:2 〜 colinux:5 で接続したとき、具体的にviewerはどうなる? messageとかは?
とりあえずcolinux:4 or :5で繋ぐとウインドウサイズが大きくなります。
ただ、接続後3.23秒後(5回平均)に画面が勝手に消えます。VNCクライアントの画面が
Alt+F4を押したときの様に勝手に消えます。
エラーメッセージボックスみたいなものが時折見えますが、表示されている最中に
消えてしまいみられません。
>・上でコケたときのco側でのnetstat -lの結果
これはVNC立ち上げて、落ちた後で良いですかね?
colinux:~# netstat -l
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 localhost:mysql *:* LISTEN
tcp 0 0 *:netbios-ssn *:* LISTEN
tcp 0 0 *:vnc-1024x768x8 *:* LISTEN
tcp 0 0 *:vnc-1024x768x32 *:* LISTEN
tcp 0 0 *:x11 *:* LISTEN
tcp 0 0 *:vnc-1280x1024x8 *:* LISTEN
tcp 0 0 *:vnc-1280x1024x32 *:* LISTEN
>・coでvncserver :1で立ち上げればwinでvncviewerでcolinux:1で正常動作?
正常に使えます
・winでvncviewerは、colinux:2 〜 colinux:5 で接続したとき、具体的にviewerはどうなる? messageとかは?
とりあえずcolinux:4 or :5で繋ぐとウインドウサイズが大きくなります。
ただ、接続後3.23秒後(5回平均)に画面が勝手に消えます。VNCクライアントの画面が
Alt+F4を押したときの様に勝手に消えます。
エラーメッセージボックスみたいなものが時折見えますが、表示されている最中に
消えてしまいみられません。
>・上でコケたときのco側でのnetstat -lの結果
これはVNC立ち上げて、落ちた後で良いですかね?
colinux:~# netstat -l
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 localhost:mysql *:* LISTEN
tcp 0 0 *:netbios-ssn *:* LISTEN
tcp 0 0 *:vnc-1024x768x8 *:* LISTEN
tcp 0 0 *:vnc-1024x768x32 *:* LISTEN
tcp 0 0 *:x11 *:* LISTEN
tcp 0 0 *:vnc-1280x1024x8 *:* LISTEN
tcp 0 0 *:vnc-1280x1024x32 *:* LISTEN
307298
2009/03/01(日) 09:14:41ID:plGeOcYq tcp 0 0 localhost:smtp *:* LISTEN
tcp 0 0 *:microsoft-ds *:* LISTEN
tcp6 0 0 *:x11 *:* LISTEN
tcp6 0 0 *:www *:* LISTEN
tcp6 0 0 *:ssh *:* LISTEN
tcp6 0 0 *:39607 *:* LISTEN
udp 0 0 colinux:netbios-ns *:*
udp 0 0 *:netbios-ns *:*
udp 0 0 colinux:netbios-dgm *:*
udp 0 0 *:netbios-dgm *:*
udp6 0 0 *:xdmcp *:*
Active UNIX domain sockets (only servers)
Proto RefCnt Flags Type State I-Node Path
unix 2 [ ACC ] STREAM LISTENING 5901 /var/run/mysqld/mysqld.sock
unix 2 [ ACC ] STREAM LISTENING 6485 /tmp/.X11-unix/X0
・co側でcolinuxで名前解決はできてる? inetd.confの -query colinux を -query 127.0.0.1 とすると?
だめでした・・・。
・tightvncserverとxdmをいったんpurgeしてからinstallしなおして、/etc/X11/xdm/下のXaccess, Xserver, xdm-config
を修正してcoをrebootしてみる。
・設定変更したときは、念のためcoをrebootする。
だめでした・・・。
>>304 ありがとうございます。皆様の暖かい支援を力に変えて私たちは
頑張っておりますと選挙カーがいっておりました。
>>305
icewm,icewm-theme ですね。以前Linuxを教えてもらってた友人に
iceはおまえの様に軽くて存在感の無いメモリ喰わない奴だから良いよと。
tcp 0 0 *:microsoft-ds *:* LISTEN
tcp6 0 0 *:x11 *:* LISTEN
tcp6 0 0 *:www *:* LISTEN
tcp6 0 0 *:ssh *:* LISTEN
tcp6 0 0 *:39607 *:* LISTEN
udp 0 0 colinux:netbios-ns *:*
udp 0 0 *:netbios-ns *:*
udp 0 0 colinux:netbios-dgm *:*
udp 0 0 *:netbios-dgm *:*
udp6 0 0 *:xdmcp *:*
Active UNIX domain sockets (only servers)
Proto RefCnt Flags Type State I-Node Path
unix 2 [ ACC ] STREAM LISTENING 5901 /var/run/mysqld/mysqld.sock
unix 2 [ ACC ] STREAM LISTENING 6485 /tmp/.X11-unix/X0
・co側でcolinuxで名前解決はできてる? inetd.confの -query colinux を -query 127.0.0.1 とすると?
だめでした・・・。
・tightvncserverとxdmをいったんpurgeしてからinstallしなおして、/etc/X11/xdm/下のXaccess, Xserver, xdm-config
を修正してcoをrebootしてみる。
・設定変更したときは、念のためcoをrebootする。
だめでした・・・。
>>304 ありがとうございます。皆様の暖かい支援を力に変えて私たちは
頑張っておりますと選挙カーがいっておりました。
>>305
icewm,icewm-theme ですね。以前Linuxを教えてもらってた友人に
iceはおまえの様に軽くて存在感の無いメモリ喰わない奴だから良いよと。
2009/03/01(日) 12:53:24ID:3QmsLvSN
icewmはウィンドウマネージャ。>>305が聞いてるのはディスプレイマネージャ。
で、xdmなら、ためしにwdmにしてみたらどう? apt-get install wdmで入れて、
/etc/X11/wdm/でxdmと同様に、Xaccessは元から変更済み、Xserverとwdm-configを修正。
あと/etc/X11/default-display-managerを/usr/bin/X11/xdmから/usr/bin/wdmに修正。
X11の有無に注意。こっちはまちっとsyslogになんか残してくれる。ような気がする。
で、念のため2回ほどshutdown -rしてvncviewerで繋げてみる。
あ、もひとつ。default-display-managerのみ修正して2回shutdown -rしてps -eでxdmが起動してなくて
wdmが起動してるの確認して、vncviewerで繋げたとき、wdm-config修正してshutdown -rしてvncviewer
で繋げたとき、Xserverも修正してshutdown -rしてvncviewerで繋げたとき、で挙動に変化があるか?
で、xdmなら、ためしにwdmにしてみたらどう? apt-get install wdmで入れて、
/etc/X11/wdm/でxdmと同様に、Xaccessは元から変更済み、Xserverとwdm-configを修正。
あと/etc/X11/default-display-managerを/usr/bin/X11/xdmから/usr/bin/wdmに修正。
X11の有無に注意。こっちはまちっとsyslogになんか残してくれる。ような気がする。
で、念のため2回ほどshutdown -rしてvncviewerで繋げてみる。
あ、もひとつ。default-display-managerのみ修正して2回shutdown -rしてps -eでxdmが起動してなくて
wdmが起動してるの確認して、vncviewerで繋げたとき、wdm-config修正してshutdown -rしてvncviewer
で繋げたとき、Xserverも修正してshutdown -rしてvncviewerで繋げたとき、で挙動に変化があるか?
309298
2009/03/01(日) 20:06:30ID:plGeOcYq >>308
↑側をやったら動きました!
これはXdmがわるかったってことですかね?何がわるかったのやら?
gdmでも動かなかったんですけど、wdmだったらおkな理由がわからないですね・・。
一応/var/log/syslogデータを
Mar 1 20:02:13 colinux wdm: Could not init font path element /usr/share/fonts/X
11/100dpi, removing from list!
Mar 1 20:02:13 colinux wdm: Could not init font path element /usr/share/fonts/X
11/75dpi, removing from list!
Mar 1 20:02:13 colinux wdm: /etc/X11/wdm/Xresources_0: line 1: /etc/X11/wdm/Xre
sources_0: Permission denied
Mar 1 20:02:13 colinux wdm: /etc/X11/wdm/Xresources_0: line 2: syntax error nea
r unexpected token `newline'
Mar 1 20:02:13 colinux wdm: /etc/X11/wdm/Xresources_0: line 2: `!'
Mar 1 20:02:13 colinux wdm: Cannot open config file. Using builtin defaults
Mar 1 20:02:20 colinux kernel: eth0: no IPv6 routers present
Mar 1 20:02:22 colinux wdm: wdmLogin warning: WINGs: could not load widget imag
es file: could not open file
Mar 1 20:03:57 colinux wdm: /etc/X11/wdm/Xresources: line 1: /etc/X11/wdm/Xreso
urces: Permission denied
Mar 1 20:03:57 colinux wdm: /etc/X11/wdm/Xresources: line 2: syntax error near
unexpected token `newline'
Mar 1 20:03:57 colinux wdm: /etc/X11/wdm/Xresources: line 2: `!'
Mar 1 20:03:57 colinux wdm: Cannot open config file. Using builtin defaults
Mar 1 20:03:58 colinux wdm: wdmLogin warning: WINGs: could not load widget imag
es file: could not open file
Mar 1 20:04:06 colinux wdm: cat: /home/itoh/.wm_style: No such file or director
y
↑側をやったら動きました!
これはXdmがわるかったってことですかね?何がわるかったのやら?
gdmでも動かなかったんですけど、wdmだったらおkな理由がわからないですね・・。
一応/var/log/syslogデータを
Mar 1 20:02:13 colinux wdm: Could not init font path element /usr/share/fonts/X
11/100dpi, removing from list!
Mar 1 20:02:13 colinux wdm: Could not init font path element /usr/share/fonts/X
11/75dpi, removing from list!
Mar 1 20:02:13 colinux wdm: /etc/X11/wdm/Xresources_0: line 1: /etc/X11/wdm/Xre
sources_0: Permission denied
Mar 1 20:02:13 colinux wdm: /etc/X11/wdm/Xresources_0: line 2: syntax error nea
r unexpected token `newline'
Mar 1 20:02:13 colinux wdm: /etc/X11/wdm/Xresources_0: line 2: `!'
Mar 1 20:02:13 colinux wdm: Cannot open config file. Using builtin defaults
Mar 1 20:02:20 colinux kernel: eth0: no IPv6 routers present
Mar 1 20:02:22 colinux wdm: wdmLogin warning: WINGs: could not load widget imag
es file: could not open file
Mar 1 20:03:57 colinux wdm: /etc/X11/wdm/Xresources: line 1: /etc/X11/wdm/Xreso
urces: Permission denied
Mar 1 20:03:57 colinux wdm: /etc/X11/wdm/Xresources: line 2: syntax error near
unexpected token `newline'
Mar 1 20:03:57 colinux wdm: /etc/X11/wdm/Xresources: line 2: `!'
Mar 1 20:03:57 colinux wdm: Cannot open config file. Using builtin defaults
Mar 1 20:03:58 colinux wdm: wdmLogin warning: WINGs: could not load widget imag
es file: could not open file
Mar 1 20:04:06 colinux wdm: cat: /home/itoh/.wm_style: No such file or director
y
2009/03/01(日) 21:12:47ID:3QmsLvSN
>>309
itohさんオメっ。
でま、せっかくなんで、次に考えていたことだけど。
・etchは最新? securityも含めupgradeしてる? ← むかし、xdmはうまくいかない、てネタがあったはず。
・pam関係でなんか弄ってない?
現象を考えるに、xdm動かそうとして、なんでか即logoutってなってんのかな? と。ただ、どうすりゃ
それができるのかさっぱりオレにゃわからんかった。うちで再現しねぇ。
xdmとgdmでいっしょでwdmのみ違う、/etc/pam.d/の設定とか? わからん。気が向いたらまちっと
追求して、なんかわかったらココで報告してくり。
itohさんオメっ。
でま、せっかくなんで、次に考えていたことだけど。
・etchは最新? securityも含めupgradeしてる? ← むかし、xdmはうまくいかない、てネタがあったはず。
・pam関係でなんか弄ってない?
現象を考えるに、xdm動かそうとして、なんでか即logoutってなってんのかな? と。ただ、どうすりゃ
それができるのかさっぱりオレにゃわからんかった。うちで再現しねぇ。
xdmとgdmでいっしょでwdmのみ違う、/etc/pam.d/の設定とか? わからん。気が向いたらまちっと
追求して、なんかわかったらココで報告してくり。
2009/03/01(日) 21:16:23ID:3QmsLvSN
で、次はxmingとか? いちおはxserverだしxmingは速そうだ。
2009/03/03(火) 19:36:24ID:SrWpxbF1
>>292
自己レスです。
Linux側の問題でなく、colinux-daemon.exeを手動起動したら、cofsを通じて「俺@win」所有のファイルが出来ました。
andLinuxインストーラは、colinux-daemon.exeをMS-Windowsの「サービス」に登録する際、Administratorで走るようにsetuid(?)みたいなことをするようです。
分かってしまえば、何だ…ですが、そこに到るまでcofs設定を試行錯誤するばかりでした。
自己レスです。
Linux側の問題でなく、colinux-daemon.exeを手動起動したら、cofsを通じて「俺@win」所有のファイルが出来ました。
andLinuxインストーラは、colinux-daemon.exeをMS-Windowsの「サービス」に登録する際、Administratorで走るようにsetuid(?)みたいなことをするようです。
分かってしまえば、何だ…ですが、そこに到るまでcofs設定を試行錯誤するばかりでした。
313298
2009/03/03(火) 20:00:29ID:nfJ+ROMl2009/03/03(火) 20:22:23ID:332zO1P1
xmingはMS-Windows上のXサーバです。
と、andLinuxで七転八倒してる俺が脇から答えました。
と、andLinuxで七転八倒してる俺が脇から答えました。
2009/03/03(火) 23:52:47ID:cNYX41ZI
>>313
アップグレードはべつに問題ないよ。
coLinuxが提供してくれてるのはカスタムカーネル周りだから、カーネルさえcoLinuxのものが使えれば問題ない。
こないだMLにFedora10のイメージ作ったぞー!的なポストがあったな。
アップグレードはべつに問題ないよ。
coLinuxが提供してくれてるのはカスタムカーネル周りだから、カーネルさえcoLinuxのものが使えれば問題ない。
こないだMLにFedora10のイメージ作ったぞー!的なポストがあったな。
2009/03/04(水) 00:29:15ID:PcRBtBqe
>>312
すげぇ。よう気が付いた、というか、よう諦めなかった、というか。
で、winのコンパネのサービスのLogOnタブのLog on as:のあたりのチップヘルプによると、
通常はsystem accountだけど、変更するなら弄れ、てことみたいなんだけど、ようなココ
弄れってことかぃな?
すげぇ。よう気が付いた、というか、よう諦めなかった、というか。
で、winのコンパネのサービスのLogOnタブのLog on as:のあたりのチップヘルプによると、
通常はsystem accountだけど、変更するなら弄れ、てことみたいなんだけど、ようなココ
弄れってことかぃな?
2009/03/04(水) 00:34:13ID:PcRBtBqe
>>313
あと、たまにupgradeすると、ハードに近いあたりで動かないのが出てきたりした経験あるけど、
そういうのは、なんだかんだで世界にゃエラい人がいっぱいいて、しばらく放っぽっておくと
ぐぐるセンセが教えてくれるように。
イメージファイルでバックアップが楽勝で取れるんだから、lennyに上げてみるってのもイイかと。
せっかくdebianなんだし。まぁ、debスレとか見る限り、desktop環境はまちっと待ったのがよさげ
だけど、coは基本consoleだし。
あと、たまにupgradeすると、ハードに近いあたりで動かないのが出てきたりした経験あるけど、
そういうのは、なんだかんだで世界にゃエラい人がいっぱいいて、しばらく放っぽっておくと
ぐぐるセンセが教えてくれるように。
イメージファイルでバックアップが楽勝で取れるんだから、lennyに上げてみるってのもイイかと。
せっかくdebianなんだし。まぁ、debスレとか見る限り、desktop環境はまちっと待ったのがよさげ
だけど、coは基本consoleだし。
2009/03/10(火) 21:33:21ID:hrcV3cEG
当該機が無いので固有名詞がウロ憶えです。
andLinuxのUbuntu 7.xを8.04(だったかな?)に上げたら、/etc/inittabから起動されていた筈の/usr/bin/X11/startwindowsナントカが起動されなくなった。
仕方ないので/etc/inittabのその箇所を/etc/rc.localに書いた。
で、質問なのですが、startwindowsナントカはどこに書くのが正解なのでしょうか。
#rc.localでも困ってはいないのですが。
andLinuxのUbuntu 7.xを8.04(だったかな?)に上げたら、/etc/inittabから起動されていた筈の/usr/bin/X11/startwindowsナントカが起動されなくなった。
仕方ないので/etc/inittabのその箇所を/etc/rc.localに書いた。
で、質問なのですが、startwindowsナントカはどこに書くのが正解なのでしょうか。
#rc.localでも困ってはいないのですが。
2009/03/10(火) 23:48:40ID:YzO+WXzP
>>318
ubuntuってinittabないんだけど、andLinuxってinittab使うようにしてんの?
ubuntuってinittabないんだけど、andLinuxってinittab使うようにしてんの?
2009/03/11(水) 08:23:46ID:pRxyugBB
2009/03/11(水) 08:25:11ID:pRxyugBB
アンカーミス。正:319、誤:318。
2009/03/11(水) 09:30:05ID:un7iL/T6
>>320
とすると、andLinuxのubuntuイメージ作った人の好みでinittab形式だったんだけど、
これをupgradeしたら本来のubuntuに更新された?
でも、その場合でもinittabがあれば、それを見に行くらしいんだけどな?
とすると、andLinuxのubuntuイメージ作った人の好みでinittab形式だったんだけど、
これをupgradeしたら本来のubuntuに更新された?
でも、その場合でもinittabがあれば、それを見に行くらしいんだけどな?
2009/03/11(水) 18:50:40ID:NnwlEHNE
見に行くけど見ないと言いますか…
inittab自体はrc-default(だったかな?)がランレベルを導出するために走査されるのですが、ランレベルに関係の無い行、つまり今回ハマったstartwindowsterminalナントカ起動行は無視されてしまうように、私には見えます。
で、無視された行に相応しい行方を尋ねているのですが、段々 rc.localでいいような気になって来ました。
inittab自体はrc-default(だったかな?)がランレベルを導出するために走査されるのですが、ランレベルに関係の無い行、つまり今回ハマったstartwindowsterminalナントカ起動行は無視されてしまうように、私には見えます。
で、無視された行に相応しい行方を尋ねているのですが、段々 rc.localでいいような気になって来ました。
2009/03/11(水) 22:04:25ID:un7iL/T6
>>323
inittabはscriptじゃなくって、initによってSIGNALなりrunlevelなりによる動作の定義を
記述するところだから、ナントカ行が全部わからないと、わからないんじゃね?
とりあえず、起動時に必須でシステム周り、てことなら、rc.localで良いんじゃね? と思うけど。
inittabはscriptじゃなくって、initによってSIGNALなりrunlevelなりによる動作の定義を
記述するところだから、ナントカ行が全部わからないと、わからないんじゃね?
とりあえず、起動時に必須でシステム周り、てことなら、rc.localで良いんじゃね? と思うけど。
2009/03/11(水) 22:26:37ID:q2e6tqEw
ナントカ行は、
C0::respawn:/usr/bin/X11/startwindowterminalsession
です。または
C0::respawn:/etc/winterm
です。
「または」というのは、ウロ憶えなので
ttp://www.andlinux.org/forum/viewtopic.php?t=372&sid=c37a5811fd43c3731adf4c85c0a245bd
から記述を拾ったのですが、いずれにせよ startwindowterminalsessionを喚びます。
C0::respawn:/usr/bin/X11/startwindowterminalsession
です。または
C0::respawn:/etc/winterm
です。
「または」というのは、ウロ憶えなので
ttp://www.andlinux.org/forum/viewtopic.php?t=372&sid=c37a5811fd43c3731adf4c85c0a245bd
から記述を拾ったのですが、いずれにせよ startwindowterminalsessionを喚びます。
2009/03/11(水) 23:19:03ID:un7iL/T6
>>325
結局、↓に書かれているとおりっぽいね。
http://forums.codeblocks.org/index.php?topic=4549.msg%25msg_id%25
で、inittabのC0を見てるのは↓によると/etc/sbin/launcher.pl
http://www.nabble.com/INIT:-Id-%22C0%22-respawning-too-fast:-disabled-for-5-minutes-td17672529.html
だとすると、launcher.plがまだあるようなら、中みて、rcSかrc2かrc.localに書く、もしくは最新のandLinuxがどう
起動させているか調べる、しかないと思ってみたりなんかして。and固有っぽいし。
結局、↓に書かれているとおりっぽいね。
http://forums.codeblocks.org/index.php?topic=4549.msg%25msg_id%25
で、inittabのC0を見てるのは↓によると/etc/sbin/launcher.pl
http://www.nabble.com/INIT:-Id-%22C0%22-respawning-too-fast:-disabled-for-5-minutes-td17672529.html
だとすると、launcher.plがまだあるようなら、中みて、rcSかrc2かrc.localに書く、もしくは最新のandLinuxがどう
起動させているか調べる、しかないと思ってみたりなんかして。and固有っぽいし。
2009/03/12(木) 00:37:12ID:eiN5vJuT
と、思ったんだけど、launcher.plでぐぐった結果を見ると、いろいろ違うね。
ttp://ho-ki-boshi.blogspot.com/2008/12/andlinux804.html
↑の人はrc.localでstartwindowsterminalsession起動してるみたいだけど。本人?
ttp://ho-ki-boshi.blogspot.com/2008/12/andlinux804.html
↑の人はrc.localでstartwindowsterminalsession起動してるみたいだけど。本人?
2009/03/12(木) 07:44:21ID:NwtWQ/TI
いえ、blogは持っていません。
色々調べて頂き有難うございます。
andLinux搭載機に触れられる場所へ行き、読んでみようと思います。
色々調べて頂き有難うございます。
andLinux搭載機に触れられる場所へ行き、読んでみようと思います。
2009/03/12(木) 15:43:16ID:OvSYCSVb
横からですが
/usr/bin/X11/startwindowterminalsession が
/etc/wintermを参照して
実質的に/usr/local/sbin/launcher.pl
を動かしているから rc.localに
/usr/bin/X11/startwindowterminalsession &
を書くのが正解みたいですね。
ちょうどubuntu8.10に上げたらKonsoleなどが port81につながらないエラーで
はまってましたが参考になりました。
/usr/bin/X11/startwindowterminalsession が
/etc/wintermを参照して
実質的に/usr/local/sbin/launcher.pl
を動かしているから rc.localに
/usr/bin/X11/startwindowterminalsession &
を書くのが正解みたいですね。
ちょうどubuntu8.10に上げたらKonsoleなどが port81につながらないエラーで
はまってましたが参考になりました。
330login:Penguin
2009/03/18(水) 20:35:42ID:CkzxVFGk すいませんandLinuxの質問いいでしょうか??
andlinuxを立ち上げて、andLinux上のファイルをWindows上のエディタ(さくらエディタとか)で開くことは可能なんでしょうか??
教していください><
andlinuxを立ち上げて、andLinux上のファイルをWindows上のエディタ(さくらエディタとか)で開くことは可能なんでしょうか??
教していください><
331330
2009/03/18(水) 20:44:07ID:CkzxVFGk >開くことは可能なんでしょうか??
読み込みだけじゃなくて書き込みも出来るのか教えていただけると幸いですm(_ _)m
読み込みだけじゃなくて書き込みも出来るのか教えていただけると幸いですm(_ _)m
2009/03/18(水) 21:00:01ID:X40zW9g3
可能
2009/03/19(木) 01:00:15ID:R6gutDIQ
/dev/initctlをさくらエディタとかで編集してみたいと思った
あと名前付きパイプとか
あと名前付きパイプとか
2009/03/19(木) 09:12:00ID:9Rye2bRU
改行コードとエンコーディングの違いにだけ注意
2009/03/19(木) 09:44:36ID:9jVGYTHG
>>330
調べて分かったらオレにも教えて。
調べて分かったらオレにも教えて。
2009/03/19(木) 10:04:03ID:gobNSPAB
できるけど、自分のhome以外、/とか/etcとかのファイルをwindows上のエディタで弄るのは
パーミッションの関係でよろしくない、という条件が付くかと。
どうせ弄るの自分だけだしcrackはされない、ということなら、どうとでも。それでも、パーミッション600を
要求するような設定ファイルもあったりするから、そういうのは手順踏まないとダメだろ。
---と思ってるんだけど、and使ってないからなぁオレ。基本的に、andだから、ってわけじゃないんじゃねぇの?
パーミッションの関係でよろしくない、という条件が付くかと。
どうせ弄るの自分だけだしcrackはされない、ということなら、どうとでも。それでも、パーミッション600を
要求するような設定ファイルもあったりするから、そういうのは手順踏まないとダメだろ。
---と思ってるんだけど、and使ってないからなぁオレ。基本的に、andだから、ってわけじゃないんじゃねぇの?
2009/03/19(木) 12:08:40ID:XB2e6yOL
colinuxと関係ない話題だからスレ違いでないの
2009/03/19(木) 12:08:43ID:BBtFIIV2
てかwindowsはandLinux上のファイルシステムを直接には読めないだろ?
逆はマウントすればできるけど。
andLinuxでsambaサーバ立てて共有するとかしないとだめだろ。
逆はマウントすればできるけど。
andLinuxでsambaサーバ立てて共有するとかしないとだめだろ。
2009/03/19(木) 14:48:11ID:3gtpkWVY
でも、何か方法があるんでしょ?
>>336は、/ や /etc がcygwinのようにWindows fsであることを前提に言ってるわけじゃないと思うけど。
>>336は、/ や /etc がcygwinのようにWindows fsであることを前提に言ってるわけじゃないと思うけど。
2009/03/19(木) 14:58:35ID:4XWgzvoM
samba使う
2009/03/19(木) 16:02:22ID:cXuiQndO
つーかどんなファイルをWin側で開きたいと思うんだ?
2009/03/19(木) 19:09:08ID:KDP/tv8i
はい、336はオレ。
>>336はまるっきりsambaを使うの前提で書いた。だからandに限らない、と。
>>336はまるっきりsambaを使うの前提で書いた。だからandに限らない、と。
2009/03/20(金) 00:52:17ID:75YvOLLc
sambaでcolinuxのファイルをwindowsのgvimでいじることも時々あるよ。
自分がなにやってるか理解してやってるなら問題ないんじゃないかな。
パーミッションとかかわりうるのでそこは注意だね。
自分がなにやってるか理解してやってるなら問題ないんじゃないかな。
パーミッションとかかわりうるのでそこは注意だね。
2009/03/21(土) 11:00:34ID:Rc/H6txX
vimならゲストに入れね?
345343
2009/03/21(土) 18:53:32ID:kzc3g3Sh もちろん普通はcolinuxのviなりを使うが
エクスプローラでへらへら見てる時に
パパっと修正したい時なんかwindowsのエディタでやってしまう。
エクスプローラでへらへら見てる時に
パパっと修正したい時なんかwindowsのエディタでやってしまう。
346login:Penguin
2009/03/24(火) 05:07:26ID:MOkT+UG5 cofsでマウントしたファイルをcolinux側のviで保存できないのがきつい。
viの設定をいろいろいじればできるらしいけど。ちょいと残念。
viの設定をいろいろいじればできるらしいけど。ちょいと残念。
2009/03/24(火) 12:41:28ID:5DzKNSVK
なんで?できるよ?
2009/03/24(火) 14:54:24ID:Uv5JpQUb
fstabでどうにでもなるはず.
2009/03/26(木) 01:08:04ID:pNDsmppn
てゆーか、今どうやってmountしてるのかが気になる。
2009/03/26(木) 04:37:01ID:X0jknXvG
cofsに全システムファイル置けたら
完全にwindowsと融合できそうで面白そうだよな。
完全にwindowsと融合できそうで面白そうだよな。
2009/03/26(木) 05:25:17ID:He+w08Cq
>>351
そうなってくると、もはやLinuxを使う必要があるのかと思うが。
そうなってくると、もはやLinuxを使う必要があるのかと思うが。
2009/03/26(木) 07:19:33ID:h7QvbCNs
>>351
cygwinで良いではないですか。
cygwinで良いではないですか。
2009/03/26(木) 11:28:31ID:X0jknXvG
linux使う必要があるのかって、
じゃあ逆に聞くけど
ファイルシステムを別にしたいからcolinux使ってるの?
cygwinは便利で今も使ってるけど
細かい違いがやっぱり駄目なんだよな。
じゃあ逆に聞くけど
ファイルシステムを別にしたいからcolinux使ってるの?
cygwinは便利で今も使ってるけど
細かい違いがやっぱり駄目なんだよな。
2009/03/26(木) 13:09:11ID:He+w08Cq
ファイルシステムを別にするのが目的で使っている訳じゃないが、少なくともWindows環境を好きこのんで使っている訳じゃないから、分かれていることにこそ意味があると思う。
2009/03/26(木) 15:30:42ID:LO05nAgz
colinuxをbootする前に/etcを触りたくなることは、わしもあります。
なにか方法はないのかな。
なにか方法はないのかな。
2009/03/26(木) 15:32:19ID:4aLEfG7a
init=/bin/sh
2009/03/27(金) 18:31:50ID:CucEMNR6
対応してるカーネルの最新バージョンってまだ 2.6.22.18
なの?
もっと新しいの使えないかなあ
なの?
もっと新しいの使えないかなあ
2009/03/27(金) 19:40:45ID:iYk25raK
>>358
新しいカーネルのどんな機能が使いたいの?
新しいカーネルのどんな機能が使いたいの?
2009/03/30(月) 14:34:05ID:GsYpTPLc
0.7.4-rc1きたぞー!
2009/04/03(金) 12:48:19ID:pC3D/3YC
マルチコア対応はまだか
2009/04/03(金) 17:37:42ID:mElzJf9c
おまいがパッチを書けば万事解決じゃね?
■ このスレッドは過去ログ倉庫に格納されています
ニュース
- 第2次大戦に触れトランプ氏「米中は同盟国」、当時は中華民国…「抗日」巡る中国の言説補強する恐れ ★5 [蚤の市★]
- 【速報】timelesz猪俣周杜メンバー釈放 [Ailuropoda melanoleuca★]
- 【速報】 高市首相 「円の過小評価は問題だ」 ★3 [お断り★]
- パナソニックが市販カーナビ生産終了へ 30年以上の歴史に幕、スマホナビの普及など受け [少考さん★]
- 【東京】ウズベキスタン国籍のフードデリバリー配達員を逮捕 配達先の女子小学生にキスや体を触るなどわいせつ行為か ★2 [煮卵★]
- 日本代表は親善試合の世界チャンピオン!?ウルグアイ撃破も海外から皮肉「W杯やアジアカップになると」日本のファン「刺さるからやめて」 [征夷大将軍★]
- お前らが嫁もウッドデッキも手に入れられ部底辺独身アパートおじさんに成り果てた理由
- 【速報】声優の緒方恵美さん、長文お気持ち声明 [595118796]
- 【高市悲報】未だに「年賀状」書いてる人居るでしょ🥺 [616817505]
- 【悲報】ジャングリア沖縄、ガラガラすぎてガチのジャングルになる [398059782]
- HUNATAN×HUNATANについて語るスレ(・o・🍬)🏰
- 女性「たのしいピクニック女は女性から見ると知的○害者なの。クラスで嫌われていて1ミリもモテないwww」 [592058334]