CentOS は Red Hat Enterprise Linux (RHEL) から同社の商標を削除して再コンパイルした RHEL Clone です。
Red Hat と無関係でもないコミュニティが無償配布してしますが Red Hat のブランドとサポートはありません。
* Fedora 13≒RHEL 6≒CentOS 6
* Fedora 19≒RHEL 7≒CentOS 7
* Fedora 28≒RHEL 8≒CentOS 8
です。
FCやRHEL 用のノウハウ、野良 RPM、レポジトリ云々は CentOS でもほぼ通用します。
前スレ
CentOS Part 50【RHEL Clone】
http://mao.5ch.net/test/read.cgi/linux/1555069001/
CentOS (The Community ENTerprise Operating System)
http://www.centos.org/
CentOS 配布ミラーサーバ
http://www.centos.org/download/mirrors/
CentOS -- Wikipedia日本語版
http://ja.wikipedia.org/wiki/CentOS
CentOS Part 51【RHEL Clone】
■ このスレッドは過去ログ倉庫に格納されています
2019/11/08(金) 22:55:00.80ID:47UPLz72
2020/05/24(日) 21:13:11.81ID:dl/l88tt
>>576
X だけ起動して、gnome-session の起動に失敗している?
.xsession-error だったかにログは出ていないでしょうか。
あと、~/.vnc/xstartup を変更してどうなるか。
X だけ起動して、gnome-session の起動に失敗している?
.xsession-error だったかにログは出ていないでしょうか。
あと、~/.vnc/xstartup を変更してどうなるか。
578576
2020/05/27(水) 08:06:55.13ID:GF4WGhT0 >>577
結局、xstartupに、
unset DBUS_SESSION_BUS_ADDRESS
を記述する事で、VNCにて接続するも画面真っ黒の現象は解消されたのですが、本来これは記述する必要があるのでしょうか?
それとも、xstartupの記述に何か不備があるのでしょうか?
良く分かりません・・・。 iii orz iii
結局、xstartupに、
unset DBUS_SESSION_BUS_ADDRESS
を記述する事で、VNCにて接続するも画面真っ黒の現象は解消されたのですが、本来これは記述する必要があるのでしょうか?
それとも、xstartupの記述に何か不備があるのでしょうか?
良く分かりません・・・。 iii orz iii
579575
2020/05/27(水) 10:14:09.43ID:JcNtRLvJ >>578
こちらの環境では初期状態で "unset DBUS_SESSION_BUS_ADDRESS" が
/root/.vnc/xstartup の4行目に入ってた
/usr/bin/vncserver (シェルスクリプト) 内の xstartup を生成する部分にも入ってた
なので xstartup の使いまわしが原因ってことだろ
こちらの環境では初期状態で "unset DBUS_SESSION_BUS_ADDRESS" が
/root/.vnc/xstartup の4行目に入ってた
/usr/bin/vncserver (シェルスクリプト) 内の xstartup を生成する部分にも入ってた
なので xstartup の使いまわしが原因ってことだろ
580576
2020/05/27(水) 13:32:53.13ID:GF4WGhT0 >>579
重ね重ねthx!
それで、/root/.vnc/xstartupの内容をうpして頂けると、非常に助かります・・・。
あちこちのサイトでは、自分でxstartupを記述したり等の記事を見るのですが、実際に正常に動作しているxstartupがどうなっているのか、それを見てみたいので・・・。m(__)m
重ね重ねthx!
それで、/root/.vnc/xstartupの内容をうpして頂けると、非常に助かります・・・。
あちこちのサイトでは、自分でxstartupを記述したり等の記事を見るのですが、実際に正常に動作しているxstartupがどうなっているのか、それを見てみたいので・・・。m(__)m
2020/05/27(水) 17:39:11.08ID:6GjdumNV
最新のrpmパッケージの中身をバラせば入ってるんじゃね
2020/05/27(水) 18:20:16.81ID:j78Ugmty
.vncの中身って、vncserver本体が起動時にチェックし、無ければ作るってモノだから
rpmパッケージの中身見ても出てこないと思う
むしろ.vncディレクトリを別名にmvするとかして再作成させたらどうかなとも
rpmパッケージの中身見ても出てこないと思う
むしろ.vncディレクトリを別名にmvするとかして再作成させたらどうかなとも
2020/05/27(水) 18:57:08.13ID:JcNtRLvJ
584login:Penguin
2020/05/28(木) 10:15:04.71ID:n6ewUPvc rootでやってる時点でセットアップ手順がおかしいのではないか疑惑。
585login:Penguin
2020/05/29(金) 14:16:18.27ID:Ac7esVrp RHELでopensshインストールしたい場合、
バージョンはどれを選んだ方がいいですか?
7と8で対応しているバージョンが違う?
バージョンはどれを選んだ方がいいですか?
7と8で対応しているバージョンが違う?
586login:Penguin
2020/05/29(金) 14:48:12.68ID:gacDDpCw yum install openssh
587login:Penguin
2020/05/29(金) 15:17:40.20ID:yCgFd+Uh dnf
588login:Penguin
2020/05/29(金) 15:27:59.81ID:Ac7esVrp2020/05/29(金) 16:12:29.40ID:gJqU6Wys
7,8どちらもminimalで入れてもopenssh入ってるよね・・・
590login:Penguin
2020/05/29(金) 16:39:25.89ID:gacDDpCw 我われのようなしょぼいエンジニアではなくてOSを作ってたようなお方なのであろう。
591login:Penguin
2020/05/29(金) 17:07:22.52ID:Ac7esVrp >>589
無知ですみません。
脆弱性があるから最新の当てなければと思って
削除とインストールと思っていました。
RHELのopensshでデフォルトのバージョンから
大きくあげなくてもいいんですよね?
そこの部分がわからなくて
8.3までどうやったらあげれるのかを
考えていました
無知ですみません。
脆弱性があるから最新の当てなければと思って
削除とインストールと思っていました。
RHELのopensshでデフォルトのバージョンから
大きくあげなくてもいいんですよね?
そこの部分がわからなくて
8.3までどうやったらあげれるのかを
考えていました
592login:Penguin
2020/05/29(金) 17:17:48.58ID:yCgFd+Uh >>591
用途によるとしか
用途によるとしか
593login:Penguin
2020/05/29(金) 17:25:06.47ID:gacDDpCw opensshのバージョンは低くても、セキュリティ上必要なパッチはRHELのエンジニアが作ってあててくれてると思ってる。
2020/05/29(金) 18:14:13.87ID:ukmeID7W
思う思わないじゃなくchangelog見ろで終了な話では?
595login:Penguin
2020/05/29(金) 18:54:32.76ID:Ac7esVrp >>593
RHEL6.7でopenssh 5.3p1-114が
現状インストールされていて
5.3古すぎると外部から指摘があり
バージョンアップしろと昨日
投げられまして
opensshでググったら8.3が最新だから
これにバージョン上げますと報告したら
ググレカスと言われて、
ずっと朝から調べてたら
5.3p1-124.el6_10が最新ということまで
わかりました。
RHEL6.10まであげないといけないか
調べたらあげなくてもいいと
あったのですが、本当ですか?
linux昨日から使い始めて
けっこう混乱しています
RHEL6.7でopenssh 5.3p1-114が
現状インストールされていて
5.3古すぎると外部から指摘があり
バージョンアップしろと昨日
投げられまして
opensshでググったら8.3が最新だから
これにバージョン上げますと報告したら
ググレカスと言われて、
ずっと朝から調べてたら
5.3p1-124.el6_10が最新ということまで
わかりました。
RHEL6.10まであげないといけないか
調べたらあげなくてもいいと
あったのですが、本当ですか?
linux昨日から使い始めて
けっこう混乱しています
596login:Penguin
2020/05/29(金) 18:59:31.65ID:Ac7esVrp2020/05/29(金) 19:16:24.35ID:Cjr2/sdQ
バージョン表記が古くても、
OSがサポート期間にあれば原則的には
セキュリティー関連の更新は取り込まれてる。
yum update
をやってとにかく全部アップデートしろ
特定のソフトだけを更新して
セキュリティの問題を起こさないようにするなんて
貴方には無理だと思うよ
OSがサポート期間にあれば原則的には
セキュリティー関連の更新は取り込まれてる。
yum update
をやってとにかく全部アップデートしろ
特定のソフトだけを更新して
セキュリティの問題を起こさないようにするなんて
貴方には無理だと思うよ
2020/05/29(金) 19:16:43.15ID:KBHBF/CE
>>591
脆弱性ってどの脆弱性?
このあたり見れば対応されてるかわかるはず
https://access.redhat.com/errata/#/?q=openssh&portal_advisory_type=Security%20Advisory&portal_product=Red%20Hat%20Enterprise%20Linux&portal_product_version=8
https://access.redhat.com/errata/#/?q=openssh&portal_advisory_type=Security%20Advisory&portal_product=Red%20Hat%20Enterprise%20Linux&portal_product_version=7
脆弱性ってどの脆弱性?
このあたり見れば対応されてるかわかるはず
https://access.redhat.com/errata/#/?q=openssh&portal_advisory_type=Security%20Advisory&portal_product=Red%20Hat%20Enterprise%20Linux&portal_product_version=8
https://access.redhat.com/errata/#/?q=openssh&portal_advisory_type=Security%20Advisory&portal_product=Red%20Hat%20Enterprise%20Linux&portal_product_version=7
2020/05/29(金) 19:19:08.66ID:KBHBF/CE
あ、RHEL6か
ならここ
https://access.redhat.com/errata/#/?q=openssh&portal_advisory_type=Security%20Advisory&portal_product=Red%20Hat%20Enterprise%20Linux&portal_product_version=6
ならここ
https://access.redhat.com/errata/#/?q=openssh&portal_advisory_type=Security%20Advisory&portal_product=Red%20Hat%20Enterprise%20Linux&portal_product_version=6
2020/05/29(金) 19:20:02.34ID:KBHBF/CE
あれ、うまくいかんな
まぁ適宜検索してくれ
まぁ適宜検索してくれ
601login:Penguin
2020/05/29(金) 19:20:58.83ID:gacDDpCw >>595
/etc/yum.confにassumeyes=1が設定されないことを確認してから、
yum update openssh
を実行。(y/n)と出たら、一旦nを押す。
そして、メッセージ見てどこのリポジトリからインストールしようとしているかを確認。
updateとかなら問題ない。
依存関係でupdateされる物を見てupdateしてもいいか考える。
よければ、もう一度実行してyを押し、リブートすればよし。
RHEL6.10になるのか6.9なのかとか気にしなくていい。なされるがままでよし。
ただ、linux使い始めたのが昨日からなら、失敗した時に復旧できる人を確保してからやった方がいい。
/etc/yum.confにassumeyes=1が設定されないことを確認してから、
yum update openssh
を実行。(y/n)と出たら、一旦nを押す。
そして、メッセージ見てどこのリポジトリからインストールしようとしているかを確認。
updateとかなら問題ない。
依存関係でupdateされる物を見てupdateしてもいいか考える。
よければ、もう一度実行してyを押し、リブートすればよし。
RHEL6.10になるのか6.9なのかとか気にしなくていい。なされるがままでよし。
ただ、linux使い始めたのが昨日からなら、失敗した時に復旧できる人を確保してからやった方がいい。
602login:Penguin
2020/05/29(金) 19:21:31.38ID:Ac7esVrp603login:Penguin
2020/05/29(金) 19:25:59.32ID:yCgFd+Uh2020/05/29(金) 19:35:51.45ID:9QXp5KXC
他に入れてるソフトの対応の問題で
6.7で留めとかなきゃいけないとかあるの?
centじゃなくてrhelならセキュリティパッチだけ
アップデートすることも出来たはずだけど
カーネルとか含めて殆ど全部上がるから
結局全部最新にするのが一番手っ取り早いと
思うけどね
6.7で留めとかなきゃいけないとかあるの?
centじゃなくてrhelならセキュリティパッチだけ
アップデートすることも出来たはずだけど
カーネルとか含めて殆ど全部上がるから
結局全部最新にするのが一番手っ取り早いと
思うけどね
2020/05/29(金) 19:36:23.15ID:wlGhX54b
>>602
RHEL 6はまだサポート期間中だから、バージョン上げろってのが脆弱性塞げバグ直せって意味ならRedHatが配布している最新版をそのまま入れればOK。
新機能とかを利用したいからopensshをアップグレードしろって意味なら上司に相談して後はまあ頑張れ。
RHEL 6はまだサポート期間中だから、バージョン上げろってのが脆弱性塞げバグ直せって意味ならRedHatが配布している最新版をそのまま入れればOK。
新機能とかを利用したいからopensshをアップグレードしろって意味なら上司に相談して後はまあ頑張れ。
2020/05/29(金) 19:45:41.21ID:gJqU6Wys
607login:Penguin
2020/05/29(金) 19:59:54.75ID:yCgFd+Uh >>604
普通にあるよ
普通にあるよ
2020/05/29(金) 20:51:00.61ID:KabXUj0g
2020/05/29(金) 21:19:50.84ID:gJqU6Wys
>>608
RHEL6.7で止まっていてopensshが脆弱性抱えてるなんて言われたら、
年間サブスクが切れたのかなと思った。
外部からバージョンなんてわからないと思うから、内部に優しい人がいるんだな。
最新はopenssh-5.3p1-124.el6_10.x86_64.rpm(2019-04)か。
centから取ってきてrpm -Uvhってのはまずいか。
RHEL6.7で止まっていてopensshが脆弱性抱えてるなんて言われたら、
年間サブスクが切れたのかなと思った。
外部からバージョンなんてわからないと思うから、内部に優しい人がいるんだな。
最新はopenssh-5.3p1-124.el6_10.x86_64.rpm(2019-04)か。
centから取ってきてrpm -Uvhってのはまずいか。
610login:Penguin
2020/05/29(金) 23:15:12.30ID:/xGZO0Mn 普通にわかるのでは?
2020/05/29(金) 23:42:45.97ID:A83zzlXZ
>>609
telnetすればわかる。version token
telnetすればわかる。version token
612login:Penguin
2020/05/30(土) 02:36:26.03ID:WXdoqJUM 優しい人いっぱいですね
皆さんありがとう
とりあえずCentOSを自宅pcに入れました
一応本番環境なので
再起動とか怖いので、opensshだけ
あげようと思っていました。
RHEL6.7にopenssh-5.3p1-124.el6_10
導入できるけど、できるだけRHEL側も6.10と合わせた方がいいのですね
openssh入れた瞬間、サービス再起動走るとか
記載があり、設定消えたりしないか
すごく不安です
皆さんありがとう
とりあえずCentOSを自宅pcに入れました
一応本番環境なので
再起動とか怖いので、opensshだけ
あげようと思っていました。
RHEL6.7にopenssh-5.3p1-124.el6_10
導入できるけど、できるだけRHEL側も6.10と合わせた方がいいのですね
openssh入れた瞬間、サービス再起動走るとか
記載があり、設定消えたりしないか
すごく不安です
613login:Penguin
2020/05/30(土) 02:41:28.07ID:WXdoqJUM このスレ勉強になるので、
1から読みます
version token
お勉強用に調べてみます
1から読みます
version token
お勉強用に調べてみます
614login:Penguin
2020/05/30(土) 10:10:23.07ID:pW4SAFUk 入れた瞬間というか、入れる時のスクリプトでsshdが再起動されるかもしれないが、普通設定は/etc/ssh/sshd_configに書いてあるので消えることはない。
スクリプトで再起動してくれなかったら自分で再起動すれば、サーバ自体を再起動しなくてすますことも可能。
ただ、opensshのアップデートに伴って色々あがるかもしれず、可能ならサーバ再起動した方がいいだろう。
再起動する場合は、アップデート実施日よりある程度前の日に再起動だけをするべき。アップデートで不具合が発生したのか、再起動で不具合が発生したのか判断がつかなくなる為。
ある程度がどれくらいかは、動いてるクロンを見て考える。一ヶ月に一度の重要な処理がある場合は、再起動してからその処理が一度は実行されてからにする。
スクリプトで再起動してくれなかったら自分で再起動すれば、サーバ自体を再起動しなくてすますことも可能。
ただ、opensshのアップデートに伴って色々あがるかもしれず、可能ならサーバ再起動した方がいいだろう。
再起動する場合は、アップデート実施日よりある程度前の日に再起動だけをするべき。アップデートで不具合が発生したのか、再起動で不具合が発生したのか判断がつかなくなる為。
ある程度がどれくらいかは、動いてるクロンを見て考える。一ヶ月に一度の重要な処理がある場合は、再起動してからその処理が一度は実行されてからにする。
615login:Penguin
2020/05/30(土) 11:56:42.26ID:kWbY+/ma >>614
スクリプトなのですね
インストーラーみたいに思ってたから
スクリプトみることができたら確認してみます
事前に再起動するという考えいいですね
Windowsと比べてトラブル多そうですね
バージョンアップ作業
スクリプトなのですね
インストーラーみたいに思ってたから
スクリプトみることができたら確認してみます
事前に再起動するという考えいいですね
Windowsと比べてトラブル多そうですね
バージョンアップ作業
616login:Penguin
2020/05/30(土) 12:20:32.53ID:pW4SAFUk ちゃんと言うと、yumでrpmがダウンロードされ、インストールされるが、rpmの中にスクリプトが入っていて、それが実行される。
rpm -q --scripts openssh-server
で見れるが、旧バージョンをアンインストールする時にデーモンがストップし、新バージョンをインストールするとsystemctl presetするようだ。たぶんこれでスタートするのだろう。
マシンが遠隔地にある場合は現地に行った方がいい。遠隔でやる場合は、telnetなどssh以外でつないで保険かけた方が安心。
rpm -q --scripts openssh-server
で見れるが、旧バージョンをアンインストールする時にデーモンがストップし、新バージョンをインストールするとsystemctl presetするようだ。たぶんこれでスタートするのだろう。
マシンが遠隔地にある場合は現地に行った方がいい。遠隔でやる場合は、telnetなどssh以外でつないで保険かけた方が安心。
2020/05/30(土) 12:31:34.93ID:HK9LPtF3
お前がトラブルが起きたらまずい用途に使ってるぽいからスレ民が色々と考えてくれてるだけで
Windowsと比べてトラブルが多いとかいう話ではないと思うが…
Windowsと比べてトラブルが多いとかいう話ではないと思うが…
618login:Penguin
2020/05/30(土) 12:44:40.68ID:pW4SAFUk おっと間違い。systemctl try-restartか。ちゃんと動けばスタートするはず。
2020/05/30(土) 12:57:04.66ID:6rW4nRT3
細かい指摘になるけどRHEL6系ならinitスクリプトだから
systemctlじゃなくてserviceよな
systemctlじゃなくてserviceよな
620login:Penguin
2020/05/30(土) 13:08:44.09ID:pW4SAFUk おお。そうだった。
621login:Penguin
2020/05/30(土) 14:16:29.59ID:9QUzD1mp そいや先日CentOS8でsshdの設定強化しようと思ったら
/etc/sysconfig/sshd で CRYPTO_POLICY= で値空にしなきゃいけなくてちょっと詰まったわ
/etc/sysconfig/sshd で CRYPTO_POLICY= で値空にしなきゃいけなくてちょっと詰まったわ
622login:Penguin
2020/05/30(土) 19:05:03.21ID:kWbY+/ma623login:Penguin
2020/05/30(土) 20:22:31.80ID:sqkPF9Vo >>622
あなたがいつか支えるばんになるよ
あなたがいつか支えるばんになるよ
2020/05/30(土) 20:31:25.30ID:NX6hxWUq
dog year, rat yeay(死語)
2020/05/30(土) 22:13:28.72ID:GvSsYxMg
質問いたします
CentOS7.5でDNSサーバーを構築してるのですが、正引き逆引き成功を確認出来たのでスレーブDNSサーバーも構築しました。
サイトをみて、マスターDNSサーバーのゾーン設定にallow-transeer { xxx.xxx.xxx.xxx; };と記載
マスターDNSサーバーのゾーンファイルにスレーブDNSサーバーの情報を追記しました。
スレーブDNSサーバーにはゾーン設定にマスターDNSサーバーの情報とスレーブDNSサーバーのゾーンファイル転送先を記載
その後に両方再起動と読み込みをしたのですがスレーブDNSサーバーにファイルが転送されませんでした
当たり前ですがスレーブDNSサーバーでの正引き逆引きは失敗してます
エラーとかみてもいまいち分からない状態です
何をみて、修正したら良いのでしょうか
CentOS7.5でDNSサーバーを構築してるのですが、正引き逆引き成功を確認出来たのでスレーブDNSサーバーも構築しました。
サイトをみて、マスターDNSサーバーのゾーン設定にallow-transeer { xxx.xxx.xxx.xxx; };と記載
マスターDNSサーバーのゾーンファイルにスレーブDNSサーバーの情報を追記しました。
スレーブDNSサーバーにはゾーン設定にマスターDNSサーバーの情報とスレーブDNSサーバーのゾーンファイル転送先を記載
その後に両方再起動と読み込みをしたのですがスレーブDNSサーバーにファイルが転送されませんでした
当たり前ですがスレーブDNSサーバーでの正引き逆引きは失敗してます
エラーとかみてもいまいち分からない状態です
何をみて、修正したら良いのでしょうか
2020/05/30(土) 22:17:31.12ID:NX6hxWUq
DNSのバージョンとエラーを書くのが基本
2020/05/30(土) 22:32:30.62ID:ASDSyN3p
>>625
さすがにそのスペルミスに突っ込んだら負け?
さすがにそのスペルミスに突っ込んだら負け?
2020/05/30(土) 22:33:00.64ID:B/YQNsw/
DNSは脆弱性とか他国からの攻撃に使われるとかいろいろ面倒なので、
分からないんだったらお金を払ってプロに任せること
分からないんだったらお金を払ってプロに任せること
2020/05/30(土) 22:41:26.50ID:LSfJlka0
わからんのなら引っ込んでろ
2020/05/30(土) 22:51:15.26ID:GvSsYxMg
>>626
そういえばそうですね。
記載いたします。
マスターサーバーのbindバージョン…9.11.4
マスターサーバー側のログ
tail /var/named/data/named.run
network unreachable resolving './DNSKEY/IN': xxxx:xxxx:xxxx:xxxx:xxxx#53
network unreachable resolving './DNSKEY/IN': xxxx:xxxx:xxxx:xxxx:xxxx#53
network unreachable resolving './DNSKEY/IN': xxxx:xxxx:xxxx:xxxx:xxxx#53
network unreachable resolving './DNSKEY/IN': xxxx:xxxx:xxxx:xxxx:xxxx#53
network unreachable resolving './DNSKEY/IN': xxxx:xxxx:xxxx:xxxx:xxxx#53
network unreachable resolving './DNSKEY/IN': xxxx:xxxx:xxxx:xxxx:xxxx#53
all zones loaded
running
managed-keys-zone: Key 20326 for zone . acceptance timer complete: key now trusted
client @0x7fac84041e30 xxx.xxx.xxx.xxx#52135 (xxxx.xxxx): zone transfer 'xxxx.xxxx/AXFR/IN' denied
そういえばそうですね。
記載いたします。
マスターサーバーのbindバージョン…9.11.4
マスターサーバー側のログ
tail /var/named/data/named.run
network unreachable resolving './DNSKEY/IN': xxxx:xxxx:xxxx:xxxx:xxxx#53
network unreachable resolving './DNSKEY/IN': xxxx:xxxx:xxxx:xxxx:xxxx#53
network unreachable resolving './DNSKEY/IN': xxxx:xxxx:xxxx:xxxx:xxxx#53
network unreachable resolving './DNSKEY/IN': xxxx:xxxx:xxxx:xxxx:xxxx#53
network unreachable resolving './DNSKEY/IN': xxxx:xxxx:xxxx:xxxx:xxxx#53
network unreachable resolving './DNSKEY/IN': xxxx:xxxx:xxxx:xxxx:xxxx#53
all zones loaded
running
managed-keys-zone: Key 20326 for zone . acceptance timer complete: key now trusted
client @0x7fac84041e30 xxx.xxx.xxx.xxx#52135 (xxxx.xxxx): zone transfer 'xxxx.xxxx/AXFR/IN' denied
2020/05/30(土) 22:51:37.09ID:GvSsYxMg
続きです
スレーブサーバーのbindバージョン…9.11.4
スレーブサーバー側のログ
tail -n 30 /var/log/messages
May 30 22:19:19 localhost named[7242]: zone xxx.xxx.xxx.in-addr.arpa/IN: refresh: retry limit for master xxx.xxx.xxx.xxx#53 exceeded (source 0.0.0.0#0)
May 30 22:19:19 localhost named[7242]: zone xxx.xxx.xxx.in-addr.arpa/IN: Transfer started.
May 30 22:19:19 localhost named[7242]: transfer of 'xxx.xxx.xxx.in-addr.arpa/IN' from xxx.xxx.xxx.xxx#53: failed to connect: host unreachable
May 30 22:19:19 localhost named[7242]: transfer of 'xxx.xxx.xxx.in-addr.arpa/IN' from xxx.xxx.xxx.xxx#53: Transfer status: host unreachable
May 30 22:19:19 localhost named[7242]: transfer of 'xxx.xxx.xxx.in-addr.arpa/IN' from xxx.xxx.xxx.xxx#53: Transfer completed: 0 messages, 0 records, 0 bytes, 0.002 secs (0 bytes/sec)
May 30 22:19:38 localhost named[7242]: zone xxxx.xxxxIN: refresh: retry limit for master xxx.xxx.xxx.xxx#53 exceeded (source 0.0.0.0#0)
マスターサーバー側のmessagesには特に何も出て無かったので割愛しております。
IPとかは伏せてます
>>627
すみません、なぜかコピペができなかったので手打ちしたので誤りがありましたね
スレーブサーバーのbindバージョン…9.11.4
スレーブサーバー側のログ
tail -n 30 /var/log/messages
May 30 22:19:19 localhost named[7242]: zone xxx.xxx.xxx.in-addr.arpa/IN: refresh: retry limit for master xxx.xxx.xxx.xxx#53 exceeded (source 0.0.0.0#0)
May 30 22:19:19 localhost named[7242]: zone xxx.xxx.xxx.in-addr.arpa/IN: Transfer started.
May 30 22:19:19 localhost named[7242]: transfer of 'xxx.xxx.xxx.in-addr.arpa/IN' from xxx.xxx.xxx.xxx#53: failed to connect: host unreachable
May 30 22:19:19 localhost named[7242]: transfer of 'xxx.xxx.xxx.in-addr.arpa/IN' from xxx.xxx.xxx.xxx#53: Transfer status: host unreachable
May 30 22:19:19 localhost named[7242]: transfer of 'xxx.xxx.xxx.in-addr.arpa/IN' from xxx.xxx.xxx.xxx#53: Transfer completed: 0 messages, 0 records, 0 bytes, 0.002 secs (0 bytes/sec)
May 30 22:19:38 localhost named[7242]: zone xxxx.xxxxIN: refresh: retry limit for master xxx.xxx.xxx.xxx#53 exceeded (source 0.0.0.0#0)
マスターサーバー側のmessagesには特に何も出て無かったので割愛しております。
IPとかは伏せてます
>>627
すみません、なぜかコピペができなかったので手打ちしたので誤りがありましたね
2020/05/30(土) 23:49:00.63ID:ASDSyN3p
DNSKEYいる?
とりあえずシンプルなところからやってみたら?
で、スレーブ側に
failed to connect: host unreachable
って出るのか、単にマスターからnotify受け取って、取りに行けないってことは
マスター側にfirewalldとかやってない?
ローカルの中のテスト環境?
グローバルipアドレスを持つvps同士?
とりあえずシンプルなところからやってみたら?
で、スレーブ側に
failed to connect: host unreachable
って出るのか、単にマスターからnotify受け取って、取りに行けないってことは
マスター側にfirewalldとかやってない?
ローカルの中のテスト環境?
グローバルipアドレスを持つvps同士?
2020/05/30(土) 23:56:17.73ID:GvSsYxMg
2020/05/30(土) 23:58:40.26ID:nkrSI7zY
DNSSEC無効にして試してみる
2020/05/31(日) 00:58:39.68ID:rqYC+lAR
まずbindを使うのをやめる
2020/05/31(日) 08:13:28.70ID:XCOiyD0Z
スレープサーバからマスターに向けて nmap やる。
TCP53が空いているかどうか、チェック。
TCP53が空いているかどうか、チェック。
637login:Penguin
2020/05/31(日) 08:36:51.32ID:yXr+nwqd deniedなのだから、そこを解決しないとだな。というか、DNSのマスター、スレーブ構成を一度でもセットアップ成功したことはあるの?
2020/05/31(日) 09:14:44.10ID:pEbStTkS
そもそもマスター側のBindがネットワークデバイスを掴めているのかどうか
localhostじゃなくて,IPアドレスを指定してDNS引ける?
スレーブにログインしてマスターのDNSにアクセスできてる?
localhostじゃなくて,IPアドレスを指定してDNS引ける?
スレーブにログインしてマスターのDNSにアクセスできてる?
639login:Penguin
2020/05/31(日) 10:30:17.46ID:v6HpcpjR 一般的には host unreachable が出てるならそもそもIPレイヤで通信できてない
bindのエラーメッセージがその流儀にしたがってるかは知らんが
bindのエラーメッセージがその流儀にしたがってるかは知らんが
2020/05/31(日) 10:33:03.63ID:rqqEWb6u
>>634-638
ありがとうございました。
DNSSEC無効化しましたらスレーブサーバー側にファイルが転送され、正引き逆引きできるようになりました。
マスターサーバーとスレーブサーバーでの構成は初めてなので色々調べたものの分からず相談いたしました。
スレーブサーバーからマスターサーバーへのアクセスは前から出来ており、マスターサーバーではIP指定でDNSが引けてました
ありがとうございました。
DNSSEC無効化しましたらスレーブサーバー側にファイルが転送され、正引き逆引きできるようになりました。
マスターサーバーとスレーブサーバーでの構成は初めてなので色々調べたものの分からず相談いたしました。
スレーブサーバーからマスターサーバーへのアクセスは前から出来ており、マスターサーバーではIP指定でDNSが引けてました
2020/05/31(日) 22:59:42.07ID:+knzO7bp
DNSSECで失敗するとしたら、マスタとスレーブで時刻がずれてんじゃないのけ?
2020/05/31(日) 23:14:49.76ID:FXWoFTOO
DNSSECってDKIMみたいな公開鍵でマスターのデータを検証するみたいな仕組み?
2020/06/02(火) 13:41:30.29ID:0XwPWt8n
CentOS7を最新版にしたら、tigervncが起動しなくなってしまった
644login:Penguin
2020/06/02(火) 14:53:28.19ID:QUuFvsCh それはたいへんだ。
2020/06/02(火) 14:55:55.77ID:tktCprlZ
blacktigervncにすれば
2020/06/02(火) 19:20:22.23ID:rscn4UtF
2020/06/02(火) 19:27:01.54ID:0NsIAYon
なんだか無性に大きなエビが食べたくなってきた・・・
テスト用centos8にgui入れて見たけど、端末でホームディレクトリ見ると
Windowsみたいなフォルダがたくさんあって変な感じ。
テスト用centos8にgui入れて見たけど、端末でホームディレクトリ見ると
Windowsみたいなフォルダがたくさんあって変な感じ。
648login:Penguin
2020/06/05(金) 14:03:15.69ID:BL1/8BmX localectlコマンドで
VC keymap:jp
x11 Layout:jp
仮装コンソールとGUIで日本語を使うと
認識しているけれども、いまいちわからない。
こういう風に単語を揃えて使えないの?
VC keymap:jp
x11 keymap:jp
初歩でつまるというか
疑問が湧き学習が進まないです
VC keymap:jp
x11 Layout:jp
仮装コンソールとGUIで日本語を使うと
認識しているけれども、いまいちわからない。
こういう風に単語を揃えて使えないの?
VC keymap:jp
x11 keymap:jp
初歩でつまるというか
疑問が湧き学習が進まないです
649login:Penguin
2020/06/05(金) 14:18:07.66ID:DMNYr23x koadkeysとかもあるしな
2020/06/05(金) 19:53:04.58ID:UmaR/jPs
構造レベルが異なるから用語も異なる
keymap 側は昔のGUI無いころのデバイスの頃の定義で
layout はそれ以降で追加したキーとかの定義が追加されてる
keymap が参照しているだろう jp106.map.gz の中見てみると変換,無変換辺りは
ないように見えるが /usr/share/X11/xkb/symbols/jp には入ってる
ちなみにどっちも101キーボードからの上書き情報 (例えばシフト押しながら2
を押したら @ じゃなくて " が出るとか) が定義されてるファイルだ
どの OS (やアプリ)もそうだけど増設の上の増設の上に成り立ってるからねぇ
そこらへんの歪さはしょうがない
keymap 側は昔のGUI無いころのデバイスの頃の定義で
layout はそれ以降で追加したキーとかの定義が追加されてる
keymap が参照しているだろう jp106.map.gz の中見てみると変換,無変換辺りは
ないように見えるが /usr/share/X11/xkb/symbols/jp には入ってる
ちなみにどっちも101キーボードからの上書き情報 (例えばシフト押しながら2
を押したら @ じゃなくて " が出るとか) が定義されてるファイルだ
どの OS (やアプリ)もそうだけど増設の上の増設の上に成り立ってるからねぇ
そこらへんの歪さはしょうがない
651login:Penguin
2020/06/05(金) 20:20:33.84ID:B8iy+Z492020/06/07(日) 19:04:48.84ID:Lk/dL6Qc
質問です
CentOS7でsambaサーバを構築し、Windowsから\\IPアドレス\設定したディレクトリにアクセスしようとしましたら
「アクセスできません」と表示されました
一体何が原因なのでしょうか
ちなみに設定はこうなっております。
smb.confの設定
[global]
dns proxy = No
map to guest = Bad User
netbios name = CENTOS7
ntlm auth = ntlmv1-permitted
printcap name = cups
security = USER
server string = Samba Server %v
idmap config * : backend = tdb
cups options = raw
[homes]
browseable = No
comment = Home Directories
inherit acls = Yes
read only = No
valid users = %S %D%w%S
[Share]
guest ok = Yes
path = /samba/share/
read only = No
CentOS7でsambaサーバを構築し、Windowsから\\IPアドレス\設定したディレクトリにアクセスしようとしましたら
「アクセスできません」と表示されました
一体何が原因なのでしょうか
ちなみに設定はこうなっております。
smb.confの設定
[global]
dns proxy = No
map to guest = Bad User
netbios name = CENTOS7
ntlm auth = ntlmv1-permitted
printcap name = cups
security = USER
server string = Samba Server %v
idmap config * : backend = tdb
cups options = raw
[homes]
browseable = No
comment = Home Directories
inherit acls = Yes
read only = No
valid users = %S %D%w%S
[Share]
guest ok = Yes
path = /samba/share/
read only = No
2020/06/07(日) 19:05:41.50ID:Lk/dL6Qc
次のログになります
/var/log/samba/log.smbd
[2020/06/07 19:00:06.721055, 0] ../../source3/smbd/uid.c:448(change_to_user_internal)
change_to_user_internal: chdir_current_service() failed!
[2020/06/07 19:00:06.724281, 0] ../../source3/smbd/uid.c:448(change_to_user_internal)
change_to_user_internal: chdir_current_service() failed!
[2020/06/07 19:00:06.725456, 0] ../../source3/smbd/uid.c:448(change_to_user_internal)
change_to_user_internal: chdir_current_service() failed!
[2020/06/07 19:00:08.208004, 0] ../../source3/smbd/uid.c:448(change_to_user_internal)
change_to_user_internal: chdir_current_service() failed!
/var/log/samba/log.nmbd
nmbd version 4.10.4 started.
Copyright Andrew Tridgell and the Samba Team 1992-2019
[2020/06/07 18:45:19.093362, 0] ../../lib/util/become_daemon.c:136(daemon_ready)
daemon_ready: daemon 'nmbd' finished starting up and ready to serve connections
[2020/06/07 18:45:42.327961, 0] ../../source3/nmbd/nmbd_become_lmb.c:397(become_local_master_stage2)
*****
Samba name server CENTOS7 is now a local master browser for workgroup WORKGROUP on subnet 192.168.122.1
*****
気になるのはサブネットが192.168.122.1になっているところです。
CentOS7のIPは192.168.0.19でWindowsのIPは192.168.0.35で
192.168.122.1はNATでのIPだと思われます。
/var/log/samba/log.smbd
[2020/06/07 19:00:06.721055, 0] ../../source3/smbd/uid.c:448(change_to_user_internal)
change_to_user_internal: chdir_current_service() failed!
[2020/06/07 19:00:06.724281, 0] ../../source3/smbd/uid.c:448(change_to_user_internal)
change_to_user_internal: chdir_current_service() failed!
[2020/06/07 19:00:06.725456, 0] ../../source3/smbd/uid.c:448(change_to_user_internal)
change_to_user_internal: chdir_current_service() failed!
[2020/06/07 19:00:08.208004, 0] ../../source3/smbd/uid.c:448(change_to_user_internal)
change_to_user_internal: chdir_current_service() failed!
/var/log/samba/log.nmbd
nmbd version 4.10.4 started.
Copyright Andrew Tridgell and the Samba Team 1992-2019
[2020/06/07 18:45:19.093362, 0] ../../lib/util/become_daemon.c:136(daemon_ready)
daemon_ready: daemon 'nmbd' finished starting up and ready to serve connections
[2020/06/07 18:45:42.327961, 0] ../../source3/nmbd/nmbd_become_lmb.c:397(become_local_master_stage2)
*****
Samba name server CENTOS7 is now a local master browser for workgroup WORKGROUP on subnet 192.168.122.1
*****
気になるのはサブネットが192.168.122.1になっているところです。
CentOS7のIPは192.168.0.19でWindowsのIPは192.168.0.35で
192.168.122.1はNATでのIPだと思われます。
2020/06/07(日) 19:41:06.29ID:rzWu4M7L
smb.confのinterfacesとbind interfaces onlyの値を確認
2020/06/07(日) 21:40:02.00ID:r9fTIFht
CentOS 側の firewall でアクセス許可されていないんじゃないか?
192.168.0 サイドは Windows が起動済みだから Workgroup のローカルマスター
になる必要が無い(Windows 側でローカルマスター起動済みだ)が、
192.168.122 サイドは誰もいないから smbd がローカルマスターになる必要があった
ってだけだからそのログ自体は気にしなくて良いと思う
192.168.0 サイドは Windows が起動済みだから Workgroup のローカルマスター
になる必要が無い(Windows 側でローカルマスター起動済みだ)が、
192.168.122 サイドは誰もいないから smbd がローカルマスターになる必要があった
ってだけだからそのログ自体は気にしなくて良いと思う
2020/06/07(日) 21:58:24.96ID:Lk/dL6Qc
2020/06/07(日) 22:21:11.09ID:cIYAS+pl
>>656
SELinuxは?
SELinuxは?
2020/06/07(日) 22:57:08.20ID:Lk/dL6Qc
>>657
無効にしており、getenforceで確認したところdisableになりました。
無効にしており、getenforceで確認したところdisableになりました。
2020/06/07(日) 23:41:58.37ID:e55RVERu
誰かタスケテ・・・
CentOS7、muninでapacheだけ処理できないんだけど
# wget -q -O - http://127.0.0.1/server-status/?auto
Total Accesses: 2835
Total kBytes: 41719
と出るのに、
# munin-run apache_accesses
accesses80.value U
と出ない、wgetは一般ユーザでも(切り分け的に)globalからでもserver-statusは出てます。
こんなこと初めてでどこから切り分ければいいか・・・
CentOS7、muninでapacheだけ処理できないんだけど
# wget -q -O - http://127.0.0.1/server-status/?auto
Total Accesses: 2835
Total kBytes: 41719
と出るのに、
# munin-run apache_accesses
accesses80.value U
と出ない、wgetは一般ユーザでも(切り分け的に)globalからでもserver-statusは出てます。
こんなこと初めてでどこから切り分ければいいか・・・
660login:Penguin
2020/06/08(月) 10:09:12.15ID:Km+QPinN >>652
map to guest = Bad User
とか必要なの。CentOS7デフォルトの設定でやったらどうなる。後、windows10ならSMB1.0有効で為すかwindows7あたりで確認。
map to guest = Bad User
とか必要なの。CentOS7デフォルトの設定でやったらどうなる。後、windows10ならSMB1.0有効で為すかwindows7あたりで確認。
661login:Penguin
2020/06/08(月) 10:09:58.28ID:Km+QPinN /為す/試す/
662login:Penguin
2020/06/08(月) 10:26:30.41ID:Km+QPinN >>659
Total Accessesが出てるってことは、ExtendedStatus Onになってるってことなのかな。
Total Accessesが出てるってことは、ExtendedStatus Onになってるってことなのかな。
2020/06/08(月) 14:31:44.07ID:3XM2CyJR
>>662
ベタですがそこは大丈夫です。
/etc/httpd/conf.d/server_status.conf
---
ExtendedStatus On
<Location /server-status>
SetHandler server-status
Require ip 127.0.0.1
</Location>
こちらもmuninのapacheは10回ぐらいはやっているのですが、
特にトラブルも無かったので、もう少しデバッグレベルを上げられれば良いのですが、
server-statusが出ているだけに
# munin-run apache_accesses
accesses80.value U
# munin-run apache_processes
busy80.value U
idle80.value U
free80.value U
これらが出ないなんて初めてです・・
ベタですがそこは大丈夫です。
/etc/httpd/conf.d/server_status.conf
---
ExtendedStatus On
<Location /server-status>
SetHandler server-status
Require ip 127.0.0.1
</Location>
こちらもmuninのapacheは10回ぐらいはやっているのですが、
特にトラブルも無かったので、もう少しデバッグレベルを上げられれば良いのですが、
server-statusが出ているだけに
# munin-run apache_accesses
accesses80.value U
# munin-run apache_processes
busy80.value U
idle80.value U
free80.value U
これらが出ないなんて初めてです・・
2020/06/08(月) 15:37:42.14ID:k5SPE86j
Apacheを窓ガラス投げ捨てよう
665login:Penguin
2020/06/08(月) 15:37:58.18ID:Km+QPinN sudo yum install munin --enablerepo=epel
munin-run apache_accesses
accesses80.value 265
うちではこう。デフォルトで何もいじらなければ問題ないはず。
munin-run apache_accesses
accesses80.value 265
うちではこう。デフォルトで何もいじらなければ問題ないはず。
2020/06/08(月) 20:29:10.26ID:XFQu+N7I
debug modeで動かす、ログを見る、パケットをキャプチャーする
2020/06/08(月) 22:48:41.93ID:WgVX7yEi
一休みする、お茶を飲む、念仏を唱える
2020/06/08(月) 23:28:13.16ID:o8kGVpTy
>>656
CentOS 7.7 環境で mkdir -p /samba/share して smb.conf 同じにして
起動してみたけど
mount -t cifs -o guest //(ホスト名)/Share /mnt/foo
とか、同 -o user=dummy,password=dummy とか、Linux からのアクセスだけ
でなく、ドメイン非参加 Win10 Pro からもマウント出来たわ。
Windows からのアクセス時のアカウント名のドメイン名みて認証しに
以降としているのかもな。
アクセスするときの ID 内のドメイン名を . (ドット) 明示で .\dummy
とかにしてみたらどうよ?
CentOS 7.7 環境で mkdir -p /samba/share して smb.conf 同じにして
起動してみたけど
mount -t cifs -o guest //(ホスト名)/Share /mnt/foo
とか、同 -o user=dummy,password=dummy とか、Linux からのアクセスだけ
でなく、ドメイン非参加 Win10 Pro からもマウント出来たわ。
Windows からのアクセス時のアカウント名のドメイン名みて認証しに
以降としているのかもな。
アクセスするときの ID 内のドメイン名を . (ドット) 明示で .\dummy
とかにしてみたらどうよ?
2020/06/09(火) 02:54:10.30ID:6luWKM87
670login:Penguin
2020/06/09(火) 08:10:45.24ID:nKga5RJf 見れなくなったって挙動が全く変わらないということ?ログとか含めて全部?
2020/06/09(火) 08:22:43.01ID:SdtuqtTg
>>669
Explorer 開いてPCを右クリック、ネットワークドライブの割り当て、からドライブにマウント
しようとするとドライブ名とフォルダーを訊いてくるダイアログが開くから、そこで別の資格
情報を使用して接続するを選択。
その際にユーザー名とパスワードの入力が求められる。
ユーザ名は単純にユーザ名を指定する以外に ドメイン名\ユーザ名 だったり
ユーザ名@ドメイン名 でも指定が可能。
なお、前者は NETBIOS 名と呼ばれるほうのドメイン名を指定する必要がある。
指示としては NETBIOS 名にドットだけつけた .\ユーザ名 を指定しろ、特に
map to guest = Bad User で確実にゲストアカウントとして認識されるように存在しない
ユーザ(Bad User)でアクセスしろ、ということ。
Explorer 開いてPCを右クリック、ネットワークドライブの割り当て、からドライブにマウント
しようとするとドライブ名とフォルダーを訊いてくるダイアログが開くから、そこで別の資格
情報を使用して接続するを選択。
その際にユーザー名とパスワードの入力が求められる。
ユーザ名は単純にユーザ名を指定する以外に ドメイン名\ユーザ名 だったり
ユーザ名@ドメイン名 でも指定が可能。
なお、前者は NETBIOS 名と呼ばれるほうのドメイン名を指定する必要がある。
指示としては NETBIOS 名にドットだけつけた .\ユーザ名 を指定しろ、特に
map to guest = Bad User で確実にゲストアカウントとして認識されるように存在しない
ユーザ(Bad User)でアクセスしろ、ということ。
672login:Penguin
2020/06/09(火) 23:35:20.09ID:OHQ7xaCG centos6をデスクトップ使えるように導入して
ISOイメージからyumできるようにチャレンジしている。
仮装環境でISO読み込んだらCentos側で認識してるけど、dev、mnt、mediaの違いがわからん
難しすぎでしょ
マウントコマンド使っていないのに
勝手にマウントされてる気がするし、
なんだかんだでまだyumできていないという
ISOイメージからyumできるようにチャレンジしている。
仮装環境でISO読み込んだらCentos側で認識してるけど、dev、mnt、mediaの違いがわからん
難しすぎでしょ
マウントコマンド使っていないのに
勝手にマウントされてる気がするし、
なんだかんだでまだyumできていないという
2020/06/10(水) 00:24:58.58ID:qovKnRkw
なんで6?
のこり数カ月でサポート終わるのに
のこり数カ月でサポート終わるのに
674login:Penguin
2020/06/10(水) 03:00:23.51ID:POPlEAUE local-install
675login:Penguin
2020/06/10(水) 08:52:41.40ID:gJywySq0 dev デバイスファイルディレクトリ。/dev/sr0 とかがマウント元になる。
mnt マウントディレクトリ。自分で/mnt/cd-romとか作ってマウント先とする。
media OSが勝手にマウントする先。自分はいじらない、見るだけ。
mnt マウントディレクトリ。自分で/mnt/cd-romとか作ってマウント先とする。
media OSが勝手にマウントする先。自分はいじらない、見るだけ。
676login:Penguin
2020/06/10(水) 23:12:17.49ID:zXKXu/r2■ このスレッドは過去ログ倉庫に格納されています
ニュース
- 「高市総理はリフレ論者ではない」 米財務長官「リフレ政策やめるべき」発言後、経済閣僚火消し相次ぐ [蚤の市★]
- 日本、核兵器保有・原子力潜水艦保有の議論へ 小泉進次郎防衛相 「我々に対する脅威を拒否する力を持たなければいけない」 ★2 [お断り★]
- 【アイド】FRUITS ZIPPER仲川瑠夏が体調不良のためコンサート欠席 [ヴァイヴァー★]
- 「元AKBで1番の勝ち組」東海てつや&峯岸みなみの大豪邸「レベル違いすぎる」「想像をはるか超えてとんでもない」 [ヴァイヴァー★]
- 「路上で突然突き飛ばされたり、殺害予告が届いたりする日本での日常のほうが、私には怖くて危険」渡邊渚が綴る「世界を旅する理由」★3 [Ailuropoda melanoleuca★]
- 【(・(ェ)・)】道路横断中のヒグマの親子見つけ停止…親グマが車に複数回突進し前方部分を破損 北海道美深町 [ぐれ★]
- 【悲報】大阪万博の跡地開発、応募ゼロで全く進んでいない事が判明wwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwww [841411289]
- 映画館トナラー、炎上wwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwww [398059782]
- 【悲報】登録者70万人のYouTubeCH「絶望ライン工」が結婚&出産発表 ガチ恋の女性が「裏切られた」と発狂して大炎上中www [793117252]
- 高市政権、さっそく中国に反論。「いかなる国も国連の敵国条項を援用する余地はない」 [668024367]
- 【朗報】踊る大捜査線室井慎次スピンオフ映画、全作地上波初放送w w w w w w w w w w w w w w w w w
- 中村奨吾、退団wwwwwwwwwwwwwwwwwwwwwwww