リモート(hoge)で稼働しているTCP emacs serverに
ローカル(mage)のemacsclientで接続したいです
mageでemacsclient -c -f "server_file" を実行すると
hogeにウインドウが出てしまいます
emacsclient -c -d :10 -f "server_file" とすると
*ERROR*: Display :10 can't be opend とエラーになります
ところがmageでxtermを2つ開いて一方でhogeにsshでログインしておき
もう一方のxtermで emacsclient -c -d :10 -f "server_file" とすると
希望通りmageにウインドウが出ます
なおこの状態でhogeへのsshでの接続をログアウトすると
emacsclientが終了します(サーバ側は無事です)
DISPLAY環境変数やxhostやxauth? あたりの設定だと思うのですが
どのように設定すれば良い良いでしょうか?