探検


【視聴・録画】Linuxでテレビ総合17 [無断転載禁止]

レス数が900を超えています。1000を超えると表示できなくなるよ。
1login:Penguin
垢版 |
2023/09/21(木) 18:38:42.88ID:Ui36TitX
Linuxでのテレビ視聴・録画に関して、デジタル/アナログ問わず扱うスレッド

・関連スレ
【自家製】MythTV Part.3【HDDビデオ】
http://hayabusa6.2ch.net/test/read.cgi/linux/1223721998/


・前スレ
【視聴・録画】Linuxでテレビ総合16 [無断転載禁止]©2ch.net
https://mao.5ch.net/test/read.cgi/linux/1501170434/

・過去スレ
15 http://mao.2ch.net/test/read.cgi/linux/1496802072/
14 http://hayabusa6.2ch.net/test/read.cgi/linux/1487503115/
13 http://hayabusa6.2ch.net/test/read.cgi/linux/1475513549/
12 http://hayabusa6.2ch.net/test/read.cgi/linux/1464964277/
11 http://hayabusa6.2ch.net/test/read.cgi/linux/1447412254/
10 http://hayabusa6.2ch.net/test/read.cgi/linux/1417559598/
9 http://hayabusa6.2ch.net/test/read.cgi/linux/1388900589/
8 http://engawa.2ch.net/test/read.cgi/linux/1359268284/
7 http://engawa.2ch.net/test/read.cgi/linux/1342343650/
6 http://engawa.2ch.net/test/read.cgi/linux/1326804531/
5 http://engawa.2ch.net/test/read.cgi/linux/1309182037/
4 http://hibari.2ch.net/test/read.cgi/linux/1293388638/
3 http://hibari.2ch.net/test/read.cgi/linux/1269999876/
2 http://pc11.2ch.net/test/read.cgi/linux/1253880711/
1 http://pc11.2ch.net/test/read.cgi/linux/1231189481/
Linuxでテレビを見る http://pc11.2ch.net/test/read.cgi/linux/1013649811/
2024/11/19(火) 18:25:11.27ID:DmrTxUl8
raspiは10月に特大アップデートがあったので不用意にアプデすると死ぬ
810login:Penguin
垢版 |
2024/11/19(火) 18:57:36.64ID:gzdZGH5l
​ここら辺期待して px4_drv 0.5.1 にアップデートしたんだけど、PX-M1URではとくに改善なし
地上波やCSはビクともしないのに、相変わらずBSだけドロップしまくる

driver: Digibest 製チューナーに常に USB 電源を供給し、チューナーが不安定にならないようにする
​driver: ISDB2056N で衛星放送の受信結果がエラーパケットだらけになる問題が修正されそうな変更を試す
​driver: ISDB2056N で衛星放送がエラーパケットばかりで正常に受信できない問題を修正
811雀の涙
垢版 |
2024/11/20(水) 06:31:32.41ID:y6+m7DmQ
>>808でカーネルアップデートしたらドライバが動かなくなったと書いたんですが、
調べたらアップデートの際にカーネルヘッダーが正しくインストールされてなかったのが原因でした@KDEneon6.2

今は全て正常に動いてます。失礼しました
2024/11/20(水) 17:54:48.76ID:ax5G90HC
pi4(64bit bookwarm)にBondriverProxyEXをインストールして、付属のsampleで録画できる所までは確認したのですが、
Windows側のtvtest10(64bit)+bondriver_proxy.dllで見ようとするとEの数字が増えて、黒画面になってしまいます。
ココ確認しろって場所ありますか?
tvtest から別のmirakcに接続したときは、見えているので、tvtestのデコーダ周りではないと思うのですが、、、
2024/11/21(木) 19:40:38.61ID:7S7kPCHy
あああ、半年悩んでやっとわかった
Pi5とPx-S1UDのUSBの相性が悪くて5V5AでもUSB給電不良が起こるから間にハブ噛ませると安定する!!
2024/11/21(木) 20:35:07.90ID:tMdfPlOQ
なるほど!え?ケースの中に羽生持ってくんの?
2024/11/21(木) 20:35:57.52ID:tMdfPlOQ
は…ハブです
すまんこ
2024/11/21(木) 21:28:38.24ID:sGstQNtl
https://i.imgur.com/FIdm7xD.jpeg
2024/11/22(金) 14:32:43.72ID:Su/FCT3J
ハブに噛まれたといえばこの人 https://i.imgur.com/AKZdmUz.jpeg
818812
垢版 |
2024/11/22(金) 15:25:03.51ID:ttDeuGsb
>>812
解決しました。
機材を動かした時に、カードが半刺しになっていた模様。
2024/11/24(日) 13:26:43.50ID:n5ebJdFh
教えてください!
docker-mirakurun-epgstationの環境なんだけど、ファイル名にある、「‼」(ビックリマーク2個が1文字になってる)を2バイト文字の!を2個に変換するには、ソースのどこをいじればいいでしょう?
2024/11/24(日) 15:20:48.65ID:RawsImwA
ソースいじるならStrUtilでreplaceFileNameなんかをかきかえたらいいかも
ソースいじらないならリンク先でAPI使った方法が紹介されてる
s://github.com/l3tnun/EPGStation/issues/472#issuecomment-900301997
2024/11/24(日) 18:27:12.03ID:0OF7Bsjz
文字化け対策だから関係ないかもだけど、これやっとくとepgstationでフォルダ作ると文字化けしてしまうのを回避できる。
ってのをどっかで読んだ。

samba.conf
globalに以下追記
mangled names = no
vfs objects = catia
catia:mappings = 0x22:0xa8,0x2a:0xa4,0x2f:0xf8,0x3a:0xf7,0x3c:0xab,0x3e:0xbb,0x3f:0xbf,0x5c:0xff,0x7c:0xa6
2024/11/25(月) 17:33:06.12ID:v67cl6Uj
recpt1の新しいフォーク版見つけた
動作確認していないけど最新のBS改編に対応しているはず

https://github.com/stu2005/recpt1
2024/11/27(水) 09:03:25.78ID:o9QMEq8S
すみませんどなたかわかればご教示いただきたいのです。
Rpi5にdocker-mirakurun-epgstationでPX-S1UDを使用しているのですがイントラで運用するためにDHCPを設定するとmirakurunのログや設定のアクセスが異様に重くなります。
重い状態だとepgstationもmirakurunをさわれないらしく1分くらい見れなくなります。
mirakurunがあらぬネットワークを探索してるような気がするのですが、対処方法わかりますでしょうか。
2024/11/28(木) 14:03:46.04ID:tKrF2lbV
ハイスペックPCで4K放送見てるよ

ラジオライフ8月号
https://i.imgur.com/aLevPEN.png

PT4KのLinux用driverが出てる
https://seesaawiki.jp/pt4k/d/LinuxDriver
825812
垢版 |
2024/11/28(木) 22:17:26.86ID:TSmWaRs+
>>822
stz2012も11日に更新済み
2024/11/29(金) 00:07:11.02ID:qijW/14u
>>825
気が付かなかったけどstz版の動作確認したので
https://rentry.co/tschardev20240203
に反映

あと
recpt1 --help
で表示されるメッセージの修正が抜けているのでパッチを追加
https://pastebin.com/aJ1dMALR

アニマックスの場合、236 でチャンネル設定するなら関係ないけど
BS03_1 のように指定する場合のヘルプメッセージが間違っている
2024/11/29(金) 00:07:51.73ID:qijW/14u
>>826
パッチ間違えた
https://pastebin.com/HNE6Pyu5
2024/11/29(金) 09:52:31.90ID:QXPumT0l
>>822
github で、recpt1 を検索して
(https://github.com/search?q=recpt1%20in%3Aname%20fork%3Atrue&type=repositories)
更新日でソートすると、11/11 以降に更新されたのは次の5つだね。

https://github.com/kaikoma-soft/recpt1
https://github.com/shirow-github/recpt1
https://github.com/shisomaki/recpt1
https://github.com/stu2005/recpt1
https://github.com/stz2012/recpt1
2024/11/29(金) 12:38:22.43ID:Sgr0/szp
>>826
stzヘルプも取り込まれた模様
2024/12/01(日) 00:33:48.50ID:tWurSG0m
>>829
全部パッチが取り込まれたようなので
https://rentry.co/tschardev20240203
に反映
2024/12/02(月) 22:17:15.64ID:W8+PBGRN
otya氏がMirakurunやEPGStationをフォークして何やら始めた模様
https://github.com/otya128
2024/12/03(火) 09:46:22.80ID:HTXLPaN4
>>831
4k対応させてるのね
2024/12/08(日) 03:13:50.99ID:A9W2kAJk
JoinLogScpTrialSetでCMカットだけしたいが
834833
垢版 |
2024/12/08(日) 03:17:41.62ID:A9W2kAJk
以下のエラーが解消できない
L-SMASH Source入れろってとこだと思うけど何をどうすればいいのか全くわからん

logoframe Avisynth error: Script error: There is no function named 'LWLibavVideoSource'.
(/opt/JoinLogoScpTrialSetLinux/modules/join_logo_
logoframe scp_trial/result/test/in_org.avs, line 2)
2024/12/18(水) 21:07:41.24ID:LtFdSAuH
i7-8700kベースのPCにProxmoxを入れて、
VM上でDocker版のMirakurunを動かしてます。
↓これを入れてる
https://github.com/l3tnun/docker-mirakurun-epgstation

VMにCPUは2コア, メモリは4GBを割り当てて
地デジはまったく問題なく録画できますが、
BSの録画が出来ずにいます。

dvbv5-zap -a 2 -c ./config/dvbconf-for-isdb/conf/dvbv5_channels_isdbs.conf -r -P BS15_0
でdvbv5-zapを単体で動作させると
ERROR Need a LNBf to work
(0x00) C/N= -1.10dB postBER= 0
(0x00) C/N= -0.17dB postBER= 0
(0x00) C/N= -0.04dB postBER= 0
のように信号レベルが低く、受信できません。
またLNBが動いてないっぽいエラーも出てます。

dvbv5-zap -l 110BS -a 2 -c ./config/dvbconf-for-isdb/conf/dvbv5_channels_isdbs.conf -r -P BS15_0
のようにLNBを明示的に使用するオプションも試しましたが、
ERROR command POLARIZATION (256) not found during retrieve
ERROR FE_SET_TONE: Unknown error 524
ERROR FE_SET_PROPERTY: Invalid argument
のように表示され、dvbv5-zapが動かうずうまく行きませんでした。

ちなみに
dvbv5-zap -a 2 -c ./config/dvbconf-for-isdb/conf/dvbv5_channels_isdbs.conf -r -P BS15_0
の時にPT3のBNC端子にデジタルマルチメータを当ててみましたがDCは出ていないようです。

家族の部屋でTVをONにするとMirakurunでBS録画できるので、
LNBの制御が正しくできていないと疑っていますが、
どこを修正すればいいのか分からない状態です。
836login:Penguin
垢版 |
2024/12/18(水) 23:41:53.05ID:AVxu/pAQ
>>835
以前自分も色々試したけどearth_pt3ドライバだと結局PT3からアンテナに給電できなかったわ
他からアンテナに給電できたのでそれ以上追っかけなかった
pt3_drvだとモジュール読込時のオプションでLNBの指定ができるとかの情報はあったっけ
2024/12/19(木) 16:56:59.67ID:jQ5vZfQL
LNB給電アダプタ買ったほうがはやいよ
2024/12/19(木) 16:59:26.13ID:d/xwBECq
https://itest.5ch.net/mao/test/read.cgi/linux/1501170434/253
839835
垢版 |
2024/12/19(木) 18:16:19.42ID:2MrtvRNo
結局これ買った
尼のASINでいうとこのB07DK8BZZZ
2024/12/21(土) 00:30:57.49ID:+1+fETds
>>835のPT3で衛星アンテナに自己給電できないってのは
このDockerの不具合でできないのか
それとも、PT3+Mirakurunの仕様でできないのか
はたまた、たんにPT3の給電に関するなんかが壊れていてできないとか。
後は、設定を間違っているとかか
2024/12/21(土) 01:07:51.63ID:dWEAUrhO
>>835,840

PT3自体は製品の仕様ページみれば分かる通りちゃんとLNB対応してる
ttps://earthsoft.jp/PT3/specification.html

docker-mirakurun-epgstation見るとDVBデバイスとして存在するチューナをマッピングしてるだけなので、ホスト側で対応が必要。

DVB版もchardevのこれをベースにしてるのでパラメータは同じだから、lnbを設定してやればいい
ttps://github.com/m-tsudo/pt3

設定方法はここらへん参考に。
ttps://wiki.archlinux.jp/index.php/%E3%82%AB%E3%83%BC%E3%83%8D%E3%83%AB%E3%83%A2%E3%82%B8%E3%83%A5%E3%83%BC%E3%83%AB#.E3.83.A2.E3.82.B8.E3.83.A5.E3.83.BC.E3.83.AB.E3.82.AA.E3.83.97.E3.82.B7.E3.83.A7.E3.83.B3.E3.82.92.E8.A8.AD.E5.AE.9A.E3.81.99.E3.82.8B
2024/12/21(土) 09:57:42.51ID:ZKDbXbbI
>>841
DVB版erath_pt3にはパラメーターとしてlnbはなさそうなんだよね。
modinfo -p earth_pt3
adapter_nr:DVB adapter numbers (array of short)
one_adapter:Place FE's together under one adapter. (bool)
num_bufs:Number of DMA buffer (188KiB) per FE. (int)

ttps://github.com/u-n-k-n-o-w-n/BonDriverProxy_Linux/blob/62438c058f990ea8bd58ff6d07da85e9739c9e27/BonDriver_DVB.cpp#L436-L449
こっちのやり方ならLNBのON,OFFが出来ることは確認したけど、
dvbv5-zapでのやり方がわからないな。confにVOLTAGE=18とか書いたら
良いのかと期待したけどだめだった。

自分も>>839の常時給電で対応してしまった。
2024/12/21(土) 10:37:40.19ID:TaEXo8Fm
むかしDVB版で頑張って出来なくて諦めた記憶あるわ
844login:Penguin
垢版 |
2024/12/21(土) 11:29:21.81ID:inTONw99
>>842
自分も昔調べたけどDVB版ドライバにはそんなオプションなかったよな…と思ってたがやっぱり無いよね
他の録画コマンド(recisdbとか)を使ってもLNBの設定が上手くいかなかったからDVB版ドライバ(earth_pt3)自体がLNB対応できてないのかと思ってたけどそうでもないのかな?
まあ自分も他からの給電で対応したので追いかける気が起こらないのだけど
2024/12/21(土) 18:29:27.27ID:b0Uosp2R
https://git.kernel.org/pub/scm/linux/kernel/git/mchehab/linux-media.git/tree/drivers/media/pci/pt3/pt3.c#n356
ドライバにはあるみたいだけど
2024/12/21(土) 22:57:23.46ID:b4lyz+oa
>>835
DVBドライバはよく知らないんだけど、アンテナ給電はearth_pt3モジュール側で
設定するのではなくて、録画プログラム側でioctlを発行して設定する形だと思う

で、recdvbにはそれっぽいコードがあるけどdvbv5-zapにはないように見える
https://github.com/dogeel/recdvb/blob/master/recpt1core.c#L439
https://github.com/gjasny/v4l-utils/blob/master/utils/dvb/dvbv5-zap.c

dvbv5-zapがアンテナ給電に非対応なような気がする
847login:Penguin
垢版 |
2024/12/21(土) 23:34:24.66ID:inTONw99
recdvbってコマンドを使ってみたら普通にLNBに給電できてるっぽいな、端子で電圧測定まではしてないけど
なのでやっぱりdvb版ドライバは問題なくて、コマンドの問題なのね
mirakurun dockerの録画コマンドを別のに差し替えてチューナーの設定を行えばいけそうだけど、それはそれで面倒か…
848login:Penguin
垢版 |
2024/12/22(日) 02:00:50.95ID:dX0U+RfN
>>846
dvbv5-zapがアンテナ給電を制御してないなら、他でアンテナ給電の設定だけしておけばいいのかね
Linux起動時にホスト側で recdvb --dev 0 --lnb 15 とかやっておくとか
常時給電状態にはなっちゃうけど
2024/12/22(日) 12:01:09.07ID:S4yi+6iy
-w, --lna=LNA (0, 1, -1) enable/disable/auto LNA power

これ追加で行けるんちゃうの?LNAに供給されればLNBにもいくかと、
2024/12/22(日) 15:02:13.24ID:9fSjGV85
lnaも試してダメだった気がするけど昔のことで記憶が怪しい
とりあえず質問者は試してみたらいいんじゃないかな
2024/12/22(日) 20:24:54.51ID:AWolGTY7
TT
2024/12/22(日) 20:27:17.25ID:fNq+qJzv
DVBよくわからないんだけどdvbv5-zapが利用しているlibdvbv5のコードを見ると
強制的にアンテナ給電OFFにしているように見える

https://github.com/cz172638/v4l-utils/blob/7b2d48ff594dcc2c9b395463441e5abb4f5e9439/lib/libdvbv5/dvb-fe.c#L1750
https://github.com/cz172638/v4l-utils/blob/7b2d48ff594dcc2c9b395463441e5abb4f5e9439/lib/libdvbv5/dvb-fe.c#L452

ONにするには
dvb_fe_sec_voltage(&parms->p, 1, 1);
みたいなコードがいるはず

やっぱりdvbv5-zapはアンテナ給電に非対応なような気がする
2024/12/22(日) 22:44:09.24ID:OeUE949h
int dvb_fe_lnb_high_voltage(struct dvb_v5_fe_parms *p, int on)
{
struct dvb_v5_fe_parms_priv *parms = (void *)p;
int rc;

if (on) on = 1;
if (parms->p.verbose)
dvb_log( _("DiSEqC HIGH LNB VOLTAGE: %s"), on ? _("ON") : _("OFF") );
rc = xioctl(parms->fd, FE_ENABLE_HIGH_LNB_VOLTAGE, on);
if (rc == -1) {
dvb_perror("FE_ENABLE_HIGH_LNB_VOLTAGE");
return -errno;
}
return rc;
}
2024/12/22(日) 23:40:04.35ID:fNq+qJzv
>>853
dvb_fe_lnb_high_voltageはどこからも呼ばれていないと思う
2024/12/23(月) 00:41:09.48ID:q1JBvx7i
LNB有効にする方法わかった。
dvbv5-zapを-vオプション付きで起動してやると表示されるエラーだけど
L-Band frequency: 4285338.78 MHz (offset = 10678.00 MHz)
ERROR FE_SET_PROPERTY: 無効な引数です

チャンネルBS01_0は、周波数1049480で、1049480 - 10678000 = -18320 = 4285338776
dvbv5-zap側で周波数を10678000引いてるのね。であれば、confファイルのFREQUENCYに
10678000を加えた値を指定してやればよさそう。1049480 + 10678000 = 11727480。
#FREQUENCY = 1049480
FREQUENCY = 11727480

dvbv5-zap -a 0 -v -l 110BS -c ./dvbv5_channels_isdbs.conf -r -P BS01_0 -o a.ts -t 10
tuning to 11727480 Hz
LNBf with a single LO at 0.00 MHz
frequency: 11727.48 MHz, high_band: 0
ERROR command POLARIZATION (256) not found during retrieve
SEC: set voltage to 18V
DiSEqC TONE: OFF
ERROR FE_SET_TONE: 不明なエラーです 524
L-Band frequency: 1049.48 MHz (offset = 10678.00 MHz)
...
SEC: set voltage to OFF
2024/12/23(月) 01:24:45.21ID:q1JBvx7i
dvbv5-zapでLNBを有効にするには
* confファイルのFREQUENCYは12GHz帯の中心周波数をHzで設定する
* dvbv5-zapの起動オプションに「-l 110BS」を追加する

12GHz帯の中心周波数はここの左側の値。
https://sun-ele.co.jp/support/how/bs_freq.html
左側の12GHz帯と右側のBS-IF帯の差が110678000。
857login:Penguin
垢版 |
2024/12/23(月) 02:05:28.01ID:TtF9q5Xr
>>855
なるほどーLNBを指定したらIF帯の周波数になるように計算してくれるのでconfには搬送波の中心周波数を記載すればよかったのね
ずっと気になってた謎が解けました、ありがとう

>>842
なので対策方法は、dvbv5_channels_isdbs.confのFREQUENCYを全部+10678000した値に修正したものを
docker-mirakurun-epgstation/mirakurun/conf にでも置いて
チューナーの設定でBSのところを
dvbv5-zap -a 0 -l 110BS -c /app-config/dvbv5_channels_isdbs.conf -r -P <channel>
みたいに変更すればいけると思います
858login:Penguin
垢版 |
2024/12/23(月) 02:07:30.03ID:TtF9q5Xr
ごめん、上のは >>835 だった
2024/12/23(月) 07:39:09.85ID:q1JBvx7i
>>856はHzじゃなくてkHzだね。後、チューナーによっては
LNBもconfファイルで設定した方が良いかもしれない。

>>857分かりやすい説明ありがとう。
2024/12/23(月) 08:26:52.39ID:SmxDWHet
>>855
おーすばらしい
>>846と>>852で見当違いのこといっててごめんね
2024/12/23(月) 21:06:24.78ID:XOXOyA+P
チューナーカードから給電って寿命削りそう(宗教)だから給電用の途中で挟んでる。
2024/12/24(火) 01:10:57.88ID:6HCgiRBO
とりあえず給電中に抜き差しすると死ぬのは確か
2024/12/24(火) 21:16:09.23ID:o/0HrzWW
こわ
2024/12/27(金) 00:27:51.51ID:b3xWbRJ4
ちょっと気になる

総務省、BS/CS 2K放送にもHEVC圧縮が利用できる改正案。パブコメ開始
https://av.watch.impress.co.jp/docs/news/1651036.html
2024/12/27(金) 00:55:26.61ID:8C5Z6aHQ
実現したらうれしいけど、一般的な2k TVは買い替え必須なんでまず実現しないだろうな。
いやまてよ、1セグってMPEG-2よりましなコーデックなんだよな。
なら2K TVもいけるのか。無理っぽいか
2024/12/27(金) 01:04:16.05ID:EZRMiF6C
既に普及したTV規格を改変するのは10年単位の期間がかかるからな
2024/12/27(金) 13:22:37.98ID:NU09mNBS
そしていざ切り替えとなった時には今更HECVかよってなるのかもな
2024/12/27(金) 13:23:32.65ID:NU09mNBS
すまんHEVCね
2024/12/27(金) 15:15:26.35ID:+FdQppYc
レベルが高すぎてなんか間違ってても分からん
2024/12/27(金) 23:31:59.42ID:m7Yy+o6o
目に見えて画質変わる地デジ化ですら大変だったのに、テレビ離れの今あれだけの大事業同じことできるとは思えん
2024/12/28(土) 01:46:02.83ID:jckRIn/I
>>869
今考えてる爺達の気持ちが書いてある
2024/12/28(土) 14:37:36.15ID:wCP2jahL
HEVCってh.265じゃなかっけ?
h.265ならAV1にした方がよさげな気がするけど
不可逆圧縮とかの観点なんだろうかが
2024/12/28(土) 16:02:41.80ID:JdFMLUNX
HEVCは4K8K BS放送で使っているから、2K BSをHEVCにしても
既存の4K8Kチューナで対応できるということじゃないかな
874login:Penguin
垢版 |
2024/12/28(土) 16:22:47.24ID:avhhcSef
たしか家電業界がmpeg系を立ち上げたから、現状av1は選択肢に無いだろうな
av1はmpegのライセンス料とゴタゴタを回避する為にgoogle他が立ち上げたはず
当初av1が遅かったのもmpegの特許回避のせいだったような
とは言え、テレビでYouTubeが見れるような時代だし、いずれその辺の対立も消えるかも
2024/12/28(土) 18:32:54.10ID:wGUEBQVH
次世代地デジ放送ではH.266/VVCだから既存4K機器救済策なんだろうな

N100DC-ITXにMLT8で6ch全録設定してみたけどCPU余裕あるな
なぜか7ch以上にするとmirackがエラー起こすが
PT4Kも同居させて録画は出来るんだけどMMirakurunが入れ方わからん
2024/12/28(土) 23:25:21.13ID:8qVkm18D
av1のエンコード/デコードはソフトウェアだと遅すぎるし、ハードウェアはそれほど普及してないからじゃないの
2024/12/29(日) 02:47:28.76ID:JRuZ4xpG
まあやるのはいいんだけど
新旧の遷移期間中、帯域たりるんかいな?
2024/12/31(火) 01:10:29.80ID:jlLrTXz/
mirakc-timeshift-fs使ってる人居る? ちゃんと使えてる?
以下の繰り返しになる
WARN mirakc_core::config: Disabled config="jobs.sync-clocks"
WARN mirakc_core::config: Disabled config="jobs.update-schedules"
INFO mirakc_core::config: Loaded config_path="/etc/mirakc/config.yml"
INFO mirakc_timeshift_fs::filesystem: Create a timeshift filesystem fs_config.uid=0 fs_config.gid=0 fs_config.start_time_prefix=false
INFO fuser::session: Mounting /mnt
Error: IoError(Custom { kind: Other, error: "fusermount3: mount failed: Permission denied\n" })
2024/12/31(火) 10:12:53.57ID:+zWmn8OE
mirakc以前に単純に外付けストレージが上手くマウント出来てないだけじゃないの
2025/01/01(水) 00:45:27.37ID:krqa02dG
わかりやすいエラー出てるんだから少しくらい何かしてから聞いてほしい
2025/01/01(水) 02:31:45.66ID:M29cWIj5
/mntとかタイムシフトファイルのパーミッションばかり見てましたが
# In addition, you might have to run with no apparmor security profile
# in order to avoid "fusermount3: mount failed: Permission denied".
#security_opt:
# - apparmor:unconfined
これでした……失礼しました
2025/01/01(水) 21:02:02.10ID:fJQPwI44
さっきpt1_drvがFedora 41のkernel-6.12.6でビルドに失敗したので
動くようにするパッチを作成

https://pastebin.com/4vaXLDMt
2025/01/02(木) 14:14:03.17ID:F+sz65Mu
>>788の者だけど
12月に契約開始していたつもりが、1月からだったっぽく、まだ様子を見ています。
ご加入記念月ってのが今月だそうで…。
多分、昔11年ほど前にemm更新できなかった時に一度解約して入り直してまでして更新電波を得ようと慌てた名残ですね…忘れてました。
2025/01/03(金) 17:55:53.75ID:95ca2PVX
EPGStationの録画関連の通知今迄LINEで受け取ってたけどLINE Notify終了するからdiscordに変えるかな
2025/01/04(土) 11:10:03.32ID:z+jOwp/E
LINE Notifyの代替え公式アカウントだと無料枠200通では厳しい
2025/01/04(土) 15:47:31.73ID:oqHbR14o
そうなんだよね、1日当たり6通までだな
discordが無料枠で無制限ならそっちに移行しようかな
2025/01/09(木) 22:04:00.55ID:xuMyQHdf
明日早朝からBS再編なのかな
録画予約入ってて設定するタイミングがない
2025/01/10(金) 11:50:02.30ID:Yv0XDEft
PX-W3U4/PE4を公式のLinuxドライバーで使っている人向けの情報になります

PX-W3U4/W3PE4+CentOS7-1708_64bit_kernel3.10.0-693

■usb-px4.ko

BS10スターchは変更なし(スター・チャンネル2と周波数・TSID・チャンネル番号とも同じため)

BS10

周波数変更 0x00B549D8(11880920)→0x00B70B60(11996000)
4:9D48 D8 60
4:9D49 49 0B
4:9D4A B5 B7

TSID変更 0x4091→0x48F3
4:9D58 91 F3
4:9D59 40 48

チャンネル番号変更 BS09_1→BS15_3
4:AC38 04 07
4:AC3C 01 03


■recpt1/pt1_dev.h

{ 7, CHTYPE_SATELLITE, 1, "201"}, /* 201ch:スター・チャンネル2 */
{ 4, CHTYPE_SATELLITE, 1, "200"}, /* 200ch:スター・チャンネル1 */
↓
{ 7, CHTYPE_SATELLITE, 1, "201"}, /* 201ch:BS10スターch */
{ 7, CHTYPE_SATELLITE, 3, "200"}, /* 200ch:BS10 */
2025/01/10(金) 11:50:52.35ID:Yv0XDEft
なお、本来昨年のスターチャンネル2・3閉局時に
スターチャンネル(現BS10スターch)の設定を変更しておくべきだったのですが、
recpt1がスターチャンネル2の物理チャンネル番号でスターチャンネルを選局できていたため、
設定変更の必要性に気づかないままになっていました
そのため、epgrec UNAでは問題ありませんでしたが、
3ケタのサービスIDではスターチャンネルを録画できない状態になっていたようです

今回この問題の解消にあたり、サービスIDを維持してそれ以外の設定を現状に合わせる方向で作業しています
昨年のスターチャンネル2・3閉局時に何らかの設定変更をされていた方は、この点ご注意ください
2025/01/10(金) 22:33:02.26ID:cFmIZyTb
mirakcでrecpt1使ってるけどBSのチャンネル指定形式がBSxx_yだとルックアップpt1_dev.hのテーブルを使わないみたいだから
ビルドし直さなくていいって事だよな
2025/01/11(土) 05:33:47.84ID:CXM6xq0Y
>>883
続報です。
本日、日付が変わった瞬間から視聴不能となりました。
>>786
の方法では処理されないようです。
TVに刺して10分ほどで映るようにはなりました。
また時間がある時に色々やってみます。
2025/01/11(土) 08:08:28.30ID:innSqktr
チャンネルスキャンだけでは対応できないのは勘弁してほしい
893login:Penguin
垢版 |
2025/01/12(日) 11:44:43.09ID:UTaqv9hP
ラズパイの録画環境でBS10対応してたらHDD巻き込んで固まっちまったw
再起動して確かめるもHDDエラー出てアクセス出来ないんでやんの
リカバリしたけど肝心の録画データがいくつかが逝ってしまった…
残って欲しかった龍の歯医者 後編しか救出出来なかったw
前編飛んじまってどーすんのさって話 はぁ、正月早々キツいわ
早めにラズパイのtsファイルを退避しとけば良かったorz
2025/01/12(日) 13:10:23.49ID:UxbB35PN
ハードオフで見つけたジャンク3000円のN100中華ミニpcにos 入れて負荷かけても問題ないからこれで録画鯖作り直す
2025/01/12(日) 13:49:37.77ID:6JSsw5jM
中華のN100 PCは廃熱を犠牲にしてでもコンパクト化に振ってるんで、そこらはできる限りどうにかしたほうがいい。
録画鯖は、結構過酷だしな。(日に何度もON/OFF、動いて当たり前なインフラ扱いなど)
896login:Penguin
垢版 |
2025/01/12(日) 14:30:16.12ID:nwI5QgAH
N100の録画鯖ならずっと起動したままでいいんじゃないの
録画終わるたびにスリープとかトラブルの確率増やすだけだし
2025/01/12(日) 18:39:58.65ID:fOBKigco
UbuntuだとKernel6系と相性悪いんだよなぁ・・・
やっぱり20.04の方が良いのかしら・・・
2025/01/12(日) 19:56:18.83ID:KOYHMTNO
CobaltC??なんてのがあるのね
2025/01/13(月) 16:12:07.71ID:UlS9nPrV
MirakurunがBSCSのロゴ拾ってきてくれないんだけどなんかオプション必要だったりする?
900login:Penguin
垢版 |
2025/01/13(月) 20:23:17.38ID:xtULcoqw
Mirakurunは勝手にロゴ取得してくれるはずだけどなぜが全然取ってくれない時あるね
ロゴファイルはあるのに反映されないことも
なのでそういう場合はservices.jsonを編集して反映させてるわ
ロゴファイルが無い場合はTVTestから持ってくる
901login:Penguin
垢版 |
2025/01/14(火) 09:50:32.73ID:x+2ynPO9
>>899
NHK BSを1時間位録画しても出てこない?
2025/01/14(火) 19:18:45.99ID:np/1ICEg
mirakurunは更新とまったままなので頻繁にメンテナンスしてるmirakc に切り替えたわ
2025/01/15(水) 20:20:23.01ID:xRn2RQX/
へー
2025/01/16(木) 22:00:56.69ID:QPW7JTDi
>>901
これやったらできたわthx
2025/01/20(月) 16:38:02.89ID:4NgMlzMO
HDDを18TBに拡張したんだけど、EPGStationのストレージ画面の表示が16TBにしかなりません
(ext4のinodeテーブルを64bitに拡張済み)
そういうもんですか?
906905
垢版 |
2025/01/20(月) 16:45:12.75ID:4NgMlzMO
>>905
dfコマンドでは18TBと表示されているので、全容量で認識はされています。
2025/01/20(月) 17:37:09.84ID:TyqbtF3A
>>> 18 / 1.024 / 1.024 / 1.024
16.763806343078613
2025/01/20(月) 17:38:18.67ID:TyqbtF3A
じゃない、TBだから
>>> 18 / 1.024 / 1.024 / 1.024 / 1.024
16.37090463191271
レス数が900を超えています。1000を超えると表示できなくなるよ。

ニューススポーツなんでも実況